Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006778opensim[GRID] Other Servicepublic2013-09-25 18:002014-04-23 12:16
Reportersmxy 
Assigned ToBlueWall 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006778: Profile service spitting out an error for some HG visitors.
Description20:55:25 - [UTIL]: Continuing after async_call_method thread terminated with exception Absolute URI is too short at System.Uri.Parse (UriKind kind, System.String uriString) [0x00020] in /root/install/mono-3.1.0/mono/mcs/class/System/System/Uri.cs:1344
  at System.Uri.ParseUri (UriKind kind) [0x00000] in /root/install/mono-3.1.0/mono/mcs/class/System/System/Uri.cs:1206
  at System.Uri..ctor (System.String uriString, Boolean dontEscape) [0x00059] in /root/install/mono-3.1.0/mono/mcs/class/System/System/Uri.cs:230
  at System.Uri..ctor (System.String uriString) [0x00000] in /root/install/mono-3.1.0/mono/mcs/class/System/System/Uri.cs:128
  at System.Net.WebRequest.Create (System.String requestUriString) [0x00011] in /root/install/mono-3.1.0/mono/mcs/class/System/System.Net/WebRequest.cs:283
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule.JsonRpcRequest (OpenMetaverse.StructuredData.OSD& data, System.String method, System.String uri, System.String jsonId) [0x00093] in /home/ste/grid/src/coreOS/build/build-r23693/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:1298
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule.GetImageAssets (UUID avatarId) [0x0006b] in /home/ste/grid/src/coreOS/build/build-r23693/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:1031
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule+<HandleOnMakeRootAgent>c__AnonStorey16.<>m__26 (System.Object ) [0x00001] in /home/ste/grid/src/coreOS/build/build-r23693/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:178
  at OpenSim.Framework.Util+<FireAndForget>c__AnonStorey5.<>m__E (System.Object o) [0x00007] in /home/ste/grid/src/coreOS/build/build-r23693/OpenSim/Framework/Util.cs:1839
Additional InformationSeen twice today. Update: looks like I'm seeing it most times an HG visitor arrives.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version3.2
Viewer
Attached Files

- Relationships
has duplicate 0006798closedTeravus core profile related red spew when some HG visitors arrive 

-  Notes
(0025347)
smxy (reporter)
2014-03-03 15:36

This is still an issue in current Dev Master as of today:

18:32:21 - [UTIL]: Continuing after async_call_method thread terminated with exception Absolute URI is too short at System.Uri.Parse (UriKind kind, System.String uriString) [0x00020] in /opt/install/mono-3.2.3/mono-3.2.3/mcs/class/System/System/Uri.cs:1344
  at System.Uri.ParseUri (UriKind kind) [0x00000] in /opt/install/mono-3.2.3/mono-3.2.3/mcs/class/System/System/Uri.cs:1206
  at System.Uri..ctor (System.String uriString, Boolean dontEscape) [0x00059] in /opt/install/mono-3.2.3/mono-3.2.3/mcs/class/System/System/Uri.cs:230
  at System.Uri..ctor (System.String uriString) [0x00000] in /opt/install/mono-3.2.3/mono-3.2.3/mcs/class/System/System/Uri.cs:128
  at System.Net.WebRequest.Create (System.String requestUriString) [0x00011] in /opt/install/mono-3.2.3/mono-3.2.3/mcs/class/System/System.Net/WebRequest.cs:275
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule.JsonRpcRequest (OpenMetaverse.StructuredData.OSD& data, System.String method, System.String uri, System.String jsonId) [0x00094] in /home/ste/grid/src/coreOS/build/build-r24394/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:1365
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule.GetImageAssets (UUID avatarId) [0x00070] in /home/ste/grid/src/coreOS/build/build-r24394/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:1098
  at OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule+<HandleOnMakeRootAgent>c__AnonStorey19.<>m__2A (System.Object ) [0x00012] in /home/ste/grid/src/coreOS/build/build-r24394/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:178
  at OpenSim.Framework.Util+<FireAndForget>c__AnonStorey6.<>m__F (System.Object o) [0x0000e] in /home/ste/grid/src/coreOS/build/build-r24394/OpenSim/Framework/Util.cs:1910
(0025788)
smxy (reporter)
2014-04-15 16:55

This is still an issue:

19:53:20 - [UTIL]: Util STP threadfunc 238012 terminated with error System.UriFormatException: Absolute URI is too short
  at System.Uri.Parse (UriKind kind, System.String uriString) [0x00020] in /root/install/mono-3.2.8/mono-3.2.8/mcs/class/System/System/Uri.cs:1344
  at System.Uri.ParseUri (UriKind kind) [0x00000] in /root/install/mono-3.2.8/mono-3.2.8/mcs/class/System/System/Uri.cs:1206
  at System.Uri..ctor (System.String uriString, Boolean dontEscape) [0x00059] in /root/install/mono-3.2.8/mono-3.2.8/mcs/class/System/System/Uri.cs:230
  at System.Uri..ctor (System.String uriString) [0x00000] in /root/install/mono-3.2.8/mono-3.2.8/mcs/class/System/System/Uri.cs:128
  at System.Net.WebRequest.Create (System.String requestUriString) [0x00011] in /root/install/mono-3.2.8/mono-3.2.8/mcs/class/System/System.Net/WebRequest.cs:275
  at OpenSim.Framework.Servers.HttpServer.JsonRpcRequestManager.JsonRpcRequest (OpenMetaverse.StructuredData.OSD& data, System.String method, System.String uri, System.String jsonId) [0x00094] in /home/ste/grid/src/coreOS/build/build-r24617/OpenSim/Framework/Servers/HttpServer/JsonRpcRequestManager.cs:165
  at OpenSim.Region.CoreModules.Avatar.UserProfiles.UserProfileModule.GetImageAssets (UUID avatarId) [0x00075] in /home/ste/grid/src/coreOS/build/build-r24617/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:1129
  at OpenSim.Region.CoreModules.Avatar.UserProfiles.UserProfileModule+<HandleOnMakeRootAgent>c__AnonStorey0.<>m__0 (System.Object ) [0x00012] in /home/ste/grid/src/coreOS/build/build-r24617/OpenSim/Region/CoreModules/Avatar/UserProfiles/UserProfileModule.cs:181
  at OpenSim.Framework.Util+<FireAndForget>c__AnonStorey0.<>m__1 (System.Object o) [0x00091] in /home/ste/grid/src/coreOS/build/build-r24617/OpenSim/Framework/Util.cs:2148
(0025806)
BlueWall (administrator)
2014-04-19 19:29

fixed in 63fd027494cb796080d2a8fccf95c9e6348d7142
(0025876)
smxy (reporter)
2014-04-23 12:16

I've not seen the problem since the fix was applied. Thanks!

- Issue History
Date Modified Username Field Change
2013-09-25 18:00 smxy New Issue
2013-09-25 18:18 smxy Additional Information Updated View Revisions
2013-10-15 22:20 smxy Relationship added has duplicate 0006798
2014-03-03 15:36 smxy Note Added: 0025347
2014-04-15 16:55 smxy Note Added: 0025788
2014-04-19 19:29 BlueWall Note Added: 0025806
2014-04-19 19:29 BlueWall Status new => resolved
2014-04-19 19:29 BlueWall Resolution open => fixed
2014-04-19 19:29 BlueWall Assigned To => BlueWall
2014-04-23 12:16 smxy Mono Version Other => 3.2
2014-04-23 12:16 smxy Note Added: 0025876
2014-04-23 12:16 smxy Status resolved => closed
2014-04-23 12:16 smxy Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker