Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006737opensim[REGION] OpenSim Corepublic2013-08-12 12:542013-12-27 13:18
ReporterRichardus Raymaker 
Assigned Tojustincc 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0006737: admin load_heightmap and admin_save_heightmap broken (region_id or regionid or .. ) ?
DescriptionAm trying to implement admin load_heightmap , but what i do region_id or regionid
its keep generating this error on console. and i dont see anythinh wrong in my code.
testing on 0.7.5 release.

13:29:46 - [RADMIN]: Load height maps request started
13:29:46 - [RADMIN]: Method admin_load_heightmap failed. Exception missing string parameter regionid
at OpenSim.ApplicationPlugins.RemoteController.RemoteAdminPlugin.CheckStringParameters(Hashtable requestData, Hashtable responseData, String[] param)

13:30:02 - [RADMIN]: Load height maps request started
13:30:02 - [RADMIN]: Method admin_load_heightmap failed. Exception no region_name or region_id given
at OpenSim.ApplicationPlugins.RemoteController.RemoteAdminPlugin.CheckRegionParams(Hashtable requestData, Hashtable responseData)

if i try the suggested region_name i get the error like this, so at the ned you keep running rounds.

13:33:47 - [RADMIN]: Method admin_load_heightmap failed. Exception missing string parameter regionid
at OpenSim.ApplicationPlugins.RemoteController.RemoteAdminPlugin.CheckStringParameters(Hashtable requestData, Hashtable responseData, String[] param)
_______________________________________________
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Filespatch file icon Patch-fixing-RAdmin-parameter-for-load-and-save-heightmap.patch [^] (3,571 bytes) 2013-08-16 01:51 [Show Content]

- Relationships

-  Notes
(0024271)
Michelle Argus (reporter)
2013-08-12 13:09

Seems we forgot to remove the string check for regionid. Currently both parameters regionid AND region_id/region_name need to be used.

I will post a patch on the weakend fixing the issue
(0024278)
Michelle Argus (reporter)
2013-08-16 01:57

Added patch removing regionid as specified by wiki
(0024279)
justincc (administrator)
2013-08-16 16:46

Thanks Michelle. Committed as git master 14ae89d. I didn't commit this patch directly since I had to replace the tabs with spaces for OpenSimulator.
(0024923)
Richardus Raymaker (reporter)
2013-12-27 13:18

Tested with Git version 540fa84-r/24153 and works

- Issue History
Date Modified Username Field Change
2013-08-12 12:54 Richardus Raymaker New Issue
2013-08-12 13:09 Michelle Argus Note Added: 0024271
2013-08-16 01:51 Michelle Argus File Added: Patch-fixing-RAdmin-parameter-for-load-and-save-heightmap.patch
2013-08-16 01:57 Michelle Argus Note Added: 0024278
2013-08-16 01:57 Michelle Argus Status new => patch included
2013-08-16 16:46 justincc Note Added: 0024279
2013-08-16 16:46 justincc Status patch included => resolved
2013-08-16 16:46 justincc Resolution open => fixed
2013-08-16 16:46 justincc Assigned To => justincc
2013-12-27 13:18 Richardus Raymaker Note Added: 0024923
2013-12-27 13:18 Richardus Raymaker Status resolved => closed
2013-12-27 13:18 Richardus Raymaker Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker