Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006719opensim[REGION] OpenSim Corepublic2013-07-31 09:012014-01-25 10:38
Reporterkenvc 
Assigned Tokenvc 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformNAOSNAOS VersionNA
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006719: Need config.ini option to optionally make sit work as in older opensim versions to encourage people to update their simulators
DescriptionThe main reason this is needed is because there are a lot of sim operators that are NOT and will NOT upgrade their opensim software simply because the newer software uses a different sit position. They have a ton of objects on their sims that are apparently no mod that have sit scripts written for the older incorrect opensim sit position and the sit position is incorrect with the new correct opensim sit position.

I personally do not understand the logic for not updating their sit scripts and using the latest opensim software considering all the recent improvements, but this is what is happening. Having older sim software on the grid creates attachment and freeze up issues for all of us when teleporting between sims that are still running old software.

Maybe add new options somewhere in opensim.ini to allow adjusting the sit position in any direction it might need to go to match it up with the older sit position or even match it better with the sit position in SL if needed.
Steps To ReproduceTeleport from a sim running the latest dev master to a sim rumming older code such as the sim called COOL.
TagsNo tags attached.
Git Revision or version numberr/23389
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentUnknown
Mono VersionNone
ViewerFS, Sing, Imp
Attached Files

- Relationships

-  Notes
(0025058)
kenvc (reporter)
2014-01-25 10:38

This is not an issue for me, but it was for some who wrote a bunch of scripts for the old sit method and don't want to change all their builds. Since the issue doesn't not seem to interest and of the devs, I'm going to mark it as resolved but not fixed to get it cleared out.
(0025059)
kenvc (reporter)
2014-01-25 10:38

This is not an issue for me, but it was for some who wrote a bunch of scripts for the old sit method and don't want to change all their builds. Since the issue doesn't not seem to interest and of the devs, I'm going to mark it as resolved and not fixed.

- Issue History
Date Modified Username Field Change
2013-07-31 09:01 kenvc New Issue
2013-07-31 09:08 kenvc Physics Engine BasicPhysics => ODE
2013-08-28 22:04 kenvc Summary Need config.ini option to optionally make the sits work as they did in older versions of opensim. => Need config.ini option to optionally make sit work as in older opensim versions to encourage people to update their simulators
2013-08-28 22:04 kenvc Description Updated View Revisions
2014-01-25 10:38 kenvc Note Added: 0025058
2014-01-25 10:38 kenvc Status new => resolved
2014-01-25 10:38 kenvc Fixed in Version => master (dev code)
2014-01-25 10:38 kenvc Resolution open => fixed
2014-01-25 10:38 kenvc Assigned To => kenvc
2014-01-25 10:38 kenvc Note Added: 0025059
2014-01-25 10:38 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker