Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006707opensim[REGION] Script Functionspublic2013-07-15 09:002015-03-29 07:50
ReporterAnge Menges 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformLINUXOSUbuntu 64 bitsOS Version12.10
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006707: Attachments don't receive collision events when an avatar collides with something
Descriptionhttp://lslwiki.net/lslwiki/wakka.php?wakka=collisions [^]
According to the wiki, attachments will not trigger collision events if the object itself collides with something else. However, if the avatar collides with the object, the collision event is triggered.
It seems that this part is not implemented in opensim.
Steps To ReproduceJust attach to your avatar an objet with a collision start test script.
Additional InformationIn fact my aim is to detect collisions on a NPC with an attachment, I suppose it should work if working with an avatar.
TagsNo tags attached.
Git Revision or version number OSgrid OpenSimulator 0.7.6.dev.c358d5d
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
Viewer
Attached Files

- Relationships

-  Notes
(0024468)
Gwyneth Llewelyn (reporter)
2013-10-14 17:05
edited on: 2013-10-16 13:51

I've been actively tracking this down since I need the same functionality as Ange — SL definitely sends collision events to attachments while OpenSim does not.

This has been discussed on opensim-users: http://opensim-users.2152040.n2.nabble.com/collision-detection-for-attachments-td7579692.html [^]

I managed to at least get attachments detect collisions with other avatars and physics-enabled prims. However, I'm still stumped at figuring out how to receive collision events for non-physical objects, just like SL does. But the work is under way to figure this out...

(0027953)
Da Chrome (reporter)
2015-03-28 13:23
edited on: 2015-03-28 13:23

This is a thing. Using Bullet physics and a Windows install of OS 0.8.1, collison_start is not triggered on scripted attachments when an avatar collides with a nonphysics object. Workarounds are of the "don't raise the bridge, lower the river" type, and both sap performance and perform haphazardly. It would be nice if someone could implement this so it works like it does in SL.


- Issue History
Date Modified Username Field Change
2013-07-15 09:00 Ange Menges New Issue
2013-10-14 17:05 Gwyneth Llewelyn Note Added: 0024468
2013-10-16 13:51 Gwyneth Llewelyn Note Edited: 0024468 View Revisions
2015-03-28 13:23 Da Chrome Note Added: 0027953
2015-03-28 13:23 Da Chrome Note Edited: 0027953 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker