Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006681opensim[GRID] Messaging Servicepublic2013-06-16 10:222013-12-12 15:59
Reporterkcozens 
Assigned To 
PrioritylowSeverityminorReproducibilityalways
Statuspatch feedbackResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006681: Missing default for name of mute list module
DescriptionThe OpenSim.ini.example file shows a default value for the name of the mute list module. I configured a grid to use this default and found offline messaging didn't work until I set MuteListModule in my OpenSim.ini file. A check of the code shows that the value defaults to None and not MuteListModule as indicated by the example .ini file.

I have attached a patch to fix this issue.
TagsNo tags attached.
Git Revision or version number694c4bcbb671338263802457bb5a384c4fe44d26
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Windows
Mono VersionNone
Viewer
Attached Filespatch file icon 0003-Set-default-name-for-mute-list-module-as-shown-in-Op.patch [^] (1,075 bytes) 2013-06-16 10:22 [Show Content]

- Relationships

-  Notes
(0024144)
justincc (administrator)
2013-06-26 15:56

I suspect the proper behaviour is to correct the [Messaging] section in OpenSim.ini.example to match the module defaults rather than the other way around. I would not currently expect these modules to be active by default - OfflineMessageModule also defaults to "None".
(0024251)
kcozens (administrator)
2013-08-06 09:26

The default values I referred to in the INI files are only in the comments. The mute list module would only become active when the module name is set AND a URL is specified. I was just following what appeared to be a pattern I saw in other modules. If the INI file(s) should be updated, I'm open to that.
(0024863)
kcozens (administrator)
2013-12-12 15:59
edited on: 2013-12-12 16:00

The comments in OpenSim.ini.example for 0.7.6-post-fixes indicates MuteListeModule is the default value for the MuteListModule setting. The code appears to have a default value is "None" which makes this patch needed to make code match what is stated in the comments.


- Issue History
Date Modified Username Field Change
2013-06-16 10:22 kcozens New Issue
2013-06-16 10:22 kcozens File Added: 0003-Set-default-name-for-mute-list-module-as-shown-in-Op.patch
2013-06-16 10:26 kcozens Assigned To => kcozens
2013-06-16 10:26 kcozens Status new => patch included
2013-06-26 15:56 justincc Note Added: 0024144
2013-06-26 15:56 justincc Status patch included => patch feedback
2013-08-06 09:23 kcozens Assigned To kcozens =>
2013-08-06 09:26 kcozens Note Added: 0024251
2013-12-12 15:59 kcozens Note Added: 0024863
2013-12-12 16:00 kcozens Note Edited: 0024863 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker