Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006678opensim[REGION] Physics Enginespublic2013-06-15 14:342014-07-29 13:42
Reportervegaslon 
Assigned ToRobert Adams 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006678: BulletSim -- Implementation of Linear Deflection
DescriptionThis patch implements Linear Deflection for vehicles in BulletSim. Standard Test of this Feature is having a linear deflection efficiency and timescale set to reasonable numbers and dropping vehicles from a height. Expected behavior is that the vehicle will deflect the gravity velocity forwards so that the vehicle moves forward while falling.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Filespatch file icon 0001-BulletSim-Implementation-of-Linear-Deflection-it-is-.patch [^] (4,499 bytes) 2013-06-15 14:34 [Show Content]

- Relationships

-  Notes
(0024102)
Robert Adams (administrator)
2013-06-16 20:44

This patch is placing the in middle of ComputeLinearVelocity. It would fit the code pattern better if there was a separate ComputeLinearDeflection routine. Also, the SortedClampInRange should go down with the ClampInRange routine.

Mind if I rearrange this code a bit before inclusion?
(0024104)
vegaslon (reporter)
2013-06-17 04:38

You May do what needs to be done. This is your project and you need to be able to know exactly what is going on. I have put it this way to save constantly computing into the vehicle frame and back out of it again since all other linear adjustments are not based on the vehicle frame.
(0024165)
Robert Adams (administrator)
2013-06-30 16:17

patch has been included.

- Issue History
Date Modified Username Field Change
2013-06-15 14:34 vegaslon New Issue
2013-06-15 14:34 vegaslon File Added: 0001-BulletSim-Implementation-of-Linear-Deflection-it-is-.patch
2013-06-15 14:35 vegaslon Status new => patch included
2013-06-16 20:09 Robert Adams Assigned To => Robert Adams
2013-06-16 20:09 Robert Adams Status patch included => assigned
2013-06-16 20:44 Robert Adams Note Added: 0024102
2013-06-17 04:38 vegaslon Note Added: 0024104
2013-06-30 16:17 Robert Adams Note Added: 0024165
2013-06-30 16:17 Robert Adams Status assigned => resolved
2013-06-30 16:17 Robert Adams Fixed in Version => master (dev code)
2013-06-30 16:17 Robert Adams Resolution open => fixed
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker