Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006670opensim[REGION] Physics Enginespublic2013-06-10 09:042014-07-29 13:42
Reporteraiaustin 
Assigned ToRobert Adams 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version8
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006670: [BULLETSIM SHAPE] Sculpt prim with blank texture causes Mesh failed to fetch asset.
Description16:35:26 - [BULLETSIM SHAPE MESH]: All mesh triangles degenerate. Prim Planet Earth/f00f4e7d-feca-4893-8a36-18f94a41eb2a at <223.9525, 207.3283, 53.69278> in BulletSim/Openvue
16:35:26 - [BULLETSIM SHAPE]: Mesh failed to fetch asset. obj=Planet Earth/f00f4e7d-feca-4893-8a36-18f94a41eb2a, texture=5748decc-f629-461c-9a36-a35a221fe21f
16:35:26 - [BULLETSIM SHAPE MESH]: All mesh triangles degenerate. Prim Atmosphere/45fd1e6b-b777-4aa4-b9e1-4a27068b08a3 at <223.9525, 207.3283, 53.69278> in BulletSim/Openvue
16:35:26 - [BULLETSIM SHAPE]: Mesh failed to fetch asset. obj=Atmosphere/45fd1e6b-b777-4aa4-b9e1-4a27068b08a3, texture=5748decc-f629-461c-9a36-a35a221fe21f

This turned out to be two simple spheres but created as Sculpted objects for reasons of applying textures in a particular orientation.
Steps To ReproduceCreate a prim.
Make its type Sculpt.
Choose blank as the texture for the sculpty shape - making a sphere.

Restart OpenSim.exe to observe the mesh error.
TagsNo tags attached.
Git Revision or version numberr/22855
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows32
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0024057)
Misterblue (reporter)
2013-06-10 10:04

Not sure what you are describing here. Are you saying that you take a sphere and use a blank texture (all values the same) as the sculpt map? Doesn't that define a sculpty that has all vertices equal?

The BulletSim error of "failed to fetch asset" is misleading after an "all mesh triangles degenerate". The latter error says BulletSim did not find any non-zero width triangles in the mesh definition (could happen if all vertices were equal) and thus there is no usable physical mesh. BulletSim thus says the meshing failed and, so as not to keep fetching the asset over and over, it marks the asset fetch as 'failed'. It would be a little less confusing if there was another 'failed' state for 'meshing failed'.
(0024059)
aiaustin (developer)
2013-06-10 12:09

I am not sure either now... as the object definition did not make much sense, and I agree that all vertices the same sound like its not much of a shape!

The source was an "Planet Earth" object from UCI Grid (Diva Canto) some time ago which had a prim object defined as of type "Sculpt" with its sculpt texture set to blank... and given an extent somehow with taper X = 0.0 and taper Y = 1.0 which is some automagical way made a sphere! Not sure why it was done that way rather than just being simply of type "Sphere" in the first place. Maybe it was a simple sphere originally and even shifted its properties at some stage over the years on our grid (running continuously for 6 years) for all I know. There was some jiggery-pokery going on to get the Earth surface texture to be the right orientation and aligned with the rotating planet animation. But with some fiddling about I got the rotation and the texture right using rotation on the object and all sorts of rotations and flips on the texture! So I got rid of this warning by getting rid of the offending sculpty prims and use of the default UUID blank texture map.

But still... it did show as errors on all regions that had this Planet Earth sculpt object when I converted from ODE to BulletSim and the UUIID it said it could not find is the standard blank texture UUID which it definitely should have found. So at the least the error message is not helpful at all. So treat this "bug" as just a note in case its something the BulletSim developers want to note.
(0024085)
Robert Adams (administrator)
2013-06-11 17:26

Added new meshing failed code so differentiation between failed because of asset not found and failed because of meshing failure. Added/changed log messages so they state which error actually happened.

- Issue History
Date Modified Username Field Change
2013-06-10 09:04 aiaustin New Issue
2013-06-10 09:15 aiaustin Summary [BULLETSIM SHAPE] Scupt prim with blabk texture causes Mesh failed to fetch asset. => [BULLETSIM SHAPE] Sculpt prim with blank texture causes Mesh failed to fetch asset.
2013-06-10 09:15 aiaustin Steps to Reproduce Updated View Revisions
2013-06-10 10:04 Misterblue Note Added: 0024057
2013-06-10 10:21 Robert Adams Assigned To => Robert Adams
2013-06-10 10:21 Robert Adams Status new => assigned
2013-06-10 12:09 aiaustin Note Added: 0024059
2013-06-10 12:10 aiaustin Severity minor => tweak
2013-06-11 17:26 Robert Adams Note Added: 0024085
2013-06-11 17:26 Robert Adams Status assigned => resolved
2013-06-11 17:26 Robert Adams Fixed in Version => master (dev code)
2013-06-11 17:26 Robert Adams Resolution open => fixed
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker