Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006659opensim[REGION] OpenSim Corepublic2013-06-06 04:592019-02-06 11:30
Reporteraiaustin 
Assigned Tomelanie 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version8
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006659: Upload -> Set Default Permissions does not work
DescriptionSetting the default upload permissions for group and next owner does not operate correctly.

Steps To ReproduceTested in Firestorm 4.4.0 OS version.

Use Inventory -> + Upload -> Set Default Upload Permissions to have all 5 items ticked.

Upload an image/texture.

Observe its permissions are anyone copy off, share with group off, no copy, no mod.. but transfer is permitted. Hence the default upload permissions are being ignored.
Additional InformationNote this works fine with the same viewer in Second Life.

please add reports here as comments for viewers where it does and does not work.
TagsNo tags attached.
Git Revision or version numberr/22834
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Windows
Mono VersionNone
ViewerFirestorm 4.4.0 OS
Attached Files

- Relationships

-  Notes
(0024005)
aiaustin (developer)
2013-06-06 07:01
edited on: 2013-06-06 07:02

The same problem occurs in

Firestorm 4.4.0 (33720) Apr 22 2013 02:49:33 (Firestorm-Release) with OpenSimulator support

Kirstens S19 1.19.4 (407) May 16 2013

Imprudence 1.4.0 beta 2 (Sep 8 2011 17:16:46)

(0030210)
Gavin Hird (reporter)
2016-04-24 06:40

and still in Kokua 4.0.2

I guess it has never been resolved.
(0030211)
Mandarinka Tasty (reporter)
2016-04-24 07:50

Hi. You do not need to worry about it. it works. to notice that, you need to relog.

So set default upload permissions: COPY, MOD, TRANSFER.

Next upload texture.In properties fo the uploaded texture, you can see: no copy, no mod, transfer. but when you relog and next, you look at properties of the texture, it will show you full permissions for next owner.

So it works and just viewer does not show it at once.
(0030212)
melanie (administrator)
2016-04-24 07:55

I believe this to be a merge artefact. Secondlife and old Opensim respected this setting but in Avination the choice was always "don't trust the viewer", so it was ignored by choice.
Although this behavior was removed in the merge, it appears some code remains that should be found and removed to make it work without relog.
(0030214)
Gavin Hird (reporter)
2016-04-24 07:59

It would be great if it could be fixed @melanie

I'll text if your method works a bit later Mandarinka. Thanks for the heads-up!
(0030239)
melanie (administrator)
2016-04-28 09:44

This is actually a symptom of a much more involved issue.

The viewer stores default next owner permissions for a number of different types ob objects. It does send part of this info to the server, but most is kept locally.

The server is only sent the new object preferences because creating a new object (rezzing a new prim) is the one thing that is entirely server side and therefore the server needs to know.

For all other uploads, the viewer sends it's preferred next owner perms along with the request, however, they are not stored anywhere but are discarded at that point.

0.8 was hardcoded to make all uploads full perm, while Avination, and therefore 0.9, is hardcoded to use SL's default, transfer only.
This is because at Avination we received numerous complaints from commercial creators who felt that a full perm default is too dangerous as they could inadvertently give away costly items with full perms set.

Neither the full perm nor the transfer only hardcoding are acceptable for 0.9 release, though.

I will change the code to store the viewer's requested new item perms and apply them on finishing the upload rather than discarding them and hardcoding arbitrary values.

This may not be done today :)
(0030242)
melanie (administrator)
2016-04-29 13:49

Fixing this was actually pretty involved, including changes to basic communications structures and new data paths to plumb the requested permissions from the viewer's point of contact to the reply occurring much later.
This issue should now be fixed and also puts to rest the discussion about default object permissions in opensim vs. defaults in SL. Effectively, there is no more default on the server side because it's now all under viewer control.
(0034543)
BillBlight (developer)
2019-02-06 11:30

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2013-06-06 04:59 aiaustin New Issue
2013-06-06 05:10 aiaustin Git Revision or version number => r/22834
2013-06-06 07:01 aiaustin Note Added: 0024005
2013-06-06 07:02 aiaustin Note Edited: 0024005 View Revisions
2016-04-24 06:40 Gavin Hird Note Added: 0030210
2016-04-24 07:40 aiaustin Steps to Reproduce Updated View Revisions
2016-04-24 07:50 Mandarinka Tasty Note Added: 0030211
2016-04-24 07:55 melanie Note Added: 0030212
2016-04-24 07:59 Gavin Hird Note Added: 0030214
2016-04-28 09:44 melanie Note Added: 0030239
2016-04-29 13:49 melanie Note Added: 0030242
2016-04-29 13:49 melanie Status new => resolved
2016-04-29 13:49 melanie Resolution open => fixed
2016-04-29 13:49 melanie Assigned To => melanie
2019-02-06 11:30 BillBlight Note Added: 0034543
2019-02-06 11:30 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker