Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006635opensim[REGION] OpenSim Corepublic2013-05-12 18:272013-06-07 15:58
Reporterdanbanner 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusconfirmedResolutionopen 
PlatformOpenSimOSWindows 7OS Version64bit
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006635: Textures do not persist applied to tube or torus with skew
DescriptionIt seems there is a problem applying textures to certain faces of prims that are skewed.
Steps To ReproduceCreate a tube, add 0.30 skew and select a texture. Looks good until you close the edit window and then faces 4 & 5 seem to revert back to plywood. Dragging a texture directly to the face seems to work until you 'force update'

Additional Informationhttp://i.imgur.com/hm8HmsC.png [^]
TagsNo tags attached.
Git Revision or version numberr/22657 (04f76af)
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Windows
Mono VersionNone
Viewerany
Attached Filespng file icon snapshot4.png [^] (1,134,690 bytes) 2013-06-07 15:54

- Relationships

-  Notes
(0023873)
danbanner (manager)
2013-05-12 18:46

Another interesting thing is if i apply the texture before i skew the object it stays.
(0024028)
justincc (administrator)
2013-06-07 15:58

I was able to reproduce this as you can see from snapshot4 but don't yet know the cause. Probably some issue with setting the prim faces for the skewed tube.

- Issue History
Date Modified Username Field Change
2013-05-12 18:27 danbanner New Issue
2013-05-12 18:46 danbanner Note Added: 0023873
2013-06-07 15:52 justincc File Added: snapshot3.png
2013-06-07 15:53 justincc File Deleted: snapshot3.png
2013-06-07 15:54 justincc File Added: snapshot4.png
2013-06-07 15:58 justincc Note Added: 0024028
2013-06-07 15:58 justincc Status new => confirmed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker