Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006592opensim[REGION] Scripting Enginepublic2013-03-28 21:542015-06-13 15:00
Reportermewtwo0641 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006592: Attach event not firing on detach
DescriptionVery recently the attach event seems to have quit working on detach.

default
{
    state_entry()
    {
       
    }
    
    attach(key id)
    {
        //This fires on attach but not on detach
        
        if(id != NULL_KEY)
            llOwnerSay("Attachment attached.");
            
        else if(id == NULL_KEY)
            llOwnerSay("Attachment detached.");
    }
}
Steps To Reproduce1. Create a new prim with the script from Description included inside it and then wear it.

2. Detach the prim.
    * The attach event does not fire.

3. Wear the prim again.
    * The attach event will fire both the llOwnerSay for detached and attached
TagsNo tags attached.
Git Revision or version numberCommit 23ae4c0 (r/22454)
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files

- Relationships
related to 0007345closedDiva Attach event does not trigger correctly on detach 

-  Notes
(0023733)
mewtwo0641 (reporter)
2013-03-30 03:45

This appears to be somewhat working now as of commit 9fee43 although it randomly fails at times especially after crossing over into a new region and then attempt to detach/attach.

Steps to reproduce:

1. Wear the attachment with the script in Description

2. Attempt to detach
    a. May or may not get a llOwnerSay stating that it was detached
    b. If the detach message does not show up try attaching it again and cross into another region and try detaching again. This seems to get it working again but the attach and detach messages don't seem to fire in the proper order.

3. If it worked on the first try; cross over into another region and it will probably quit working.
(0023978)
mewtwo0641 (reporter)
2013-06-01 05:55

Seems to be a non issue now in master.
(0025245)
jfhopkin (reporter)
2014-02-21 03:30

This problem exists (still? again?) as described.

Testing on OpenSim 0.8.0, in OSGrid's Sandbox Plaza.

(0025248)
JeffKelley (reporter)
2014-02-21 05:07

I was considering this normal, given the race condition between script execution and script derez :

« When detached to inventory, an object is only given limited time to execute its attach events. If these events are active when the script derezzes but have not completed, execution will finish when the object is next rezzed. » (LSL Wiki)
(0025249)
jfhopkin (reporter)
2014-02-21 05:14

Ah, I didn't know that. Thanks for the pointer.
(0025693)
mewtwo0641 (reporter)
2014-04-05 15:24
edited on: 2014-04-05 15:24

Hmm I am not seeing this personally; using the above test script. But I am also testing on a local setup on master. Perhaps in the OSGrid environment it's taking a bit too long to fire the attach() event?

(0028485)
AliciaRaven (manager)
2015-05-29 00:27

Fixed in master, see mantis http://opensimulator.org/mantis/view.php?id=7345 [^]

- Issue History
Date Modified Username Field Change
2013-03-28 21:54 mewtwo0641 New Issue
2013-03-30 03:45 mewtwo0641 Note Added: 0023733
2013-03-30 03:45 mewtwo0641 Relationship added related to 0006581
2013-04-02 01:21 mewtwo0641 Relationship deleted related to 0006581
2013-06-01 05:55 mewtwo0641 Note Added: 0023978
2013-06-01 05:55 mewtwo0641 Status new => resolved
2013-06-01 05:55 mewtwo0641 Fixed in Version => master (dev code)
2013-06-01 05:55 mewtwo0641 Resolution open => no change required
2013-06-01 05:55 mewtwo0641 Assigned To => mewtwo0641
2014-02-21 03:30 jfhopkin Note Added: 0025245
2014-02-21 03:30 jfhopkin Status resolved => patch feedback
2014-02-21 05:07 JeffKelley Note Added: 0025248
2014-02-21 05:14 jfhopkin Note Added: 0025249
2014-04-05 15:24 mewtwo0641 Note Added: 0025693
2014-04-05 15:24 mewtwo0641 Note Edited: 0025693 View Revisions
2015-05-25 17:07 AliciaRaven Relationship added related to 0007345
2015-05-29 00:27 AliciaRaven Note Added: 0028485
2015-05-29 00:27 AliciaRaven Status patch feedback => resolved
2015-05-29 00:27 AliciaRaven Resolution no change required => fixed
2015-06-13 15:00 Diva Status resolved => closed
2015-06-13 15:00 Diva Assigned To mewtwo0641 =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker