Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006584opensim[REGION] Physics Enginespublic2013-03-23 12:332013-05-14 12:24
Reporterkenvc 
Assigned ToRobert Adams 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Xeon quad core 16gbOSWindowsOS VersionServer 2012
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006584: Mega with Bulletsim increases in memory consumption until it eventually crashes. ODE is OK. Memory leak?
DescriptionI have a 36 sim mega that I have been using for testing with the latest Dev Master code almost every day. This one is connected to OSG. The memory use for this instance normally stays at about 1,400 and never goes over 1,500 when Bulletsim is not being used. When Bulletsim is being used, the memory consumed by this instance slowly increases to way over twice that amount and then the instance eventually crashes. It appears to be a memory leak in Bulletsim since the memory just keeps increasing. This is not nearly apparent when using Bulletsim on smaller regions, but it appears to still be happening but to a lesser extent.
Steps To ReproduceCreate a 36 sim mega with a fair amount of prims on it and compare the memory consumption over time with and without Bulletsim active. Look at the difference between ODE and Bulletsim memory use after 24 and 48 hours.
TagsNo tags attached.
Git Revision or version numberr22417
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows32
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0023712)
Robert Adams (administrator)
2013-03-28 11:06

I cannot duplicate this problem. I did find a mega-region terrain creation race condition which has been checked into master, but my memory is not growing.

I created a 36 sim mega-region and loaded it with 140K prims and >1K scripts. I flew around the region to verify its mega-ness. After sitting for over an hour, the memory is roughly the same.

Are you still seeing this problem?
(0023838)
kenvc (reporter)
2013-05-08 20:34

Robert,

I had to go back to ODE to eliminate this issue, but will enable Bulletsim on 2 megas and try it again and let you know.
(0023840)
kenvc (reporter)
2013-05-09 11:17
edited on: 2013-05-10 07:15

Robert,

Here are the test results with the latest Dev master (r/22711) after switching back to Bulletsim on 2 35 sims megas and running for about 24 hours:

1. So far no crashes, but I have 24gb more system memory than I had last time I tested this issue. It is using more memory than ODE, but does not seem to be creaping up over time nearly like it was.
2. The 2 megas are using about 10 times more CPU time at idle that with ODE.
3. The 2 megas show about twice as many threads present at idle in task manager that when using ODE.

(0023867)
kenvc (reporter)
2013-05-11 19:56

As of r22712 this issue appears to be fixed. CPU time is back to normal and seems to be very comparable to the same instances when using ODE.
(0023868)
kenvc (reporter)
2013-05-11 19:58

As of r22712 this issue appears to be fixed. CPU time is back to normal and seems to be very comparable to the same instances when using ODE.
(0023895)
kenvc (reporter)
2013-05-14 12:24

This has been fixed.

- Issue History
Date Modified Username Field Change
2013-03-23 12:33 kenvc New Issue
2013-03-23 12:34 kenvc Summary Mega using Bulletsim steadily increases in memory consumption until it eventually crashes. Memory leak? => Mega with Bulletsim increases in memory consumption until it eventually crashes. ODE is OK. Memory leak?
2013-03-23 13:01 kenvc Steps to Reproduce Updated View Revisions
2013-03-25 16:01 kenvc Git Revision or version number Latest Dev Master => r22417
2013-03-25 16:01 kenvc OS => Windows
2013-03-25 16:01 kenvc OS Version Windows 2012 => Server 2012
2013-03-25 16:01 kenvc Platform => Dual Xeon quad core 16gb
2013-03-25 16:08 Robert Adams Assigned To => Robert Adams
2013-03-25 16:08 Robert Adams Status new => assigned
2013-03-28 11:06 Robert Adams Note Added: 0023712
2013-05-08 20:34 kenvc Note Added: 0023838
2013-05-09 11:17 kenvc Note Added: 0023840
2013-05-10 07:15 kenvc Note Edited: 0023840 View Revisions
2013-05-11 19:56 kenvc Note Added: 0023867
2013-05-11 19:58 kenvc Note Added: 0023868
2013-05-11 19:58 kenvc Status assigned => resolved
2013-05-11 19:58 kenvc Fixed in Version => master (dev code)
2013-05-11 19:58 kenvc Resolution open => fixed
2013-05-14 12:24 kenvc Note Added: 0023895
2013-05-14 12:24 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker