Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006582opensim[REGION] OpenSim Corepublic2013-03-21 22:372014-07-29 13:42
Reportermewtwo0641 
Assigned Tojustincc 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006582: Region cross /TP sometimes fail and causes a variety of other issues when triggered
DescriptionRegion crosses / TP's sometimes fail with either an eternal walk/run past the sim border or a never ending TP progress screen. If this happens the only way to fix it is to relog. This can cause a variety of weirdness such as adjacent regions not showing up on relog (can't TP to them either), attachments not attaching, error messages in the viewer on the next log in, etc.
Steps To ReproduceI have not yet been able to consistently reproduce this since it appears random but it happens fairly common enough to be able to run across it after a few login attempts and teleport/region cross attempts.

However one of the factors in my testing that I am noticing is that the presence of scripted attachments seems to make this happen more often than simply using all non scripted attachments. (I have been testing with 5 scripted attachments with a total of appx. 20 - 30 scripts or so)

These steps may or may not produce consistent results (Will need at least 2 regions set up)

1. Wear a few scripted attachments and a few non scripted attachments on random attach points(I wore 5 attachments with about 30 scripts, varying numbers of scripts per attachments, and about 8 non scripted). Also try wearing the AO attachment included in the aotest.iar file here http://opensimulator.org/mantis/view.php?id=6577 [^] in addition to any other scripted attachments worn.

2. Cross back and forth between regions multiple times until teleport fails
    a. This may take a few tries but usually it will trigger within 5-10 tries but it may take more.
    b. I am not certain if there is a difference in crossing a region boarder or direct TP, I have mainly been doing region crossings since it is easier to do. But I have seen this a couple times with direct TP.

3. Log out and then log back in and you may notice warning similar to this int he console: WARN - OpenSim.Region.Framework.Scenes.Scene [SCENE]: Existing root scene presence detected for Test User 4462532a-0742-4528-870a-11b63ae40079 in Test Region 2 when connecting. Removing existing presence. There will also be one or more errors from the viewer stating something similar to "Could not upload <random UUID here due to invalid login credentials"

4. Once in world most if not all attachments prior to the TP cross fail will more than likely be missing (not attached, as opposed to missing from inventory). Any adjacent regions will either be invisible and unable to be crossed into, or will look unloaded and unable to cross into (If using a completely flat region via terrain fill command, it will look like there is a huge hole in the center of the region)

5. Relog again and the console warning from step 3 will show up again. Avatar attachments may or may not be attached again from before previous TP fail. They may or may not be able to be detached or reattached, this seems random. Any adjacent regions may or may not still be invisible (in my tests they were usually invisible and unable to be crossed over to) Any repeated relog attempts will always result in the console warning and most of the time invisible adjacent regions.

6. Log out and attempt to shut down OpenSim. The console will hang on shutdown attempt or attempt to forcibly remove the affected avatar... It almost looks like this issue http://opensimulator.org/mantis/view.php?id=6557 [^]
TagsNo tags attached.
Git Revision or version numberr/22414
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files? file icon Opensim32.log (TP failure) [^] (38,260 bytes) 2013-04-04 17:39

- Relationships

-  Notes
(0023693)
justincc (administrator)
2013-03-25 15:04

Chris, from point 6, perhaps then you could try co-operative script termination as I've now detailed in Mantis 6557? Having scripts running in attachments is a trigger I associate strongly with these problems.
(0023697)
mewtwo0641 (reporter)
2013-03-25 20:58

I set the ScriptStopStrategy to co-op and I was having a bit of a hard time testing in this mode because the console keeps giving me this error per scripted attachment:

22:39:19 - [SCRIPT INSTANCE]: Not starting script <script name> (id 36cb
d393-2b1c-4d30-9802-b5d319ca2b48) in part <object name> (id 835e6c6
e-cd79-40e9-8ab9-92f46666e6f6) in object <object name> in Test Regi
on 2. You must remove all existing ScriptEngines\a6885bb3-049c-11de-ae71-0050c2
490048\CommonCompiler_compiled_63f4b2f6-0a96-4dde-9bbf-d0ff270de788.dll* script
DLL files before using enabling co-op termination, either by setting DeleteScrip
tsOnStartup = true in [XEngine] for one run or by deleting these files manually.

Made sure to delete my ScriptEngines folder prior to starting OpenSim and also tried several more times deleting this folder and restarting OpenSim.

I was able to temporarily work around it by recompiling all worn attachment scripts and proceeded to test from there. From what I could tell, there was no difference in this issue whether using abort or co-op. The console also did still hang on attempt to shutdown / forcibly remove the avatar.
(0023701)
justincc (administrator)
2013-03-26 17:54

Are you absolutely sure that you wiped your previous scripts? These errors strongly suggest that there are still DLLs around.

Perhaps you could try the DeleteScriptsOnStartup switch instead?
(0023704)
mewtwo0641 (reporter)
2013-03-27 00:53

Hi Justin, I am fairly positive that I am wiping all the scripts as I am deleting the ScriptEngines directory itself. Gave the DeleteScriptsOnStartup = true a try though and deleted the ScriptEngines folder again for good measure; but am still seeing the errors. It looks as if though a few scripts will load and some will result in that error (This is with attachments that are already on the avatar prior to log in).

As I try to attach random things from my inventory, different attachments with different scripts, the error messages seem to appear on random scripts. Although once I find an attachment with scripts that result in the message, I've noticed that a detach and a reattach will always result in the error on the same script(s) every time. Rezzing the object to the ground from inventory will also result in the messages on the same script(s) as an attach does.

Upon next run of OpenSim (either with DeleteScriptsOnStartup = true or manually remove the ScriptEngines directory manually before startup), the errors may not necessarily appear again on the same objects with the same scripts and may appear to work. Other objects that may have previously worked may now show the error on 1 or more scripts contained in them.

These are also fairly complex scripts (Anywhere within the range of 50 - 900 lines long) that show the error. I haven't yet been able to trigger this with the simple default New Script.

I tried to look in the scripts reported back in the console to see if there was anything common between all of them that might cause them to show the errors and not other scripts, but haven't had much success with it.
(0023709)
justincc (administrator)
2013-03-27 19:56

This is very odd. Are you using TrustBinaries = true in [Startup] in OpenSim.ini or anything similar? Perhaps you could attach the results of "config save" with passwords redacted.
(0023710)
mewtwo0641 (reporter)
2013-03-27 22:50

In my OpenSim.ini I am using:

[Startup]
AllowScriptCrossing = true
TrustBinaries = true

[XEngine]
ThreadStackSize = 262144
AppDomainLoading = false
ScriptStopStrategy = co-op

Sent the results of config save to your googlemail email address as I would rather not make my config known to the public :)
(0023714)
justincc (administrator)
2013-03-28 15:38

Please could you try with TrustBinaries = false and see if that makes those errors go away.
(0023718)
justincc (administrator)
2013-03-28 19:40

You might also want to try git master 23ae4c0a, though I believe those changes are actually independent of the issues you're seeing here.
(0023721)
mewtwo0641 (reporter)
2013-03-28 21:46
edited on: 2013-03-28 21:56

Hi Justin, I gave git master current a try. It is a bit better now although I am still seeing the Not Starting Script errors in co-op mode. I gave TrustBinaries = false a try and I don't seem to see these errors when running scripts in that manner.

Teleports also seem to be a bit more stable now on my testing but I need to test this further.

(0023729)
justincc (administrator)
2013-03-29 17:51

Interesting, it sounds like OpenSimulator may end up using binaries stored in assets with TrustBinaries = true, which means that they're not removed when you wipe the bin/ScriptEngines directory. I will have to think about how to handle that.
(0023732)
mewtwo0641 (reporter)
2013-03-30 03:39

Ah I see...I mainly keep TrustBinaries = true because, for me at least, it results in a quicker teleport / region cross and seems to make it slightly more stable.

On a (un?)related note I have tested commit 9fee43 and teleports do seem to be quite a bit more stable now although I have noticed that sometimes when I log in I can't see any surrounding regions and can't teleport or cross into them. A relog usually fixes it but sometimes it takes a couple tries. The issue appears to come up randomly.
(0023735)
kenvc (reporter)
2013-03-30 09:45

Seeing a lot of teleporting issues, but all other functions seem to be working fine. Here is info from the console that appears when the teleport fails. This is teleporting from a non-mega region into another non-mega region with no scripted attachments on the AV.

11:35:26 - [SCENE]: Region Fantasy Dream 1 authenticated and authorized incoming
 child agent Ken Savage 83f2889f-5546-742d-31e8-8cd147ebebe3 (circuit code 97262
0115)
11:35:37 - [SCENE PRESENCE]: Did not find presence with id 83f2889f-5546-742d-31
e8-8cd147ebebe3 in Fantasy Dream 1 before timeout
11:35:37 - [BASE HTTP SERVER]: Slow handling of 39 PUT /agent/83f2889f-5546-742d
-31e8-8cd147ebebe3/ from 192.168.1.1:54498 took 10389ms
11:35:48 - [SCENE PRESENCE]: Did not find presence with id 83f2889f-5546-742d-31
e8-8cd147ebebe3 in Fantasy Dream 1 before timeout
11:35:48 - [BASE HTTP SERVER]: Slow handling of 40 PUT /agent/83f2889f-5546-742d
-31e8-8cd147ebebe3/ from 192.168.1.1:54503 took 10327ms
Region (root) #
(0023757)
kenvc (reporter)
2013-04-04 17:40

Justin,

Just attached the log file from the failed tp using todays dev master.
(0023758)
justincc (administrator)
2013-04-04 17:54

@mewtwo0641. Please try git master d236796 and tell me if that improves the issue with some regions not always being seen.

If not, it would also be helpful if you could try replacing the current git master HttpServer_OpenSim.dll with the one from the 0.7.5 release (from the Mono or Windows distributions as appropriate).
(0023759)
justincc (administrator)
2013-04-04 17:54

@kenvc. Yeah, as we discussed on IRC, unfortunately the lack of debug detail in that log means I can't tell anything from it. It also doesn't seem to contain any mention of actual teleport failure or a kick due to a failure to ACK on the UDP connection which surprises me.
(0023760)
mewtwo0641 (reporter)
2013-04-05 03:34

Hi Justin, I ran git master d236796 and tested with 2 different attachment situations:

With a single attachment on any given point with some scripted and some unscripted I was able to successfully log in 15 times with out disappearing regions.

With multiple attachments on any given point with some scripted and some unscripted I was able to log in 13 times successfully without disappearing regions. On the 14th try the only region I could see and access was the one I logged into. On the next relog, the regions were visible, and accessible again.

I repeated the above two tests and came up with slightly different results from my initial tests: 2 sets of 15 login attempts, one with single attachments on any given point, and 1 with multiple attachments on any given point and was able to trigger the disappearing region issue in both tests.

Shut down OpenSim and replaced HttpServer_OpenSim.dll with the one from 0.7.5 Release (Binaries zip file for Windows) and repeated the above tests. On my second login attempt there was missing regions (all but the one I logged into). So there does not seem to be a difference between using HttpServer_OpenSim.dll from d236796 or the one from 0.7.5 Release as far as I can tell.

As far as teleport stability is concerned I tested in several login sessions, when I am able to see joining regions and they are accessible, that I was also able to cross back and forth between regions appx 30 times successfully and was able to teleport between two regions appx 15 times successfully as well. Tested with various attachment scenarios; some multi attachment, some single attachment, some scripted, and some unscripted.
(0023761)
justincc (administrator)
2013-04-05 16:06

@metwo0641: Would you say that the DLL from d236796 (and from 0.7.5) improves teleport stability and neighbour region appearance for you compared to previously?
(0023765)
mewtwo0641 (reporter)
2013-04-06 01:53

As far as I can tell in my testing I can't really see a difference between the two DLLs where teleport stability and region appearance is concerned. But compared to the commit when multi attachments was introduced a few weeks ago I can say that teleport stability and region appearance is greatly improved :)

- Issue History
Date Modified Username Field Change
2013-03-21 22:37 mewtwo0641 New Issue
2013-03-25 15:04 justincc Note Added: 0023693
2013-03-25 20:58 mewtwo0641 Note Added: 0023697
2013-03-26 17:54 justincc Note Added: 0023701
2013-03-27 00:53 mewtwo0641 Note Added: 0023704
2013-03-27 19:56 justincc Note Added: 0023709
2013-03-27 22:50 mewtwo0641 Note Added: 0023710
2013-03-28 15:38 justincc Note Added: 0023714
2013-03-28 19:40 justincc Note Added: 0023718
2013-03-28 21:46 mewtwo0641 Note Added: 0023721
2013-03-28 21:56 mewtwo0641 Note Edited: 0023721 View Revisions
2013-03-29 17:51 justincc Note Added: 0023729
2013-03-30 03:39 mewtwo0641 Note Added: 0023732
2013-03-30 09:45 kenvc Note Added: 0023735
2013-04-04 17:39 kenvc File Added: Opensim32.log (TP failure)
2013-04-04 17:40 kenvc Note Added: 0023757
2013-04-04 17:54 justincc Note Added: 0023758
2013-04-04 17:54 justincc Note Added: 0023759
2013-04-05 03:34 mewtwo0641 Note Added: 0023760
2013-04-05 16:06 justincc Note Added: 0023761
2013-04-06 01:53 mewtwo0641 Note Added: 0023765
2013-09-24 16:26 justincc Status new => resolved
2013-09-24 16:26 justincc Resolution open => fixed
2013-09-24 16:26 justincc Assigned To => justincc
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker