Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006579opensim[REGION] OpenSim Corepublic2013-03-21 21:222014-07-29 13:42
Reportermewtwo0641 
Assigned Tomewtwo0641 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006579: Attachments sometimes show up "floating" in world or are invisible
DescriptionAttachments tend to show up "floating" in world rather than attached to the avatar. That is, they look as if they've been rezzed in world and won't move around with your avatar, but the inventory says they are actually attached. They can be detached normally either through inventory or by right clicking the floating object and detach.

Sometimes they tend to simply be invisible but the inventory says they're attached.

They can sometimes be detached and then reattached but most often I've seen that they will refuse to reattach (and sometimes refuse to detach) until either a relog or teleport to a different region. On occasion, nothing but a relog will work.
Steps To ReproduceI have not yet been able to consistently reproduce this since it appears random but it happens fairly common enough to be able to run across it after a few login attempts and teleport/region cross attempts.

However one of the factors in my testing that I am noticing is that the presence of scripted attachments seems to make this happen more often than simply using all non scripted attachments. (I have been testing with 5 scripted attachments with a total of appx. 20 - 30 scripts or so)
Additional InformationOn commit 3611d3 (r/22387) this usually shows up upon a freshy started instance of OpenSim and usually whatever is attached to the left hand is what ends up floating in world. This can be detached but cannot be reattached until either crossing into a different sim or relogging.

In the commits later than 3611d3 this can show up on any random attachment (that I can tell)
TagsNo tags attached.
Git Revision or version numberr/22414
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files

- Relationships
related to 0006581resolvedmewtwo0641 Some attachments refuse to attach on login 

-  Notes
(0024403)
mewtwo0641 (reporter)
2013-09-26 07:28

Closing this as fixed; have not seen this issue show up in a long while.

- Issue History
Date Modified Username Field Change
2013-03-21 21:22 mewtwo0641 New Issue
2013-03-21 22:53 mewtwo0641 Additional Information Updated View Revisions
2013-03-30 03:49 mewtwo0641 Relationship added related to 0006581
2013-09-26 07:28 mewtwo0641 Note Added: 0024403
2013-09-26 07:28 mewtwo0641 Status new => resolved
2013-09-26 07:28 mewtwo0641 Fixed in Version => master (dev code)
2013-09-26 07:28 mewtwo0641 Resolution open => fixed
2013-09-26 07:28 mewtwo0641 Assigned To => mewtwo0641
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker