Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006577opensim[REGION] OpenSim Corepublic2013-03-21 20:552014-07-29 13:42
Reportermewtwo0641 
Assigned Tomewtwo0641 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006577: Using an AO while crossing to another region results in stuck walk animations and general animation weirdness
DescriptionWhen using an active AO and attempting to cross to another region (cross over sim border via walk/run and not direct TP) it causes which ever animation that the AO was playing to become "stuck" and the only solution I can tell to fix it is to either reattach the AO or manually reset it.
Steps To Reproduce1. Upload the attached IAR and wear the Simple AO v1.0.0 object. (Attaches to HUD bottom, a bit off center by default).

2. Walk around in the same region for a few seconds to verify that Walk/Run/Stand animations are being properly overridden. If not, reset the AO via reset scripts in selection.

3. Attempt to walk or run across a region boarder into a different region.
    a. If the avatar is standing still and simply teleports to the new region then it will appear that the AO simply is not functioning at all after the teleport completes even though the changed event for CHANGED_ANIMATION appears to be firing still (This can be verified by locating the line in the change & CHANGED_ANIMATION check and uncommenting the llOwnerSay for it and then repeat the tests)

4. Should notice that the animation that was playing upon crossing is still playing and will not stop until the AO is reattached or manually reset.
TagsNo tags attached.
Git Revision or version numberr/22414
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files? file icon aotest.iar [^] (17,355 bytes) 2013-03-21 20:55

- Relationships
related to 0006581closedmewtwo0641 Some attachments refuse to attach on login 

-  Notes
(0023979)
mewtwo0641 (reporter)
2013-06-01 05:56

This seems to be fixed now; have not seen it show up for a while.

- Issue History
Date Modified Username Field Change
2013-03-21 20:55 mewtwo0641 New Issue
2013-03-21 20:55 mewtwo0641 File Added: aotest.iar
2013-03-28 19:39 justincc Relationship added related to 0006581
2013-06-01 05:56 mewtwo0641 Note Added: 0023979
2013-06-01 05:56 mewtwo0641 Status new => resolved
2013-06-01 05:56 mewtwo0641 Fixed in Version => master (dev code)
2013-06-01 05:56 mewtwo0641 Resolution open => fixed
2013-06-01 05:56 mewtwo0641 Assigned To => mewtwo0641
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker