Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006570opensim[REGION] Specific OpenSim Modulepublic2013-03-09 09:022014-07-29 13:42
ReporterMichelle Argus 
Assigned ToTeravus 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006570: [RemoteAdmin] responce is delayed in every 2nd call
DescriptionThere is some delay in the Remote Admin module. Every 2nd time one send a command, Remote Admin receives the request after a very long delay. Webaplications can run out of time while waiting for the responce.

 I am however not sure if this is a problem caused by Opensim or by php. I am using the php Example 1 found here: http://opensimulator.org/wiki/RemoteAdmin:RemoteAdmin_Examples#Example_1 [^]
TagsNo tags attached.
Git Revision or version numberall current
Run Mode Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Files

- Relationships
related to 0006548closedSnoopy Very High Memory Consumption 

-  Notes
(0023658)
justincc (administrator)
2013-03-12 16:44

If you specify "debug http in 3" on the console then all incoming http requests will be logged (see "help debug http" for more details.

Does this show that that the second request is received immediately but is somehow not processed for a minute?
(0023664)
Michelle Argus (reporter)
2013-03-13 12:44

Ok, I have narrowed the problem down...

 The RemoteAdmin PHP Class which I am using from the Wiki uses fsockopen to communicate with the sim. It successfully send the command to OS and RemoteAdmin also executes the command succesfully. The problem is somewere in the responce were while(!feof($fp)) does not exit the loop. The responce from Remote Admin is being send, which i tested by forcing an exit from while.

 I also tryed the alternative php example2 which uses curl instead of fsockopen. Using curl always works fine.
(0023754)
Teravus (administrator)
2013-04-04 16:14

Turned out the default was to have reuse contexts on, but if the application code didn't specify, it would flip between reuse contexts on and reuse contexts off. This is why the first connection worked as desired, the second one failed.

- Issue History
Date Modified Username Field Change
2013-03-09 09:02 Michelle Argus New Issue
2013-03-10 14:07 Snoopy Relationship added related to 0006548
2013-03-12 16:44 justincc Note Added: 0023658
2013-03-13 12:44 Michelle Argus Note Added: 0023664
2013-04-04 16:14 Teravus Note Added: 0023754
2013-04-04 16:14 Teravus Status new => resolved
2013-04-04 16:14 Teravus Resolution open => fixed
2013-04-04 16:14 Teravus Assigned To => Teravus
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker