Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006552opensim[GRID] Robust Serverpublic2013-02-25 15:452014-07-29 13:42
ReporterTodd Davis 
Assigned ToTodd Davis 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDell PowerEdgeOSUbuntuOS Version12.041
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006552: Unable to log into region
DescriptionI am unable to log in to test region. I get error on region console.

2013-02-25 17:27:05,742 ERROR - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer [LLUDPSERVER]: UseCircuitCode handling from endpoint 216.26.209.189:60643, client unknown unknown failed. Exception Invalid URI: The URI scheme is not valid. at System.Uri.Parse (UriKind kind, System.String uriString) [0x00000] in <filename unknown>:0
  at System.Uri.ParseUri (UriKind kind) [0x00000] in <filename unknown>:0
  at System.Uri..ctor (System.String uriString, Boolean dontEscape) [0x00000] in <filename unknown>:0
  at System.Uri..ctor (System.String uriString) [0x00000] in <filename unknown>:0
  at System.Net.WebRequest.Create (System.String requestUriString) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.SynchronousRestFormsRequester.MakeRequest (System.String verb, System.String requestUrl, System.String obj) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceRemoteConnector.MakeRequest (System.String method, System.Collections.Generic.Dictionary`2 sendData) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceRemoteConnector.GetMembership (System.String RequestingAgentID, System.String AgentID, UUID GroupID) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceRemoteConnectorModule+<>c__DisplayClass13.<GetAgentActiveMembership>b__12 () [0x00000] in <filename unknown>:0
  at OpenSim.Groups.RemoteConnectorCacheWrapper.GetAgentActiveMembership (System.String AgentID, OpenSim.Groups.GroupMembershipDelegate d) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceRemoteConnectorModule.GetAgentActiveMembership (System.String RequestingAgentID, System.String AgentID) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceHGConnectorModule.GetAgentActiveMembership (System.String RequestingAgentID, System.String AgentID) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsModule.GetGroupTitle (UUID avatarID) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence..ctor (IClientAPI client, OpenSim.Region.Framework.Scenes.Scene world, OpenSim.Framework.AvatarAppearance appearance, PresenceType type) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.SceneGraph.CreateAndAddChildScenePresence (IClientAPI client, OpenSim.Framework.AvatarAppearance appearance, PresenceType type) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.Scene.AddNewClient (IClientAPI client, PresenceType type) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.Start () [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.AddClient (UInt32 circuitCode, UUID agentID, UUID sessionID, System.Net.IPEndPoint remoteEndPoint, OpenSim.Framework.AuthenticateResponse sessionInfo) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.HandleUseCircuitCode (System.Object o) [0x00000] in <filename unknown>:0
Steps To ReproduceIt will not work with r/22227.. I have gone back to r/22215 and I am able to log into test region.. I have check rechecked and even copied my OpenSim.ini file from r/22215 to r/22227 instance and still have gotten the same error.. So it is not a config file issue or network issue..
TagsNo tags attached.
Git Revision or version numberr/22227
Run Mode Standalone (Multiple Regions)
Physics EngineODE
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Files

- Relationships

-  Notes
(0023598)
Todd Davis (reporter)
2013-02-25 15:47

I accidentally put this under robust.. I am not sure it should be under robust.. perhaps under grid something..
(0023599)
Diva (administrator)
2013-02-25 15:51

This looks like misconfiguration of Groups -- GroupsServerURI
(0023600)
Todd Davis (reporter)
2013-02-25 16:28

Yes this was my fault.. my config was wrong. Thank you Diva.. Sorry about submitting a bug. I thought I had covered my bases. Please close this report..
(0023601)
Todd Davis (reporter)
2013-02-25 16:28

configuration issue in the OpenSim.ini.. user error..

- Issue History
Date Modified Username Field Change
2013-02-25 15:45 Todd Davis New Issue
2013-02-25 15:47 Todd Davis Note Added: 0023598
2013-02-25 15:51 Diva Note Added: 0023599
2013-02-25 16:28 Todd Davis Note Added: 0023600
2013-02-25 16:28 Todd Davis Note Added: 0023601
2013-02-25 16:28 Todd Davis Status new => resolved
2013-02-25 16:28 Todd Davis Fixed in Version => master (dev code)
2013-02-25 16:28 Todd Davis Resolution open => fixed
2013-02-25 16:28 Todd Davis Assigned To => Todd Davis
2014-01-23 15:41 justincc Category Robust Server => [GRID] Robust Server
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker