Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006497opensim[REGION] Script Functionspublic2013-01-09 20:222016-12-14 14:49
Reporterdjphil 
Assigned ToPixel Tomsen 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowOSSevenOS VersionIntegral
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0006497: llRequestPermissions for PERMISSION_TELEPORT return a error
DescriptionThe two scripts di SL wiki does not compile correctly
Steps To ReproduceTry to compile this:

key teleportee;
 
default
{
    state_entry()
    {
        llSay(0, "Touch to teleport");
    }
 
    touch_start(integer total_num)
    {
        teleportee = llDetectedKey(0);
        llRequestPermissions(teleportee, PERMISSION_TELEPORT);
    }
 
    run_time_permissions(integer perm)
    {
        if(PERMISSION_TELEPORT & perm)
        {
            llTeleportAgent(teleportee, "", <13.0, 38.0, 23.5>, <13.0, 12.0, 23.5>);
        }
    }
}

or this:

key teleportee;
 
default
{
    state_entry()
    {
        llSay(0, "Touch to teleport");
    }
 
    touch_start(integer total_num)
    {
        teleportee = llDetectedKey(0);
        llRequestPermissions(teleportee, PERMISSION_TELEPORT);
    }
 
    run_time_permissions(integer perm)
    {
        if(PERMISSION_TELEPORT & perm)
        {
            llTeleportAgent(teleportee, "Experience Tools 1", <0.0, 0.0, 0.0>, <0.0, 0.0, 0.0>);
        }
    }
}
Additional Informationsource : http://wiki.secondlife.com/wiki/LlTeleportAgent [^]
TagsNo tags attached.
Git Revision or version numberOSgrid (0.7.5 (Dev) 4f98259
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
ViewerVoodoo
Attached Files

- Relationships
related to 0006341closedadministrator [PATCH] Adds PERMISSION_TELEPORT constant to LSL_Constants.cs 

-  Notes
(0023646)
Richardus Raymaker (reporter)
2013-03-07 12:31

I can confirm i have the same problem.
----------------------------------------
Opensim 0.7.5 release
Windows 64bit
Singularity Viewer 1.7.3 (3868) Feb 26 2013 22:19:11 (Singularity Alpha)

llRequestPermissions(agent, PERMISSION_TELEPORT);
is still not working.

"The name 'PERMISSION_TELEPORT' does not exist in the current context(17,11)"

This the wiki example i tried and generate the error
-----------------------

key agent;
 
default
{
    state_entry()
    {
        llSay(0, "Touch to teleport");
    }
 
    touch_start(integer total_num)
    {
        agent = llDetectedKey(0);
        llRequestPermissions(agent, PERMISSION_TELEPORT);
    }
 
    run_time_permissions(integer perm)
    {
        if(PERMISSION_TELEPORT & perm)
        {
            llTeleportAgent(agent, "", <114.0, 165.0, 25>, <13.0, 12.0, 23.5>);
        }
    }
}
(0023647)
jak.daniels (reporter)
2013-03-07 12:52

It will work if you add:
integer PERMISSION_TELEPORT = 0x1000;
to the top of your script. The constant doesn't seem to be defined by OS lsl yet.
(0023648)
zadark (reporter)
2013-03-07 15:08

A safer temporary solution would be to replace PERMISSION_TELEPORT with 0x1000
as PERMISSION_TELEPORT would be a reserved name and create a compile error once the omission is fixed.
(0024794)
djphil (reporter)
2013-12-01 07:51

The patch is applied it soon ?
(0025358)
djphil (reporter)
2014-03-03 18:21

This problem is not resolved in the latest version of OpenSim provided on the site OsgGrid.
(0028370)
greg0254 (reporter)
2015-05-13 15:30

Would really like to see the constant PERMISSION_TELEPORT added, since it's a such a minor fix and these bug reports have been open for so long.
(0031462)
djphil (reporter)
2016-12-14 14:49

Everything is ok here, thanks :)

- Issue History
Date Modified Username Field Change
2013-01-09 20:22 djphil New Issue
2013-01-10 07:36 Pixel Tomsen File Added: 0001-Fix-LSL-constant-PERMISSION_TELEPORT-permission-chec.patch
2013-01-10 07:37 Pixel Tomsen Assigned To => Pixel Tomsen
2013-01-10 07:37 Pixel Tomsen Status new => patch included
2013-01-14 08:07 Pixel Tomsen Relationship added related to 0006341
2013-01-14 08:19 Pixel Tomsen File Deleted: 0001-Fix-LSL-constant-PERMISSION_TELEPORT-permission-chec.patch
2013-01-14 08:19 Pixel Tomsen Status patch included => new
2013-03-07 12:31 Richardus Raymaker Note Added: 0023646
2013-03-07 12:52 jak.daniels Note Added: 0023647
2013-03-07 15:08 zadark Note Added: 0023648
2013-12-01 07:51 djphil Note Added: 0024794
2014-03-03 18:21 djphil Note Added: 0025358
2015-05-13 15:30 greg0254 Note Added: 0028370
2016-12-14 14:49 djphil Note Added: 0031462
2016-12-14 14:49 djphil Status new => resolved
2016-12-14 14:49 djphil Fixed in Version => master (dev code)
2016-12-14 14:49 djphil Resolution open => fixed
2016-12-14 14:49 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker