Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006491opensim[REGION] Physics Enginespublic2013-01-04 10:392013-01-28 12:11
ReporterRobert Adams 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0006491: BulletSim: possible memory leak
DescriptionRunning a region with BulletSim seems to grow memory-wise. The actual cause is not clear. Just booting up a simple region and letting it set does not grow in memory. Having a region where avatars come and go and/or has scripts will eventually grow in memory. The BulletSim regions on OSGrid grow from 200K to 2G in about two days.

There are anecdotal reports of OpenSim with ODE having the same problem but this is not confirmed.
TagsNo tags attached.
Git Revision or version numbera0739a80a89f5f89f3d95a0338cb9f833fee09a5
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Fileslog file icon OpenSim.32BitLaunch.log [^] (9,649 bytes) 2013-01-04 11:35
? file icon OpenSim.32BitLaunch.log (Startup error) [^] (75,404 bytes) 2013-01-04 11:44

- Relationships

-  Notes
(0023381)
kenvc (reporter)
2013-01-04 11:34
edited on: 2013-01-04 11:45

I can confirm there is a new problem of some kind. When I checked the server this morning, Windows was displaying a message that opensim32 has a problem and needs to be shut down. This was using the current Dev Master as of todays date.

Attached is a portion of the log file pulled this morning that contains the same error over and over which filled up 3 log files. The entire log file is not included because its just the same error repeated hundreds, thousands of times. I suspect the problem is related to a memory leak because of the windows message about needing to shutdown the Bulletsim instance.

(0023382)
kenvc (reporter)
2013-01-04 11:43

Attaching a 2nd startup log that includes everything from startup until the regions are all ready. An error occurs on startup in this log that I do not see when not using Bulletsim, but not sure if all this is related.
(0023397)
mewtwo0641 (reporter)
2013-01-10 19:39

I can confirm this. I ran my setup under BulletSim for about half an hour and memory use steadily climbed to over 300 MB for Objects and 1 GB of process memory use before I shut it down. ODE seems to be fine for me, it stays steady at around 200 MB Objects and 650 - 700 MB process and am able to use it with multiple avs logged in for long periods of time (several hours or more) with only slight change to memory use (I never see it above 750 MB for process).
(0023461)
Robert Adams (administrator)
2013-01-28 10:42

Bullet has a bug that it leaks memory when profiling is turned on. Profiling has been turned off in the latest master checkin and memory does not grow on my test regions.
(0023462)
Teravus (administrator)
2013-01-28 11:47

Congrats! you got it!

- Issue History
Date Modified Username Field Change
2013-01-04 10:39 Robert Adams New Issue
2013-01-04 10:39 Robert Adams Status new => assigned
2013-01-04 10:39 Robert Adams Assigned To => Robert Adams
2013-01-04 11:34 kenvc Note Added: 0023381
2013-01-04 11:35 kenvc File Added: OpenSim.32BitLaunch.log
2013-01-04 11:43 kenvc Note Added: 0023382
2013-01-04 11:44 kenvc File Added: OpenSim.32BitLaunch.log (Startup error)
2013-01-04 11:45 kenvc Note Edited: 0023381 View Revisions
2013-01-10 19:39 mewtwo0641 Note Added: 0023397
2013-01-28 10:42 Robert Adams Note Added: 0023461
2013-01-28 10:42 Robert Adams Status assigned => resolved
2013-01-28 10:42 Robert Adams Fixed in Version => master (dev code)
2013-01-28 10:42 Robert Adams Resolution open => fixed
2013-01-28 11:47 Teravus Note Added: 0023462
2013-01-28 11:47 Teravus Status resolved => closed
2013-01-28 12:09 Teravus Status closed => feedback
2013-01-28 12:09 Teravus Resolution fixed => reopened
2013-01-28 12:11 Teravus Status feedback => closed
2013-01-28 12:11 Teravus Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker