Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006485opensim[REGION] Specific OpenSim Modulepublic2013-01-01 22:392014-07-29 13:42
Reporterorenh 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0006485: [PATCH] Fixed several problems with the Sun: some settings didn't work, or were inconsistently used
Description- The sun position is always calculated by combining the sun settings in the Region and Estate. This fixes the problem that 'UseEstateSun' didn't work.
- To remove ambiguity, the EstateToolsSunUpdate event no longer accepts the sun's position as parameters. That's because the position is always calculated from the Region and Estate settings.
- Use only the 'FixedSun' flag to determine whether the sun is fixed; not the 'UseGlobalTime' flag.
- Don't change the region's 'SunPosition' field according to the sun's position: this field is used only to set the position when using a FixedSun. (The 'SunVector' field does get updated according to the sun's position in the sky)
TagsNo tags attached.
Git Revision or version numberf1639827fc92d0ddd9d109474934fdd484a908f1
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux64
Mono Version2.10
Viewer
Attached Filespatch file icon 0001-Fixed-several-problems-with-the-Sun-some-settings-di.patch [^] (11,890 bytes) 2013-01-01 22:39 [Show Content]

- Relationships

-  Notes
(0023363)
justincc (administrator)
2013-01-02 15:40

Added as git master 1a6694b. Thanks Oren.

- Issue History
Date Modified Username Field Change
2013-01-01 22:39 orenh New Issue
2013-01-01 22:39 orenh Status new => assigned
2013-01-01 22:39 orenh Assigned To => justincc
2013-01-01 22:39 orenh File Added: 0001-Fixed-several-problems-with-the-Sun-some-settings-di.patch
2013-01-01 22:39 orenh Status assigned => patch included
2013-01-02 15:40 justincc Note Added: 0023363
2013-01-02 15:40 justincc Status patch included => resolved
2013-01-02 15:40 justincc Resolution open => fixed
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker