Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006467opensim[GRID] Asset Servicepublic2012-12-16 13:322012-12-16 14:09
ReporterToy_Wylie 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformLinuxOSopenSUSEOS Version11.4
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006467: Coalesced objects aren't stored correctly in prim contents
DescriptionWhen you try dragging a coalesced object (multiple unlinked prims) into a prim's contents only the "root" prim of the coalesced group gets transfered.
Steps To Reproduce- Rez a number of prims
- Select all prims
- Right Click / Take
- Rez another prim
- Drag the previously rezzed group into the prim's contents
- Drag the group out of the prim to rez it on the ground
- Observed: Only the "root" prim of the coalesced group rezzes
- Expected: The whole coalesced group should rez
TagsNo tags attached.
Git Revision or version numberOpenSim 0.7.5 Dev OSgrid 0.7.5 (Dev) 4f98259: 2012-11-10 (Unix/Mono)
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32
Mono Version2.8
ViewerPhoenix Viever 1.6.1.1691
Attached Files

- Relationships

-  Notes
(0023274)
melanie (administrator)
2012-12-16 13:41

This is design behavior and matches the effect of rezzing from a script. Since there is an object_rez event nd it can only take one UUID, only one link set can be rezzed from a prim. The coalesced object is, however, not damaged, dragging itback to agent inventory and rezzing from there rezzes all parts. It's just not designed to do that from a prim.
(0023275)
nebadon (administrator)
2012-12-16 13:44

setting this to "won't fix" and "acknowledged" in the future it would be good to test anything your not sure about against Second Life functionality if you can.
(0023276)
melanie (administrator)
2012-12-16 13:49

I intentionally didn't because I was looking for a comment from the reporter before closing it.
(0023277)
Toy_Wylie (reporter)
2012-12-16 13:59
edited on: 2012-12-16 14:00

The way it works in SL is that the coalesced object is rezzed fully and an object_rez() event is called for each piece of the rez, so with 6 prims in the group it would send 6 events with each object's key.

I am always testing against SL, that's why I am filing these as bugs here.

(0023278)
nebadon (administrator)
2012-12-16 14:09

ok I set it back to open then, well I didn't close it, I set it to won't fix only because it sounded like it was designed this way, the ticket was never actually closed though.

- Issue History
Date Modified Username Field Change
2012-12-16 13:32 Toy_Wylie New Issue
2012-12-16 13:41 melanie Note Added: 0023274
2012-12-16 13:44 nebadon Note Added: 0023275
2012-12-16 13:44 nebadon Status new => acknowledged
2012-12-16 13:44 nebadon Resolution open => won't fix
2012-12-16 13:49 melanie Note Added: 0023276
2012-12-16 13:59 Toy_Wylie Note Added: 0023277
2012-12-16 14:00 Toy_Wylie Note Edited: 0023277 View Revisions
2012-12-16 14:09 nebadon Note Added: 0023278
2012-12-16 14:09 nebadon Resolution won't fix => open


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker