Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006458opensim[REGION] Physics Enginespublic2012-12-11 21:462014-07-29 13:43
ReporterMata Hari 
Assigned ToMata Hari 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformIntel Core i7 930OSWindowsOS VersionWin 7
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0006458: Uploading an animation causes avatar physics to stop functioning until reloag
DescriptionI have tested this with both the Firestorm and Cool VL viewers (most recent "official" non-beta releases of each: Firestorm 4.3.1 (31155) OpenSim Release and Cool VL Viewer 1.26.4 (40) Nov 24 2012 Release) and encountered the identical problem so I suspect this is OS related rather than a viewer issue.

If avatar physics are enabled on either viewer they will normally work more or less perfectly (i.e. the bouncing/swaying breast/belly/butt effects) however if I upload a new single animation (set to preview on the avatar) it seems to consistently -- though NOT always -- cause the physics to cease to work at all until I shut down the viewer and relog. This isn't a huge issue, but it's something of an annoyance.
Steps To Reproduce1. Log in to a sim using any viewer that supports avatar physics

2. Ensure that avatar physics are enabled (preferences > graphics > advanced...)

3. Create and wear an avatar physics (clothing item)

4. Ensure that settings for the physics will display conveniently. Easy (exaggerated) way is to select a default Ruth avatar, then set Breast bounce to Max Effect 50, Spring 50, Gain 50, Dampening 10 and in Advanced settings set Breast Mass to 50 and Breast Drag to 50. This will cause the breast to bounce significantly with almost any up/down motion such as a jump.

5. Test by jumping and ensuring physics is easily visible.

6. Now upload any bvh animation file and preview it on the avatar. The problem seems to occur almost every time I upload an animation that I set to priority 4 and loop, though it will also happen with lower priority settings and/or with non-looped animations.

7. Now repeat step 5 using whatever action you did (like a jump) that successfully displayed the avatar physics effect.
Additional InformationI have only tested this on Firestorm and Cool VL so if they happen to use the same engine to render avatar physics then it could be a viewer issue.

I have only tested and encountered this doing single animation uploads (not sure if it's even possible to bulk upload a set of animations but most users wouldn't do so because of the need to set animation priority/loop/ease in/ease out parameters at the time of upload)

I have always had my animations set to preview on the avatar at time of upload so I cannot say if this issue occurs when not set to preview.

It seems to happen almost every time I upload an animation that I set to priority 4, although I *think* that I have successfully uploaded a few without triggering the problem. The same is true of setting the animation to loop.

This error occurs approximately 80% of the time for me (I've uploaded about 50-60 assorted animations and only managed to have working avatar physics after the upload on perhaps a dozen occasions...the other 40+ times I had to relog.

I encountered the same error prior to the current 0.7.5 OpenSim release but I've only recently begun to work on animations so it's only now that I've realized there's a consistency to when it stops working. I tried a search to see if anyone else had reported the issue but wasn't able to find any previous bugs related to this topic so perhaps it was caused by something introduced relatively recently to the code (or nobody noticed it before?!)
TagsNo tags attached.
Git Revision or version numberOpenSim 0.7.5 Dev OSgrid 0.7.5 (Dev) 583e441: 2012-12-04 (Win/.NET)
Run Mode Grid (1 Region per Sim)
Physics EngineBasicPhysics
Environment.NET / Windows32
Mono VersionNone
ViewerFirestorm and Cool VL
Attached Files

- Relationships

-  Notes
(0025651)
Mata Hari (reporter)
2014-04-01 12:03

Hasn't happened to me in a long time I so assume this is fixed

- Issue History
Date Modified Username Field Change
2012-12-11 21:46 Mata Hari New Issue
2014-04-01 12:03 Mata Hari Note Added: 0025651
2014-04-01 12:03 Mata Hari Status new => resolved
2014-04-01 12:03 Mata Hari Fixed in Version => master (dev code)
2014-04-01 12:03 Mata Hari Resolution open => fixed
2014-04-01 12:03 Mata Hari Assigned To => Mata Hari
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker