Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006443opensim[REGION] OpenSim Corepublic2012-11-20 10:542013-05-13 15:57
Reporterkenvc 
Assigned Tojustincc 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformQuadcore 8 gig ram 2.8 ghzOSWindowsOS VersionWindow 8 64 bi
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006443: Teleporting into a mega region into any sim other than sim 1 results in frozen AV requiring relog to recover.
DescriptionTeleporting from another simulator to any sim inside a megaregion other than the man sim 1 of the megaregion results in the AV being unable to move. It often ends up underground and falling forever, then sometimes the screen looks like nothing but deep underwater with no land and sometimes no visible AV. This is repeatable and it happens everytime.

After this happens you cannot teleport anywhere else or recover from this condition without restarting the browser. Even then, if you try to sign in to your last location, the exact same thing will continue to happen over and over. You have to sign back in to a different simulator to recover. Teleporting into the 1st sim of a megaregion works fine, then you can go where you want in that mega without issues. I tried setting landing points, allowing landing anywhere, etc. etc. and the result is the same.
Steps To ReproduceTeleport to a region in a mega that is NOT the first region.
TagsNo tags attached.
Git Revision or version numberr21811
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Filestxt file icon Teleport & Megaregion.txt [^] (3,241 bytes) 2013-03-29 04:04 [Show Content]
txt file icon Teleport & Megaregion_22454_23ae4c0_290313.txt [^] (3,805 bytes) 2013-03-29 12:57 [Show Content]

- Relationships

-  Notes
(0023448)
kenvc (reporter)
2013-01-25 06:55

Tested this several times gain last night with the latest dev master and this issue is still going on. If you try to teleport using the map to any sim other than sim 1 of a mega region, you end up in the far upper right corner of sim 1 unable to move or do anything without relogging.

Some time ago this problem did not exist. I recall it would do some type of double teleport to get you to the coordinates you wanted. It appeared to teleport you into the first sim then immediately teleport you from there to your destination, but this not longer works.
(0023449)
Garmin Kawaguichi (reporter)
2013-01-25 08:16

@kenvc
Please try that:
- "try to teleport using the map to any sim other than sim 1 of a mega region"
- when you are at the 0.0, 0.0 corner of the destination, open again the map and double-click the red circle displayed on the destination region.

1) That works and you can walk and fly on the whole megaregion: well, the double teleport works ... manually :)))

2) Still stuck at the edge of the region; connect to Osgrid
a) try to teleport to MegaSdb01 using the map; it is the root of a megaregion
b) if this first teleport works fine return to your home region
c) try to teleport to MegaSdb07UseMegaSdb01 using the map
d) when you are at the 0.0, 0.0 corner of the destination, open again the map and double-click the red circle displayed on the destination region. (this worked for me when I teleport from Plaza Germany, or from Isle or from Fort)
e) if that works for you, I'll publish the patch I'm testing in MegaSdb megaregion; but this patch is not satisfactory, since it requires two manual operations.
(0023577)
kenvc (reporter)
2013-02-16 19:17

This issue is still going on. It used to work, but its been broken for some time now.
(0023699)
justincc (administrator)
2013-03-26 17:09
edited on: 2013-03-26 17:09

Some improvement in git master 01636ca where this did correctly do the double teleport (after delay) for me. However, reports indicate this doesn't work in all circumstances and/or with larger sized megaregions. Further reports welcome.

(0023716)
justincc (administrator)
2013-03-28 18:53

Further improvements up to 9ca54d0. If you're using Bulletsim you might also want to go up to 6a9630d2b.

In d87ddf50 I tried eliminating the pause before reteleport but it seems this might not be stable on all systems. Reverted in e89bcf4f pending further work.
(0023722)
Garmin Kawaguichi (reporter)
2013-03-29 04:04

We tried various kinds of teleport before and after R22416_01636ca_230313. The results are in the file "Teleport & Megaregion.txt"
(0023724)
Garmin Kawaguichi (reporter)
2013-03-29 13:09

New tests with R22454_23ae4c0_290313. See file Teleport & Megaregion_22454_23ae4c0_290313.txt
- All tests are OK (teleport to a non root region with a bit of a wait).
- Noted but not sure whether it is your changes: when teleporting from the megaregion to a standard region, FireStorm is locked for about fifteen seconds
- Note especially that the teleport to a sub-region (grid mode and from a standard region) still works fine with a landmark; it may be a possible direction for a sustainable solution.
(GCI)
(0023728)
justincc (administrator)
2013-03-29 17:35

Thanks for the feedback, Garmin, I will have to take a look at that when I get time for this, though I can't be sure when that will next be.

The wait on some teleports was originally there to allow the old mechanism of reteleporting via god-like request to work. But now that we're re-teleporting via a different mechanism it might be possible to eliminate it in the long term.

If you compile the code then you can do this by commenting out the 10 second sleep at the top of EntityTransferModule.InformClientToInitiateTeleportToLocationAsync().

I've had good results with this with the re-teleporting happening seemlessly on a local 3x3 (with the initial teleport progress screen still up). However, Nebadon reported a bad result externally (teleport appeared to be successfully but then a little while later could no longer move/teleport, etc.). Probably some timing issue.
(0023823)
kenvc (reporter)
2013-05-01 12:37

Justin, it appears the initial issue I reported has been corrected with the double teleport solution. It does not seem quit as fast as it originally was before this problem started, but the main thing is that it works.
(0023824)
Teravus (administrator)
2013-05-01 12:39

Coolness!
(0023826)
Arielle (reporter)
2013-05-01 13:31

Just a note that may or may not be of interest is that teleport lures from non-root regions of a mega consistently brings the receiving avatar to the non root region as expected on .7.5.
(0023869)
kenvc (reporter)
2013-05-11 20:00

The initial issue I reported has been corrected with the double teleport solution. It does not seem quit as fast as it originally was before this problem started, but the main thing is that it works.
(0023878)
Teravus (administrator)
2013-05-13 13:14

test

- Issue History
Date Modified Username Field Change
2012-11-20 10:54 kenvc New Issue
2012-11-20 15:15 kenvc Description Updated View Revisions
2012-11-23 11:00 kenvc Summary Teleporting from another simulator to any sim in a megaregion other than sim 1 results in AV unable to move => Teleporting from another simulator to any sim in a megaregion other than sim 1 results in AV being unable to move
2013-01-25 06:55 kenvc Note Added: 0023448
2013-01-25 06:57 kenvc Git Revision or version number r21078 => r21811
2013-01-25 06:57 kenvc Priority normal => high
2013-01-25 06:57 kenvc Summary Teleporting from another simulator to any sim in a megaregion other than sim 1 results in AV being unable to move => Teleporting into a mega region into any sim other than sim 1 results in frozen AV requiring relog to recover.
2013-01-25 08:16 Garmin Kawaguichi Note Added: 0023449
2013-02-16 19:17 kenvc Note Added: 0023577
2013-02-16 19:18 kenvc Priority high => urgent
2013-02-16 19:18 kenvc Severity major => crash
2013-03-26 17:09 justincc Note Added: 0023699
2013-03-26 17:09 justincc Note Edited: 0023699 View Revisions
2013-03-28 18:53 justincc Note Added: 0023716
2013-03-29 04:04 Garmin Kawaguichi File Added: Teleport & Megaregion.txt
2013-03-29 04:04 Garmin Kawaguichi Note Added: 0023722
2013-03-29 12:57 Garmin Kawaguichi File Added: Teleport & Megaregion_22454_23ae4c0_290313.txt
2013-03-29 13:09 Garmin Kawaguichi Note Added: 0023724
2013-03-29 17:35 justincc Note Added: 0023728
2013-03-29 17:36 justincc Assigned To => justincc
2013-03-29 17:36 justincc Status new => assigned
2013-05-01 12:37 kenvc Note Added: 0023823
2013-05-01 12:39 Teravus Note Added: 0023824
2013-05-01 13:31 Arielle Note Added: 0023826
2013-05-11 20:00 kenvc Note Added: 0023869
2013-05-11 20:00 kenvc Status assigned => resolved
2013-05-11 20:00 kenvc Fixed in Version => master (dev code)
2013-05-11 20:00 kenvc Resolution open => fixed
2013-05-13 13:14 Teravus Note Added: 0023878
2013-05-13 15:57 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker