Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006424opensim[REGION] Physics Enginespublic2012-11-11 13:072014-07-29 13:41
Reporterstella Luna 
Assigned ToRobert Adams 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinux 64 bitOSDebian GNU/Linux (squeeze)OS Version6.0.6
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006424: Sim Crahes on start of vehicles from OKC Racer KIT V0.186X [BOX]
DescriptionWhen I try to start Nabadon Izumi's OKC Racer v0.186X (super-lite) or Kitto Flora's OKC Chopped Treadmaster 2009 v1.8 from the OKC Racer KIT V0.186X the sim crashes. This applies to any other vehicle I have tested of same kind as well. Only BulletSim is affected. There is no problem with ODE.
Steps To ReproduceRez the OKC Chopped Treadmaster mentioned above, right-click and choose "Tread It!" from the menue pie. The Avatar starts running and soon after the sim crashes. Below is all that can be found in the log.
Additional Information19:18:03 - [WATCHDOG]: Started tracking thread AsyncLSLCmdHandlerThread, ID 144
Region (Lucid Dreams) # Stacktrace:


Native stacktrace:

        mono() [0x487ad6]
        mono() [0x4d354f]
        /lib/libpthread.so.0(+0xeff0) [0x7fa64c9dcff0]
        lib64/libBulletSim.so(_ZN9btVector3C1ERKfS1_S1_+0x18) [0x7fa6344157c0]
        lib64/libBulletSim.so(_ZN7Vector312GetBtVector3Ev+0x2c) [0x7fa634416202]
        lib64/libBulletSim.so(SetInterpolationAngularVelocity2+0x1c) [0x7fa63441b626]
        [0x418fdb0d]

Debug info from gdb:


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted
TagsNo tags attached.
Git Revision or version numberOpenSim 0.7.5 Dev OSgrid 0.7.5 (Dev) 4f98259: 2012-11-10 (Unix/Mono)
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0023100)
stella Luna (reporter)
2012-11-12 07:36

Mono JIT compiler version 2.6.7 (Debian 2.6.7-5.1)
(0023101)
stella Luna (reporter)
2012-11-12 10:21

I made a simple test on a empty region with one prim containing a script with the following statements in the touch_end event:
            llSetStatus(STATUS_PHYSICS, TRUE);
            llSetVehicleType(VEHICLE_TYPE_BALLOON);
            
The crash occurs when the vehicle type is set. I tested with VEHICLE_TYPE_SLED, VEHICLE_TYPE_CAR and VEHICLE_TYPE_BALLOON. The behaviour was the same in all three cases.

However, I'll do some more investigation on this as BulletSim crashes my other sim already during startup. The other sim is running the same OS, Mono and OpenSim version. However, it's running on another vServer and there are two regions with some builds and scripted content.

This is how it looks like at the OpenSim console window when it crashes at startup. There is not more or better information in the OpenSim.log.
...
22:02:55 - [WATCHDOG]: Started tracking thread Heartbeat (Sweet Dreams), ID 11
22:02:55 - [RADMIN]: Creating default avatar entries
22:02:55 - [RADMIN]: No default avatar information available
22:02:55 - [RADMIN]: Default avatars not loaded
22:02:55 - [REGIONMODULES]: PostInitializing...
22:02:55 - [MUTE LIST]: Mute list enabled
22:02:55 - [OFFLINE MESSAGING]: Offline messages enabled
Currently selected region is Sweet Dreams
22:02:55 - [COMMANDFILE]: Running startup_commands.txt
22:02:55 - [COMMANDFILE]: Running 'fcache assets'
22:02:55 - [FLOTSAM ASSET CACHE]: Ensuring assets are cached for all scenes.
22:02:55 - [STARTUP]: Non-script portion of startup took 0m 8s. PLEASE WAIT FOR LOGINS TO BE ENABLED ON REGIONS ONCE SCRIPTS HAVE STARTED.
Region (Sweet Dreams) # Stacktrace:


Native stacktrace:

        mono() [0x80d5b19]
        mono() [0x810f7ab]
        /lib/libpthread.so.0(+0xde80) [0xb76eee80]

Debug info from gdb:


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted
(0023102)
nebadon (administrator)
2012-11-12 10:23

I have seen the same thing in Linux on Mono 2.10.8 Under SuSE 11.4, this does not happen under windows.
(0023105)
stella Luna (reporter)
2012-11-12 11:25

The crash at startup on my other sim seems not to be directly related and might be something else. The oars taken from the two regions dont crash the other sim.

However, the issue with the crash at llSetVehicleType(VEHICLE_TYPE_CAR) remains.
(0023181)
Robert Adams (administrator)
2012-11-28 13:40

The latest checkin of BulletSim fixed the crash caused by SetInterpolationAngularVelocity().

- Issue History
Date Modified Username Field Change
2012-11-11 13:07 stella Luna New Issue
2012-11-11 20:29 Robert Adams Assigned To => Robert Adams
2012-11-11 20:29 Robert Adams Status new => assigned
2012-11-12 07:36 stella Luna Git Revision or version number => OpenSim 0.7.5 Dev OSgrid 0.7.5 (Dev) 4f98259: 2012-11-10 (Unix/Mono)
2012-11-12 07:36 stella Luna Note Added: 0023100
2012-11-12 10:21 stella Luna Note Added: 0023101
2012-11-12 10:23 nebadon Note Added: 0023102
2012-11-12 11:25 stella Luna Note Added: 0023105
2012-11-28 13:40 Robert Adams Note Added: 0023181
2012-11-28 13:40 Robert Adams Status assigned => resolved
2012-11-28 13:40 Robert Adams Fixed in Version => master (dev code)
2012-11-28 13:40 Robert Adams Resolution open => fixed
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker