Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006420opensim[REGION] OpenSim Corepublic2012-11-10 20:152013-05-13 15:59
Reporterkenvc 
Assigned ToDiva 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformQuad core 8 gig ram 2.8 ghzOSWindowsOS Version8 64 bit
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006420: All simulators started crashing on startup right after #0 Rest Plugins not configured warning message
DescriptionUpdated to latest dev master today. Now all simulators crash shortly after startup right after seeing 2 warning about #0 Rest plugins not configured. Have to revert to get back online.

Steps To ReproduceJust start up the simulator and wait a few seconds for the crash
Additional Information2012-11-10 22:00:07,573 INFO - OpenSimProfile.Modules.OpenProfile.OpenProfileModule [PROFILE] OpenProfile module is activated
2012-11-10 22:00:07,578 WARN - OpenSim.ApplicationPlugins.Rest.RestPlugin [REST-HANDLER] #0 Rest Plugins not configured
2012-11-10 22:00:07,580 WARN - OpenSim.ApplicationPlugins.Rest.RestPlugin [REST-REGION] #0 Rest Plugins not configured

... then the console gives a terminating message that doesn't show up in the log. Screenshot attached shows the final error messages before the simulators terminate.
TagsNo tags attached.
Git Revision or version numberr20969
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Filesjpg file icon Console error message.jpg [^] (169,389 bytes) 2012-11-10 20:16

- Relationships

-  Notes
(0023084)
kenvc (reporter)
2012-11-10 20:44
edited on: 2012-11-10 20:55

Reverting to r20949 fixed the problem.
Results after GIT Bisect to locate bad commit:

791c4d5b9fe831cab3dd984184714e6e674918f9 is the first bad commit
commit 791c4d5b9fe831cab3dd984184714e6e674918f9
Author: Diva Canto <diva@metaverseink.com>
Date: Sat Nov 10 08:10:43 2012 -0800

One more module converted: J2KDecoderModule.

:040000 040000 23342cde0eb5307d4d64c2234cc4e0f9b71a0a28 69c8cfac39a7771e0457cc24260cd66d2a27e778 M OpenSim
Success (375 ms @ 11/10/2012 10:41:20 PM)

(0023086)
Diva (administrator)
2012-11-11 11:23

I'll fix it
(0023087)
Diva (administrator)
2012-11-11 11:24

Actually, I'm not sure what version you were when you were getting this. It may be fixed already. Give it a try with head.
(0023089)
kenvc (reporter)
2012-11-11 12:40
edited on: 2012-11-11 12:47

I had not updated in a few days, then updated to head and it started. After experimenting, I found it does this on every revision since that one including today's head. I even completely wiped out my git folder and re-pulled. Automatic batch files wipe out all old dlls and exes etc before copying the new files to the simulator folders.

(0023092)
Diva (administrator)
2012-11-11 13:35

Melanie fixed it. Pull and try.
(0023095)
kenvc (reporter)
2012-11-11 18:13
edited on: 2012-11-12 14:13

Diva & Melanie,
The latest code fixed the actual crashing issue, but the console still shows 2 warning messages that I don't recall ever seeing before as included below. Is there a setting I can change to get rid of these messages?

2012-11-11 20:09:23,626 WARN - OpenSim.ApplicationPlugins.Rest.RestPlugin [REST-HANDLER] #0 Rest Plugins not configured

2012-11-11 20:09:26,536 WARN - OpenSim.ApplicationPlugins.Rest.RestPlugin [REST-REGION] #0 Rest Plugins not configured
2


- Issue History
Date Modified Username Field Change
2012-11-10 20:15 kenvc New Issue
2012-11-10 20:16 kenvc File Added: Console error message.jpg
2012-11-10 20:17 kenvc Additional Information Updated View Revisions
2012-11-10 20:44 kenvc Note Added: 0023084
2012-11-10 20:55 kenvc Note Edited: 0023084 View Revisions
2012-11-11 11:23 Diva Note Added: 0023086
2012-11-11 11:23 Diva Assigned To => Diva
2012-11-11 11:23 Diva Status new => assigned
2012-11-11 11:24 Diva Note Added: 0023087
2012-11-11 12:40 kenvc Note Added: 0023089
2012-11-11 12:42 kenvc Note Edited: 0023089 View Revisions
2012-11-11 12:47 kenvc Note Edited: 0023089 View Revisions
2012-11-11 13:35 Diva Note Added: 0023092
2012-11-11 18:13 kenvc Note Added: 0023095
2012-11-12 14:13 kenvc Note Edited: 0023095 View Revisions
2013-05-13 15:59 kenvc Status assigned => resolved
2013-05-13 15:59 kenvc Fixed in Version => master (dev code)
2013-05-13 15:59 kenvc Resolution open => fixed
2013-05-13 15:59 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker