Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006373opensim[REGION] OpenSim Corepublic2012-10-24 06:182014-07-29 13:41
Reporterorenh 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0006373: [PATCH] Prevent some rare errors when loading/saving OARs
DescriptionThese patches fix some errors that can occur when loading or saving OARs:

1) 0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch

It's possible to time-out while saving the assets of an OAR or IAR. When that happens we now call the callback that had been waiting for the assets to finish; previously the callback wasn't called.

2) 0001-Changed-locks-to-prevent-deadlocks-especially-during.patch

Added locking to prevent some rare multithreading errors. I have seen these errors when loading multi-region OARs.
TagsNo tags attached.
Git Revision or version numberfc666a0ddb60c129585b23625d470a67647155be
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Filespatch file icon 0001-Changed-locks-to-prevent-deadlocks-especially-during.patch [^] (8,488 bytes) 2012-10-24 06:18 [Show Content]
patch file icon 0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch [^] (8,323 bytes) 2013-01-01 22:31 [Show Content]

- Relationships

-  Notes
(0023269)
orenh (administrator)
2012-12-16 06:36

Any updates about this patch? It fixed a real problem for me (albeit a rare one).
(0023353)
justincc (administrator)
2013-01-01 16:56

Hi Oren. I looked through the first patch and I'm happy to apply. However, the code has changed enough since October that it no longer applies cleanly. Please could you update it?

I hope to look through the second patch very soon but have run out of time today.
(0023355)
orenh (administrator)
2013-01-01 22:32

I have uploaded a new version of the file: "0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch". It applies cleanly on today's git master.
(0023360)
justincc (administrator)
2013-01-02 14:33

* If-Save-OAR-IAR... patch applied to git master as d24ca0d.

* Changed-locks-to-prevent... patch applied to git master as 9784e4e.

Thanks Oren.

- Issue History
Date Modified Username Field Change
2012-10-24 06:18 orenh New Issue
2012-10-24 06:18 orenh Status new => assigned
2012-10-24 06:18 orenh Assigned To => justincc
2012-10-24 06:18 orenh File Added: 0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch
2012-10-24 06:18 orenh File Added: 0001-Changed-locks-to-prevent-deadlocks-especially-during.patch
2012-10-24 06:18 orenh Status assigned => patch included
2012-12-16 06:36 orenh Note Added: 0023269
2013-01-01 16:56 justincc Note Added: 0023353
2013-01-01 22:31 orenh File Deleted: 0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch
2013-01-01 22:31 orenh File Added: 0001-If-Save-OAR-IAR-times-out-while-waiting-for-assets-t.patch
2013-01-01 22:32 orenh Note Added: 0023355
2013-01-02 14:33 justincc Note Added: 0023360
2013-01-02 14:33 justincc Status patch included => resolved
2013-01-02 14:33 justincc Resolution open => fixed
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker