Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006371opensim[REGION] OpenSim Corepublic2012-10-21 14:462012-10-29 13:35
ReporterPixel Tomsen 
Assigned Tomelanie 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformLinux64,Win32/64OSsuse , windowsOS Version12.1, 64bit
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0006371: Commit - Dwell=>http://opensimulator.org/viewgit/?a=commit&p=opensim&h=efae7c6fc27cc43134c531df9cb9b42e210fad5e [^]
DescriptionI think it is not good, the udp-handler function make use of a module, it should work it indipendent (if the module is not enabled, we generally get the safe value '0').

note this mantis http://opensimulator.org/mantis/view.php?id=5396, [^] please let me finish them
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022881)
melanie (administrator)
2012-10-21 14:53

Your already committed work which hardwired a handler breaks external (non core) dwell modules. The new approach using a minimal default dwell module makes use of the ReplaceableInterface method to allow grid runners to replace the dwell module function with one of their own without having to do any configuration.

Apart from the fact that having no core dwell support never did cause any issues except for a cosmetic viewer effect, core cannot support dwell fully.

Dwell depends on a centralized database of parcels with dwell data being collected and posted to that database. OpenSim doesn't support a central registry of parcels, so dwell is out of scope for core.

As it is now, 3rd party modules can still work, unlike your code which cripples 3rd party modules.

Since all core code should be runnable in a federated grid like OSGrid and that is not true for dwell, dwell cannot be put into core.

- Issue History
Date Modified Username Field Change
2012-10-21 14:46 Pixel Tomsen New Issue
2012-10-21 14:53 melanie Note Added: 0022881
2012-10-21 14:55 melanie Summary Commit: Dwell=>http://opensimulator.org/viewgit/?a=commit&p=opensim&h=efae7c6fc27cc43134c531df9cb9b42e210fad5e [^] => Commit - Dwell=>http://opensimulator.org/viewgit/?a=commit&p=opensim&h=efae7c6fc27cc43134c531df9cb9b42e210fad5e [^]
2012-10-21 14:55 melanie Status new => resolved
2012-10-21 14:55 melanie Resolution open => no change required
2012-10-21 14:55 melanie Assigned To => melanie
2012-10-29 13:35 Pixel Tomsen Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker