Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006360opensim[REGION] Script Functionspublic2012-10-14 15:052014-07-29 13:41
Reporterdanbanner 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOpenSimOSLinuxOS Version64bit
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006360: llGiveInventoryList causes an exception in the console
DescriptionUse of this function causes an exception and further execution of the script fails

Exception: http://pastebin.com/BJutyThQ [^]
Steps To Reproduce// When any user clicks this object, this script will give a folder containing everything in the objects inventory
// This could be used to give away multiple freebies at once.
 
default
{
    touch_start(integer total_number)
    {
        list inventory;
        integer num = llGetInventoryNumber(INVENTORY_ALL);
        string script = llGetScriptName();
        integer i = 0;
 
        for (; i < num; ++i) {
            string name = llGetInventoryName(INVENTORY_ALL, i);
            //Don't give them the selling script.
            if(name != script)
            {
                if(llGetInventoryPermMask(name, MASK_OWNER) & PERM_COPY)
                {
                    inventory += name;
                }
                else
                {
                    llSay(0, "Don't have permissions to give you \""+name+"\".");
                }
            }
        }
 
        if (llGetListLength(inventory) < 1)
        {
            llSay(0, "No items to offer.");
        }
        else
        {
            // give folder to agent, use name of object as name of folder we are giving
            llGiveInventoryList(llDetectedKey(0), llGetObjectName(), inventory);
            llSay(0,"This line is never reached due to an exception");
        }
    }
}
Additional InformationThe inventory is still sent, however the llSay typically used to indicate items were sent is never seen.
TagsNo tags attached.
Git Revision or version numberr/20706 (dc46057)
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE, BulletSim
EnvironmentMono / Linux64
Mono Version2.10
Viewerall
Attached Files

- Relationships
related to 0006311new llGiveInventoryList no longer functions as expected. 

-  Notes
(0022860)
justincc (administrator)
2012-10-15 18:42

Dan, please try git master ab0294f. Thanks.

- Issue History
Date Modified Username Field Change
2012-10-14 15:05 danbanner New Issue
2012-10-15 12:33 danbanner Relationship added related to 0006311
2012-10-15 18:42 justincc Note Added: 0022860
2012-10-16 15:53 justincc Status new => resolved
2012-10-16 15:53 justincc Resolution open => fixed
2012-10-16 15:53 justincc Assigned To => justincc
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker