Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006325opensim[REGION] OpenSim Corepublic2012-09-29 10:442015-02-28 16:36
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformPCOSWindowsOS VersionVista
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006325: [ASYNC REQUEST]: Request GET ... callback failed with exception Object reference not set to an instance of an object
DescriptionThis error is repeated continuosuly every 3 or 4 seconds.. but is apparently only on two assets.. repeated in pairs throughout...

18:42:03 - [ASYNC REQUEST]: Request GET http://assets.osgrid.org/assets/b95057e2 [^]
-3380-40cc-be72-bce67e202df5 callback failed with exception Object reference not
 set to an instance of an object. at OpenSim.Framework.AssetLandmark..ctor(Ass
etBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\Ass
etLandmark.cs:line 41

18:42:07 - [ASYNC REQUEST]: Request GET http://assets.osgrid.org/assets/ad21f100 [^]
-fc6c-4d2a-bb83-a313bfd8f538 callback failed with exception Object reference not
 set to an instance of an object. at OpenSim.Framework.AssetLandmark..ctor(Ass
etBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\Ass
etLandmark.cs:line 41
Steps To ReproduceReported as noted on OSGrid recent release 29-Sep-2012 r/20546 (osgrid.opensim-09282012.v0.7.5.4e9509d. Repeats every 3 or 4 seconds continuosuly and does not stop, But each is a pair of errors referring to justtwo assets

http://assets.osgrid.org/assets/b95057e2-3380-40cc-be72-bce67e202df5 [^]
http://assets.osgrid.org/assets/ad21f100-fc6c-4d2a-bb83-a313bfd8f538 [^]
Additional InformationFull report of error from Opensim.log

2012-09-29 18:29:44,341 ERROR - OpenSim.Framework.AsynchronousRestObjectRequester [ASYNC REQUEST]: Request GET http://assets.osgrid.org/assets/b95057e2-3380-40cc-be72-bce67e202df5 [^] callback failed with exception Object reference not set to an instance of an object. at OpenSim.Framework.AssetLandmark..ctor(AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\AssetLandmark.cs:line 41

   at OpenSim.Region.ScriptEngine.Shared.Api.LSL_Api.<>c__DisplayClasse.<llRequestInventoryData>b__d(String i, Object sender, AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Region\ScriptEngine\Shared\Api\Implementation\LSL_Api.cs:line 4158

   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Asset.HGAssetBroker.<>c__DisplayClass6.<Get>b__2(String assetID, Object s, AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Region\CoreModules\ServiceConnectorsOut\Asset\HGAssetBroker.cs:line 309

   at OpenSim.Services.Connectors.AssetServicesConnector.<>c__DisplayClass4.<Get>b__0(AssetBase _asset) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Services\Connectors\Asset\AssetServicesConnector.cs:line 193

   at OpenSim.Services.Connectors.AssetServicesConnector.<>c__DisplayClass4.<Get>b__1(AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Services\Connectors\Asset\AssetServicesConnector.cs:line 223

   at OpenSim.Framework.AsynchronousRestObjectRequester.<>c__DisplayClass4`2.<MakeRequest>b__2(IAsyncResult res2) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\WebUtil.cs:line 856

2012-09-29 18:29:48,553 ERROR - OpenSim.Framework.AsynchronousRestObjectRequester [ASYNC REQUEST]: Request GET http://assets.osgrid.org/assets/ad21f100-fc6c-4d2a-bb83-a313bfd8f538 [^] callback failed with exception Object reference not set to an instance of an object. at OpenSim.Framework.AssetLandmark..ctor(AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\AssetLandmark.cs:line 41

   at OpenSim.Region.ScriptEngine.Shared.Api.LSL_Api.<>c__DisplayClasse.<llRequestInventoryData>b__d(String i, Object sender, AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Region\ScriptEngine\Shared\Api\Implementation\LSL_Api.cs:line 4158

   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Asset.HGAssetBroker.<>c__DisplayClass6.<Get>b__2(String assetID, Object s, AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Region\CoreModules\ServiceConnectorsOut\Asset\HGAssetBroker.cs:line 309

   at OpenSim.Services.Connectors.AssetServicesConnector.<>c__DisplayClass4.<Get>b__0(AssetBase _asset) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Services\Connectors\Asset\AssetServicesConnector.cs:line 193

   at OpenSim.Services.Connectors.AssetServicesConnector.<>c__DisplayClass4.<Get>b__1(AssetBase a) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Services\Connectors\Asset\AssetServicesConnector.cs:line 223

   at OpenSim.Framework.AsynchronousRestObjectRequester.<>c__DisplayClass4`2.<MakeRequest>b__2(IAsyncResult res2) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-4e9509d\OpenSim\Framework\WebUtil.cs:line 856
TagsNo tags attached.
Git Revision or version number0.7.5 Dev r/20546
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022746)
melanie (administrator)
2012-09-29 10:52

Looks like that may be a bad landmark
(0022747)
aiaustin (developer)
2012-09-29 10:54
edited on: 2012-09-29 11:20

Reverting to the last OSGrid release 0.7.5 (Dev) 224efe7: 2012-09-11 with identical Opensim.db SQLite data base does NOT have this error. Then shifting again to r/20546 introduced it again consistently.

(0022748)
aiaustin (developer)
2012-09-29 10:56
edited on: 2012-09-29 11:19

Okay Melanie,... that could make sense... I have noticed some very odd behavioiur with landmarks saved via Firestorm recently. I have a couple inside objects in the affected region that are meant show on the map when you click them. I will check or replace. Thanks. Odd that it shows as an error in r/20546 from 28-Sep-2012 and not in the 11-Sep-2012 OSGrid release?

(0022749)
aiaustin (developer)
2012-09-29 11:19
edited on: 2012-09-29 11:20

Okay, I found two landmarks with the culprit UUIDs inside the contents of an object which brings up a location on the viewer map. Each landmark was saved in Firestorm latest release. When I replaced those landmarks with ones saved in another viewer and restarted the Opensim.exe instance, the errors went away.

I assume this must be a firestorm viewer problem perhaps at its root, but note it was an error that only showed up between the 11-Sep-2012 and 28-Sep-2012 releases of 0.7.5 dev master that were the last 2 releases for OSGrid add on region users. The error was present of cours ein the region opensim.exe instance and without any user logged in or a viewer involved. So a faulty asset perhaps created by Firestorm drove a continuous loop of errors that never stopped.

Thanks for your suggestion which led me straight to the issue Melanie. Much appreciated to let me get there quickly.

(0022751)
aiaustin (developer)
2012-09-29 13:02

Reported on Firestorm JIRA as issue FIRE-7816

- Issue History
Date Modified Username Field Change
2012-09-29 10:44 aiaustin New Issue
2012-09-29 10:47 aiaustin Description Updated View Revisions
2012-09-29 10:47 aiaustin Steps to Reproduce Updated View Revisions
2012-09-29 10:52 melanie Note Added: 0022746
2012-09-29 10:54 aiaustin Note Added: 0022747
2012-09-29 10:56 aiaustin Note Added: 0022748
2012-09-29 10:58 aiaustin Note Edited: 0022748 View Revisions
2012-09-29 11:19 aiaustin Note Added: 0022749
2012-09-29 11:19 aiaustin Note Edited: 0022748 View Revisions
2012-09-29 11:20 aiaustin Note Edited: 0022747 View Revisions
2012-09-29 11:20 aiaustin Note Edited: 0022749 View Revisions
2012-09-29 13:02 aiaustin Note Added: 0022751


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker