Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006300opensim[REGION] Specific OpenSim Modulepublic2012-09-17 05:072014-07-29 13:41
ReporterSignpostMarv 
Assigned Tomelanie 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006300: llAttachToAvatarTemp will not work
DescriptionllAttachToAvatarTemp is currently implemented in a region module via script invocations.

script invocations cannot currently have a void return type, thus llAttachToAvatarTemp will not be "found" despite being registered.
Steps To Reproducedefault
{
    touch_start(integer t)
    {
        llRequestPermissions(llDetectedKey(0), PERMISSION_ATTACH);
    }

    run_time_permissions(integer p)
    {
        if(p & PERMISSION_ATTACH)
        {
            llAttachToAvatarTemp((integer)ATTACH_RHAND);
        }
    }
}
Additional InformationDue to being a script invocation, one currently needs to cast script constants to integer.

Patch also fixes a bug with a null reference exception being thrown.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim)
Physics EngineBasicPhysics
Script Engine
Environment.NET / Windows32, .NET / Windows64
Mono VersionNone
Viewer
Attached Filespatch file icon llAttachToAvatarTemp-tweaks.patch [^] (3,856 bytes) 2012-09-17 05:07 [Show Content]

- Relationships
related to 0006366patch included osForceAttachToOtherAvatarTemp & osForceAttachToOtherAvatarFromInventoryTemp 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-09-17 05:07 SignpostMarv New Issue
2012-09-17 05:07 SignpostMarv File Added: llAttachToAvatarTemp-tweaks.patch
2012-09-17 05:07 SignpostMarv Status new => patch included
2012-09-17 05:33 melanie Status patch included => resolved
2012-09-17 05:33 melanie Resolution open => fixed
2012-09-17 05:33 melanie Assigned To => melanie
2012-10-18 08:52 SignpostMarv Relationship added related to 0006366
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker