Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006295opensim[REGION] OpenSim Corepublic2012-09-13 23:442013-08-26 07:13
Reporterthomax 
Assigned Tojustincc 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
Platformcross platformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006295: stop flotsam deleting dynamic textures
Descriptionhello,

i use dynamic textures regularly and i often find the prims blurred or white because a new load of the texture is in progress or it got deleted from the flotsam cache.

because dynamic textures are not stored in the database but on the (flotsam) cache, i think the cache should not delete it with each expire run. i talked about it on a dev meeting on osgrid and some other people agreed that this is a bit annoying, too.

that's why i wrote a little patch which works pretty well. it just stops the flotsam expire routine from removing the texture with asset.Name starting with "dynamicImage". i know it's not perfect but it points out that it should be possible.

there is a new issue coming along with the persistent textures. i didn't solved yet, because i see more than one way to solve it. it's what will happen if the object(s) which use the textures got deleted? the solutions i have in mind, are, 1) have an extra expire time for dynamic textures (which might be about several weeks or whatever) and 2) check in the deep scan if a dynamic texture is still used in any scene.

ok, that's all for now. please have a look at this little tiny patch which is just a working base. it's not yet ready for the repository but it works (for early adopters :-).

greetings,

tx Oh
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux64
Mono Version2.8
Viewer
Attached Filespatch file icon flotsam-no1.patch [^] (1,097 bytes) 2012-09-13 23:44 [Show Content]

- Relationships

-  Notes
(0022611)
justincc (administrator)
2012-09-14 17:31

Hi tx. Thanks for the patch. This does help me understand the problem that you're seeing and that blocking all deletion of dynamic textures does solve the issue. However, as we discussed in IRC this cannot be a final core OpenSim solution since it is too arbitrary.

Exactly what behaviour is triggering this problem? Is it multiple simultaneous or near simultaneous updates of a dynamic texture on the same prim?

And/or does it appear after asset expiry? From my reading of the code, this should not happen since existing objects are scanned for asset references (unless you did not have DeepScanBeforePurge = true in [AssetCache] or you had it set to false). In commit d5c8c6b I have changed this to always scan so please could you try this commit.
(0022612)
thomax (reporter)
2012-09-15 11:55

wow,

looks like we can close this. d5c8c6b just solve it.

great,

tx Oh
(0022632)
nebadon (administrator)
2012-09-18 11:23

fixed now
(0022646)
thomax (reporter)
2012-09-21 01:40

i'm so sorry. but i made further investigations and found that dynamic textures still get expired on the normal expire runs...
(0022656)
justincc (administrator)
2012-09-21 17:24

Ok, could you answer my previous questions above. Also, are these dynamic textures being used in the scene or in avatar attachments or similar?
(0022666)
thomax (reporter)
2012-09-22 20:22

it seems to be solved, but it isn't. the textures are in the scene. this means, that the situation is better now than before your changes. but under undefined circumstances it occurs that it still may happen (not regularly) that dynamic textures getting expired while they should stay in the scene.

i haven't found a reproduceable receipt yet.
i don't update the textures.
if it appears, than yes, after expire.
the textures are not on attachments, they are in the scene.
(0024287)
thomax (reporter)
2013-08-26 04:17

well, i think this could be closed :-)

- Issue History
Date Modified Username Field Change
2012-09-13 23:44 thomax New Issue
2012-09-13 23:44 thomax File Added: flotsam-no1.patch
2012-09-14 17:31 justincc Note Added: 0022611
2012-09-14 17:31 justincc Assigned To => justincc
2012-09-14 17:31 justincc Status new => assigned
2012-09-15 11:55 thomax Note Added: 0022612
2012-09-18 11:23 nebadon Note Added: 0022632
2012-09-18 11:23 nebadon Status assigned => closed
2012-09-18 11:23 nebadon Resolution open => fixed
2012-09-21 01:40 thomax Note Added: 0022646
2012-09-21 01:40 thomax Fixed in Version => master (dev code)
2012-09-21 17:23 justincc Status closed => feedback
2012-09-21 17:23 justincc Resolution fixed => reopened
2012-09-21 17:24 justincc Note Added: 0022656
2012-09-22 20:22 thomax Note Added: 0022666
2012-09-22 20:22 thomax Status feedback => assigned
2013-08-26 04:17 thomax Note Added: 0024287
2013-08-26 07:13 nebadon Status assigned => closed
2013-08-26 07:13 nebadon Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker