Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006278opensim[REGION] OpenSim Corepublic2012-09-08 13:552012-09-09 15:17
ReporterBruce 
Assigned ToBlueWall 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDedicated ServerOSWindows 2008 Standard ServerOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006278: UUID GATHERER exceptions
DescriptionUUID GATHERER exceptions for HG enabled Standalone on windows x64 and linux x64 (thanks zardak for confirming the latter).
Additional InformationMultiple red line errors in region console (example):
[UUID GATHERER]: Failed to gather uuids for asset id [asset uuid], type LSLText
[UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object.
[UUID GATHERER]: Texture entry length for prim was 76 (min is 46)

Maybe related to mantis 004977 (thanks noud for finding this)

Last good commit appears to be r/20258 of 06-Sep-12 (thanks zardak for helping to test this)
TagsNo tags attached.
Git Revision or version number4e2805496cfbdb07e0bada2f9e36fcea0989c60d (r/20267 of 06-Sep-12)
Run Mode Standalone (Multiple Regions)
Physics EngineODE
EnvironmentUnknown
Mono VersionNone
ViewerImprudence 1.4.0.3
Attached Files

- Relationships

-  Notes
(0022553)
zadark (reporter)
2012-09-08 14:02

Here is a sample exception from a simple single region configured as standalone HG, hosted on Linux x64

21:10:58 - [UUID GATHERER]: Failed to gather uuids for asset id a1cd9ad4-cc65-4441-a0f6-268718e9b6c9, type Notecard
21:10:58 - [UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetAsset (UUID uuid) [0x00007] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:220
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetTextEmbeddedAssetUuids (UUID embeddingAssetId, IDictionary`2 assetUuids) [0x00000] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:249
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids (UUID assetUuid, AssetType assetType, IDictionary`2 assetUuids) [0x00051] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:108
21:10:58 - [UUID GATHERER]: Texture entry length for prim was 46 (min is 46)
21:10:58 - [UUID GATHERER]: Failed to gather uuids for asset id 5a897550-2401-4f23-aea5-6bc3051d90d6, type LSLText
21:10:58 - [UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetAsset (UUID uuid) [0x00007] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:220
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetTextEmbeddedAssetUuids (UUID embeddingAssetId, IDictionary`2 assetUuids) [0x00000] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:249
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids (UUID assetUuid, AssetType assetType, IDictionary`2 assetUuids) [0x00067] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:112
21:10:58 - [UUID GATHERER]: Texture entry length for prim was 46 (min is 46)
21:10:58 - [UUID GATHERER]: Failed to gather uuids for asset id 9d469609-f5be-49a6-a4db-0fad849f8ff8, type LSLText
21:10:58 - [UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetAsset (UUID uuid) [0x00007] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:220
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetTextEmbeddedAssetUuids (UUID embeddingAssetId, IDictionary`2 assetUuids) [0x00000] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:249
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids (UUID assetUuid, AssetType assetType, IDictionary`2 assetUuids) [0x00067] in /home/user1/opensimdev/opensim/OpenSim/Region/Framework/Scenes/UuidGatherer.cs:112
21:10:58 - [UUID GATHERER]: Texture entry length for prim was 46 (min is 46)
(0022561)
kenvc (reporter)
2012-09-09 07:26

Updated to the latest dev master r20282 last night with all sims connected to OSGrid. Havent updated for about a week. I got the same red error spew on every sim in every instance as described above. Some sims were still spewing this morning when I found it filling up the log files.

I restarted all the instances this morning and so far it hasn't started doing this again. I don't know if this was a one time glitch with OSGrid, but I think not because the original issue described in this Mantis says it was on a stand-alone system. Running Windows 64 Professional, 8 gig ram, multiple instances connected to OSGrid.
(0022563)
kenvc (reporter)
2012-09-09 10:29
edited on: 2012-09-09 10:30

Update:

Spew started back up after sim sat there a while. Appeared to maybe start up after an AV antered the sim but not sure what triggered it. I am not running a stand-alone system, so this issue is not limited to just stand-alones.

Looking at one of the log files, it appears the red spew gets triggered exactly once an hour. Going to revert one ver at a time until the issue goes away.

(0022568)
zadark (reporter)
2012-09-09 14:18

Updated to r/20285 (720685cb9d510410936d8a61dca0efd7fe41a5b4)

Monitor updated sim for several hours and NO UUID GATHERER exceptions reported.
(0022569)
kenvc (reporter)
2012-09-09 14:35

updated to r20285 and have been running for 2-3 hours and have not seen this problem again.
(0022570)
BlueWall (administrator)
2012-09-09 15:17

Thanks, I made some changes to the way FlotsamCache loads. The unit tests and manual testing was OK here. I did find a way to trigger the message and reverting the work fixed it. So, we'll say that it's fixed.

- Issue History
Date Modified Username Field Change
2012-09-08 13:55 Bruce New Issue
2012-09-08 14:02 zadark Note Added: 0022553
2012-09-09 07:26 kenvc Note Added: 0022561
2012-09-09 10:29 kenvc Note Added: 0022563
2012-09-09 10:30 kenvc Note Edited: 0022563 View Revisions
2012-09-09 14:18 zadark Note Added: 0022568
2012-09-09 14:35 kenvc Note Added: 0022569
2012-09-09 15:17 BlueWall Note Added: 0022570
2012-09-09 15:17 BlueWall Status new => resolved
2012-09-09 15:17 BlueWall Fixed in Version => master (dev code)
2012-09-09 15:17 BlueWall Resolution open => fixed
2012-09-09 15:17 BlueWall Assigned To => BlueWall
2012-09-09 15:17 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker