Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006270opensim[REGION] Specific OpenSim Modulepublic2012-09-06 00:052012-10-18 00:49
Reporterhiro_lecker 
Assigned ToBlueWall 
PrioritynormalSeveritymajorReproducibilityalways
Statuspatch feedbackResolutionfixed 
PlatformOScentosOS Version5.8
Product Version 
Target VersionFixed in Version 
Summary0006270: Warp3D leaks memory on mono based systems
Descriptionenable the warp3d module on mono based systems.
It starts to eat huge of memory.

I created patch which corrects it. see below.
it look worked fine,
reduse using memory (1GB -> 500MB) after patched.

--- OpenSim/Region/CoreModules/World/Warp3DMap/Warp3DImageModule.cs.orig 2012-08-20 16:58:34.000000000 +0900
+++ OpenSim/Region/CoreModules/World/Warp3DMap/Warp3DImageModule.cs 2012-09-06 15:46:28.000000000 +0900
@@ -208,6 +208,9 @@
                     bitmap = ImageUtils.ResizeImage(origBitmap, viewport.Width, viewport.Height);
             }

+ GC.Collect();
+ m_log.Debug("[WARP 3D IMAGE MODULE]: GC.Collect()");
+
             return bitmap;
         }
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Files

- Relationships
related to 0006034closedDigi Fly Warp3D Map module increase memory usage without end. 

-  Notes
(0022521)
BlueWall (administrator)
2012-09-06 02:52

patch applied: 5eb2526e889c

Thanks
(0022525)
justincc (administrator)
2012-09-06 16:50

I'm reopening this mantis for tracking purposes - the patch remains applied at this point.

Hiro - does manually calling GC.Collect() really make a big difference here? In principle, one would expect a GC collect to occur fairly shortly afterwards anyway, and manually doing this is generally regarded as a bad idea.
(0022608)
hiro_lecker (reporter)
2012-09-13 03:07

ahhh, sry. I was mistake.
It was not effective although I observed the memory usage of consumption for 7days.

please remove this patch.
(0022813)
IshTom (reporter)
2012-10-08 11:43
edited on: 2012-10-11 14:15

I was faced the same memory problem with mono 2.10 / Linux32.(CentOS 5.8)

But I think that the cause was not by warp3D.
By deleting(comment out) warp3D, memory leak was not fixed with my Linux32.

After all effort, finally I changed the OS to CentOS 5.8 x86_64 (Linux64).
Then the big memory leak had almost gone.

Now I see many "[WARP 3D IMAGE MODULE]: GC.Collect()" messages
in my console with 0.7.5.4e9509d [r/20546].
It may be increasing CPU usage.
Please think about GC.Collect ON/OFF feature by ini file.
Default ON may help Linux32 servers.


- Issue History
Date Modified Username Field Change
2012-09-06 00:05 hiro_lecker New Issue
2012-09-06 00:05 hiro_lecker Status new => patch included
2012-09-06 02:52 BlueWall Note Added: 0022521
2012-09-06 02:52 BlueWall Status patch included => resolved
2012-09-06 02:52 BlueWall Resolution open => fixed
2012-09-06 02:52 BlueWall Assigned To => BlueWall
2012-09-06 16:49 justincc Status resolved => patch feedback
2012-09-06 16:50 justincc Note Added: 0022525
2012-09-06 16:52 justincc Relationship added related to 0006034
2012-09-13 03:07 hiro_lecker Note Added: 0022608
2012-10-08 11:43 IshTom Note Added: 0022813
2012-10-08 11:45 IshTom Note Edited: 0022813 View Revisions
2012-10-08 11:47 IshTom Note Edited: 0022813 View Revisions
2012-10-08 11:47 IshTom Note Edited: 0022813 View Revisions
2012-10-11 14:15 IshTom Note Edited: 0022813 View Revisions
2012-10-18 00:49 IshTom Note Added: 0022870
2012-10-18 00:49 IshTom Note Deleted: 0022870


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker