Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006264opensim[REGION] Script Functionspublic2012-09-01 09:112012-09-03 16:10
ReporterSignpostMarv 
Assigned Tomelanie 
PrioritynormalSeverityminorReproducibilityalways
Statuspatch includedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006264: scripted prim rotations work when they don't in SL
DescriptionWhile testing to see if a refactor I wrote broke anything, I discovered that OpenSim was rotating linksets when Second Life doesn't.

Repro script tested on a 4-prim linkset.
Steps To Reproducedefault
{
    touch_start(integer t)
    {
        llSetPrimitiveParams([
            PRIM_LINK_TARGET,
                2,
            PRIM_ROT_LOCAL,
                llEuler2Rot(<1,0,PI_BY_TWO>),
            PRIM_LINK_TARGET,
                3,
            PRIM_ROT_LOCAL,
                llEuler2Rot(<0,1,PI>),
            PRIM_LINK_TARGET,
                4,
            PRIM_ROT_LOCAL,
                llEuler2Rot(<0,0,TWO_PI>)
        ]);
        
        llOwnerSay("foo");
        state a;
    }
}

state a
{
    touch_start(integer t)
    {
        llSetPrimitiveParams([
            PRIM_LINK_TARGET,
                2,
            PRIM_ROTATION,
                llEuler2Rot(<1,0,PI_BY_TWO>),
            PRIM_LINK_TARGET,
                3,
            PRIM_ROTATION,
                llEuler2Rot(<0,1,PI>),
            PRIM_LINK_TARGET,
                4,
            PRIM_ROTATION,
                llEuler2Rot(<0,0,TWO_PI>)
        ]);
        
        llOwnerSay("bar");
        state default;
    }
}
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBasicPhysics
Script Engine
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Filespatch file icon SecondLife-rots.patch [^] (5,838 bytes) 2012-09-02 12:21 [Show Content]
? file icon Mantis-6264.iar [^] (86,552 bytes) 2012-09-03 04:47

- Relationships

-  Notes
(0022508)
SignpostMarv (reporter)
2012-09-01 09:15

ah yes; it helps to set the root prim rotation to something other than ZERO_ROTATION.
(0022509)
SignpostMarv (reporter)
2012-09-01 09:46

deleted patch because it's a mess.
(0022510)
melanie (administrator)
2012-09-01 10:22

Bad points:

- megapatch, it is not possible to separate the actual fix from formatting
- Refotmatting unrelated code should not be done together with a fix. Also, as opensim is an upstream project, reformatting is generally very low priority as it is sure to break merges. Better not to.
- Changes behavior of low level functions and will therefore break content. There is no option provided to turn it off.
- Overuse of regions hampers non-windows developers as those are easy to break and hard to fix outside of VC#

-1
(0022511)
melanie (administrator)
2012-09-02 12:12

Reopened by request
(0022512)
SignpostMarv (reporter)
2012-09-02 12:21

New patch. Observations seem to indicate that getting the rotation is correct, but that local rots were already taken care of somewhere else in the code, so LSL_Api.cs did not need to correct child rotations itself.
(0022513)
melanie (administrator)
2012-09-02 14:59

please test root prim (both rot and local rot) ensuring that each actually does a rotation (and is not a no-op) as well as attachments
(0022514)
SignpostMarv (reporter)
2012-09-03 04:47
edited on: 2012-09-03 04:53

root prim & attachment rots do not behave differently under the patch. Patch appears to behave similarly to SL with regards to root prims, child prims and attachments.

(0022515)
justincc (administrator)
2012-09-03 16:10

Re-opened as the behaviour in the patch is new to Second Life and may be reverted because it breaks existing content. Taking a wait and see approach.

- Issue History
Date Modified Username Field Change
2012-09-01 09:11 SignpostMarv New Issue
2012-09-01 09:11 SignpostMarv File Added: accidental-rot-fix.patch
2012-09-01 09:12 SignpostMarv Status new => patch included
2012-09-01 09:15 SignpostMarv Note Added: 0022508
2012-09-01 09:46 SignpostMarv File Deleted: accidental-rot-fix.patch
2012-09-01 09:46 SignpostMarv Note Added: 0022509
2012-09-01 10:22 melanie Note Added: 0022510
2012-09-01 10:22 melanie Status patch included => closed
2012-09-01 10:22 melanie Assigned To => melanie
2012-09-01 10:22 melanie Resolution open => won't fix
2012-09-02 12:12 melanie Note Added: 0022511
2012-09-02 12:12 melanie Status closed => feedback
2012-09-02 12:12 melanie Resolution won't fix => reopened
2012-09-02 12:13 melanie Status feedback => new
2012-09-02 12:21 SignpostMarv File Added: SecondLife-rots.patch
2012-09-02 12:21 SignpostMarv Note Added: 0022512
2012-09-02 12:21 SignpostMarv Status new => patch included
2012-09-02 14:59 melanie Note Added: 0022513
2012-09-03 04:47 SignpostMarv Note Added: 0022514
2012-09-03 04:47 SignpostMarv File Added: Mantis-6264.iar
2012-09-03 04:53 SignpostMarv Note Edited: 0022514 View Revisions
2012-09-03 06:13 melanie Status patch included => resolved
2012-09-03 06:13 melanie Resolution reopened => fixed
2012-09-03 16:10 justincc Note Added: 0022515
2012-09-03 16:10 justincc Status resolved => patch included


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker