Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006186opensim[REGION] Physics Enginespublic2012-08-13 13:502014-07-29 13:41
Reportercmickeyb 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0006186: flying avatars crossing region borders sink after the crossing
DescriptionFlying across a region border causes the avatar to sink in the new region when it stops flying. Landings and walking become erratic and jumpy.
TagsNo tags attached.
Git Revision or version number3a55d5b123dabbe
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022171)
Robert Adams (administrator)
2012-08-16 15:09

It does look like the flying flag is getting lost on a region crossing. There is also a hiccup in avatar walking movement. They both will be examined.

It looks like the fix for the avatar on terrain problem solved the 'erratic and jumpy' problem.
(0022172)
Robert Adams (administrator)
2012-08-17 13:43

Problem was the resetting of the flying state as the border is crossed.
Fixed in 03d76e94034bbaa82d1872284d1fadbaa263411d

- Issue History
Date Modified Username Field Change
2012-08-18 04:32 DMX04 New Issue
2012-08-18 04:32 DMX04 Issue generated from: 0006153
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker