Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006170opensim[REGION] Scripting Enginepublic2012-08-17 05:052012-09-07 17:04
ReporterSignpostMarv 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionreopened 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006170: LSL List implementation with regards to llSetPrimitiveParams deviates from Second Life implementation
Descriptionthe script engine is performing typecasting on list.GetLSLStringItem and other functions when it should be throwing an InvalidCastException in order to produce error messages like "string expected but vector given."
Steps To Reproduce
default
{
    state_entry()
    {
        llSetPrimitiveParams([
            PRIM_TEXT,
                ZERO_VECTOR,
                ZERO_VECTOR,
                1
        ]);
    }
}
TagsNo tags attached.
Git Revision or version numberdc82ad0
Run ModeStandalone (1 Region)
Physics EngineBasicPhysics
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022392)
justincc (administrator)
2012-08-20 12:32

Reported not fixed.
(0022480)
justincc (administrator)
2012-08-29 16:21

SignpostMarv, is this still a problem since your other patches or can it now be closed?
(0022481)
SignpostMarv (reporter)
2012-08-29 16:22

I didn't fix it in my patches as I wasn't sure if the current behaviour was intended.
(0022544)
justincc (administrator)
2012-09-07 17:04

I do not believe such behaviour was intended.

- Issue History
Date Modified Username Field Change
2012-08-17 05:05 SignpostMarv New Issue
2012-08-17 05:05 SignpostMarv Relationship added related to 0006169
2012-08-17 15:13 justincc Status new => resolved
2012-08-17 15:13 justincc Resolution open => fixed
2012-08-17 15:13 justincc Assigned To => justincc
2012-08-18 04:32 DMX04 Issue cloned: 0006183
2012-08-20 12:32 justincc Assigned To justincc =>
2012-08-20 12:32 justincc Note Added: 0022392
2012-08-20 12:32 justincc Status resolved => feedback
2012-08-20 12:32 justincc Resolution fixed => reopened
2012-08-29 16:21 justincc Note Added: 0022480
2012-08-29 16:22 SignpostMarv Note Added: 0022481
2012-08-29 16:22 SignpostMarv Status feedback => new
2012-09-07 17:04 justincc Note Added: 0022544


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker