Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006168opensim[REGION] Physics Enginespublic2012-08-16 20:072013-05-13 15:58
Reporterkenvc 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformQuad core 8 gig ramOSWindowsOS Version7 64 bit
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006168: Bulletsim: AV drops through the ground down to a height of 2m on all mega region sims unless you are on the first sim
DescriptionAV drops right through the ground down to a height of 2m on all mega region sims unless you are on the first sim when using latest Bulletsim. Its as though the ground is not even there. It works fine only on the main sim 0000001 of the mega region.

If the AV is standing on a prim it is usually OK, but if it tries to stand directly on the ground, it drops through the ground and stops at a Z height of 2 meters.
TagsNo tags attached.
Git Revision or version numberr20061
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerNA
Attached Files

- Relationships

-  Notes
(0022101)
Robert Adams (administrator)
2012-08-17 10:07

BulletSim does not implement PhysicsScene.Combine() and PhysicsScene.UnCombine() functions so it doesn't know about the larger combined terrain. Code that does what ODE does will be added.
(0022107)
Robert Adams (administrator)
2012-08-17 14:54

Didn't fix this problem yet. I fixed something else.
(0022115)
kenvc (reporter)
2012-08-17 16:49

Yes, just tested with the latest dev master and issue is still the same.
(0022419)
zadark (reporter)
2012-08-23 07:24

The issue is also apparent using single region simulators as of current dev/master 4820dfd
(0022501)
Robert Adams (administrator)
2012-08-31 12:57

Mega-regions should be working in BulletSim as of 32b534f324c0d69b3b56746a07e80ab38d7dd546 (Fri Aug 31 1840 GMT).

- Issue History
Date Modified Username Field Change
2012-08-16 20:07 kenvc New Issue
2012-08-17 08:47 kenvc Description Updated View Revisions
2012-08-17 10:05 Robert Adams Assigned To => Robert Adams
2012-08-17 10:05 Robert Adams Status new => assigned
2012-08-17 10:07 Robert Adams Note Added: 0022101
2012-08-17 10:07 Robert Adams Status assigned => confirmed
2012-08-17 14:48 Robert Adams Status confirmed => resolved
2012-08-17 14:48 Robert Adams Fixed in Version => master (dev code)
2012-08-17 14:48 Robert Adams Resolution open => fixed
2012-08-17 14:54 Robert Adams Note Added: 0022107
2012-08-17 14:54 Robert Adams Status resolved => assigned
2012-08-17 16:49 kenvc Note Added: 0022115
2012-08-18 04:32 DMX04 Issue cloned: 0006179
2012-08-19 13:46 kenvc Relationship added related to 0006179
2012-08-23 07:24 zadark Note Added: 0022419
2012-08-31 12:57 Robert Adams Note Added: 0022501
2012-08-31 12:57 Robert Adams Status assigned => resolved
2013-05-13 15:58 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker