Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006167opensim[REGION] Physics Enginespublic2012-08-16 15:422014-07-29 13:41
ReporterRobert Adams 
Assigned ToRobert Adams 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0006167: BulletSim: mega-prims with curves are not meshed correctly
DescriptionCurvey mega-prims (cylinders and such) do not have the same collision and physical shape.
Steps To ReproduceCreate a cylinder. Set X and Y to 50 and Z to 10. Path cut B to .40 then position resulting wall just above terrain. Walk around the construction. You will find that the physical shape of the object is not the same shape as the visible object. Looking at it in wireframe, it looks like the physical shape is 1/3 or 1/4 the LOD as the visible prim.
TagsNo tags attached.
Git Revision or version numberc2210825d9a9abd2186f302f39d54b61accf034b
Run Mode Standalone (Multiple Regions)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022106)
Robert Adams (administrator)
2012-08-17 14:51

Added parameters and code to cause mega-prims to be meshed at a higher resolution.

- Issue History
Date Modified Username Field Change
2012-08-16 15:42 Robert Adams New Issue
2012-08-16 15:42 Robert Adams Status new => assigned
2012-08-16 15:42 Robert Adams Assigned To => Robert Adams
2012-08-17 14:51 Robert Adams Note Added: 0022106
2012-08-17 14:51 Robert Adams Status assigned => resolved
2012-08-17 14:51 Robert Adams Resolution open => fixed
2012-08-18 04:32 DMX04 Issue cloned: 0006184
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker