Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006163opensim[REGION] Physics Enginespublic2012-08-16 11:292014-07-29 13:41
Reporterzadark 
Assigned ToRobert Adams 
PrioritynoneSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version3.2.0-23-generic
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006163: BulletSim enabled: Crash during startup
DescriptionCrash during startup
Steps To ReproduceEnable BulletSim
Start Simulator
Additional information includes console output from 2 separate Lunux x64 installations. First is Ubuntu 12.04 (simple flat land, few prims and no scripts), the second is Fedora 14 (several hundred prims and scripts)
Additional InformationUbuntu 2.10.8
[WATCHDOG]: Started tracking thread Incoming Packets (hrethra4), ID 16
[WATCHDOG]: Started tracking thread Outgoing Packets (hrethra4), ID 17
[WATCHDOG]: Started tracking thread Heartbeat (hrethra4), ID 18
[SCENE]: Starting scripts in hrethra4, please wait.
Stacktrace:

Native stacktrace:

        mono() [0x4916ba]
        mono() [0x4e0d4f]
        mono() [0x41bc77]
        /lib/x86_64-linux-gnu/libpthread.so.0(+0xfcb0) [0x7fad5d539cb0]
        lib64/libBulletSim.so(_ZN13TerrainObjectC1EP9WorldDatajPf+0xc4) [0x7fad400cb784]
        lib64/libBulletSim.so(_ZN9BulletSim12SetHeightmapEPf+0x6d) [0x7fad400beabf]
        lib64/libBulletSim.so(SetHeightmap+0x34) [0x7fad400b62cb]
        [0x408ef0aa]
10:55:07 - [PERMISSIONS]: Groups module not found, group permissions will not work

Debug info from gdb:

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted

Fedora using Mono 2.6.7
[WATCHDOG]: Started tracking thread Incoming Packets (hrethra), ID 9
[WATCHDOG]: Started tracking thread Outgoing Packets (hrethra), ID 10
[WATCHDOG]: Started tracking thread Heartbeat (hrethra), ID 11
[SCENE]: Starting scripts in hrethra, please wait.
[PERMISSIONS]: Groups module not found, group permissions will not work
[REGIONMODULES]: PostInitializing...
Stacktrace:

Native stacktrace:

        mono() [0x4893f1]
        mono() [0x4d13ef]
        /lib64/libpthread.so.0() [0x3f17c0eeb0]
        lib64/libBulletSim.so(_ZN13TerrainObjectC1EP9WorldDatajPf+0xc4) [0x7f3dc843a784]
        lib64/libBulletSim.so(_ZN9BulletSim12SetHeightmapEPf+0x6d) [0x7f3dc842dabf]
        lib64/libBulletSim.so(SetHeightmap+0x34) [0x7f3dc84252cb]
        [0x4103602a]

Debug info from gdb:

19:18:58 - [LLLOGIN IN CONNECTOR
]: Starting...
Currently selected region is hrethra
19:18:58 - [STARTUP
]: Non-script portion of startup took 0m 6s. PLEASE WAIT FOR LOGINS TO BE ENABLED ON REGIONS ONCE SCRIPTS HAVE STARTED.
$<5>Region (hrethra$<5>Mono support loaded.
[Thread debugging using libthread_db enabled]
[New Thread 0x7f3dbe950700 (LWP 2214)]
[New Thread 0x7f3dbe991700 (LWP 2213)]
[New Thread 0x7f3de6f62700 (LWP 2212)]
[New Thread 0x7f3dbdb09700 (LWP 2211)]
TagsNo tags attached.
Git Revision or version number57a9879
Run ModeStandalone (1 Region)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version2.10
ViewerNA
Attached Files

- Relationships

-  Notes
(0023180)
Robert Adams (administrator)
2012-11-28 13:38

Zadar, there have been a few updates to BulletSim since this crash report. I have been running BulletSim on test regions one Ubuntu 64bit systems and haven't had this crash. Is this crash still happening for you?
(0023240)
Robert Adams (administrator)
2012-12-14 13:14

This particular crash was a physical object that rezzed below the terrain. The check that applied a force to move below terrain objects was getting invoked before the object was created in the world. In general, accesses to the physical object have been protected by an existence check.

- Issue History
Date Modified Username Field Change
2012-08-16 11:29 zadark New Issue
2012-08-18 04:32 DMX04 Issue cloned: 0006193
2012-11-19 10:52 Robert Adams Assigned To => Robert Adams
2012-11-19 10:52 Robert Adams Status new => assigned
2012-11-28 13:38 Robert Adams Note Added: 0023180
2012-12-14 13:14 Robert Adams Note Added: 0023240
2012-12-14 13:14 Robert Adams Status assigned => resolved
2012-12-14 13:14 Robert Adams Fixed in Version => master (dev code)
2012-12-14 13:14 Robert Adams Resolution open => fixed
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker