Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006153opensim[REGION] Physics Enginespublic2012-08-13 13:502014-07-29 13:41
Reportercmickeyb 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0006153: flying avatars crossing region borders sink after the crossing
DescriptionFlying across a region border causes the avatar to sink in the new region when it stops flying. Landings and walking become erratic and jumpy.
TagsNo tags attached.
Git Revision or version number3a55d5b123dabbe
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0022100)
Robert Adams (administrator)
2012-08-16 15:09

It does look like the flying flag is getting lost on a region crossing. There is also a hiccup in avatar walking movement. They both will be examined.

It looks like the fix for the avatar on terrain problem solved the 'erratic and jumpy' problem.
(0022104)
Robert Adams (administrator)
2012-08-17 13:43

Problem was the resetting of the flying state as the border is crossed.
Fixed in 03d76e94034bbaa82d1872284d1fadbaa263411d

- Issue History
Date Modified Username Field Change
2012-08-13 13:50 cmickeyb New Issue
2012-08-13 13:50 cmickeyb Status new => assigned
2012-08-13 13:50 cmickeyb Assigned To => Robert Adams
2012-08-16 15:09 Robert Adams Note Added: 0022100
2012-08-16 15:09 Robert Adams Status assigned => confirmed
2012-08-17 13:43 Robert Adams Mono Version trunk => None
2012-08-17 13:43 Robert Adams Note Added: 0022104
2012-08-17 13:43 Robert Adams Status confirmed => resolved
2012-08-17 13:43 Robert Adams Fixed in Version => master (dev code)
2012-08-17 13:43 Robert Adams Resolution open => fixed
2012-08-18 04:32 DMX04 Issue cloned: 0006186
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker