Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006044opensim[MISC] Compiling / Buildingpublic2012-06-07 06:482012-06-08 00:26
ReporterWhiteStar 
Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0006044: Building master currently fails
DescriptionBuild FAILED.

"C:\GIT\opensim\opensim.sln" (default target) (1) ->
"C:\GIT\opensim\OpenSim\Framework\Servers\HttpServer\OpenSim.Framework.Servers.HttpServer.csproj" (default target) (7) ->
(CoreCompile target) ->
  OSHttpRequest.cs(110,26): warning CS0618: 'HttpServer.IHttpClientContext.Secured' is obsolete: 'Use IsSecured instead.'


"C:\GIT\opensim\opensim.sln" (default target) (1) ->
"C:\GIT\opensim\OpenSim\Framework\Servers\HttpServer\OpenSim.Framework.Servers.HttpServer.csproj" (default target) (7) ->
(CoreCompile target) ->
  PollServiceRequestManager.cs(62,17): error CS0012: The type 'System.Func`1<T0>' is defined in an assembly that is not refe
renced. You must add a reference to assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
'.

    1 Warning(s)
    1 Error(s)

Time Elapsed 00:00:01.15
Steps To Reproduceprebuild & compile
TagsNo tags attached.
Git Revision or version number7550b97-r/19237
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Filespatch file icon 0002-Mantis-6044-Building-master-currently-fails.patch [^] (693 bytes) 2012-06-07 08:04 [Show Content]

- Relationships

-  Notes
(0021628)
BlueWall (administrator)
2012-06-07 07:19

Fixed in 21f6572bf33309fa926dfb6fdab7be795c74e379
Thanks!
(0021629)
Talun (manager)
2012-06-07 08:03

Looks like it needs a tweak in prebuild.xml too for the problem with PollServiceRequestManager.cs
Patch will be uploaded shortly
(0021630)
Talun (manager)
2012-06-07 08:34
edited on: 2012-06-07 08:37

My patch was committed by BlueWall as r/19239
Checked out into a different repo. Retested and windows build is now fine for me once runprebuild.bat had been run


- Issue History
Date Modified Username Field Change
2012-06-07 06:48 WhiteStar New Issue
2012-06-07 07:19 BlueWall Assigned To => BlueWall
2012-06-07 07:19 BlueWall Status new => assigned
2012-06-07 07:19 BlueWall Note Added: 0021628
2012-06-07 07:19 BlueWall Status assigned => resolved
2012-06-07 07:19 BlueWall Fixed in Version => master (dev code)
2012-06-07 07:19 BlueWall Resolution open => fixed
2012-06-07 07:19 BlueWall Status resolved => closed
2012-06-07 08:03 Talun Note Added: 0021629
2012-06-07 08:03 Talun Status closed => feedback
2012-06-07 08:03 Talun Resolution fixed => reopened
2012-06-07 08:03 Talun Status feedback => new
2012-06-07 08:04 Talun Status new => patch included
2012-06-07 08:04 Talun File Added: 0002-Mantis-6044-Building-master-currently-fails.patch
2012-06-07 08:06 Talun Assigned To BlueWall => Talun
2012-06-07 08:06 Talun Status patch included => assigned
2012-06-07 08:06 Talun Assigned To Talun =>
2012-06-07 08:07 Talun Status assigned => patch included
2012-06-07 08:34 Talun Note Added: 0021630
2012-06-07 08:35 Talun Status patch included => resolved
2012-06-07 08:35 Talun Resolution reopened => fixed
2012-06-07 08:35 Talun Assigned To => Talun
2012-06-07 08:36 Talun Status resolved => assigned
2012-06-07 08:37 Talun Note Edited: 0021630 View Revisions
2012-06-07 08:37 Talun Status assigned => resolved
2012-06-08 00:26 Talun Status resolved => closed
2012-06-08 00:26 Talun Assigned To Talun =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker