Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006008opensim[REGION] Specific OpenSim Modulepublic2012-05-06 04:482014-07-29 13:41
Reporterorenh 
Assigned Tojustincc 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006008: [PATCH] Save the Telehub in the OAR file
DescriptionChanged the OAR format to include the Telehub and its Spawn Points, if they exist.
Steps To Reproduce1. Define a Telehub in a region.
2. Save OAR: the OAR's settings file will contain the telehub object UUID and the location of its spawn points.
3. Load OAR: the telehub and its spawn points will be restored. The telehub will have a different UUID because Load OAR assigns new UUID's to all the objects.
TagsNo tags attached.
Git Revision or version numbercbfc579e242eaec39aeaad413d37b65a1280b091
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Filespatch file icon 0001-Save-the-Telehub-and-its-Spawn-Points-in-the-OAR.patch [^] (12,043 bytes) 2012-05-06 04:48 [Show Content]

- Relationships

-  Notes
(0021408)
BlueWall (administrator)
2012-05-10 20:02

Applied, Thanks!
(0021418)
justincc (administrator)
2012-05-11 18:41

Reverted, possibly temporarily, i ngit master 8b958e7.

    Sorry BlueWall, I wanted to discuss an aspect of the data storage but I couldn't assign bugs in 'patch included' state to myself until I changed mantis just now and I forgot to mention it on ir
    I wouldn't normally revert but thinks get tricky when it comes to data formats.
    Essentially, I would like to see the Yaw, Pitch and Distance values as separate XML entities (as used in other aspects such as vectors, quaternions) rather than as a . delimited string for consistency and clarity.

Oren, please could you comment on this.
(0021443)
orenh (administrator)
2012-05-11 22:36

I modeled this after Vector3, which also stores its components comma-separated. See for example how the OAR stores UserLocation and UserLookAt. I think that strongly-coupled numbers are better stored this way, because they're always read and written together, and this makes the file format simpler.
(0021444)
orenh (administrator)
2012-05-11 22:37

I would much prefer not to change this, because I have already started creating OARs in this format.
(0021459)
justincc (administrator)
2012-05-14 12:14

Okay, I can accept the argument about simplicity and precedence - recommitted as git master 52a3287. Looking at a few of the external formats out there (e.g. [1] and [2], I see they also store such values as space or comma delimited rather than breaking them out into X, Y, Z, etc. elements. This seems more sensible on reflection.

Sorry about coming down on this - I'm just keen to try and stop the OpenSimulator data formats becoming more fscked up and inconsistent than they already are.

In fact, I see UserLocation and UserLookAt are already screwed up - they store the > and < from Vector3.ToString(). Sigh.

Could you please add a new subpage to [3] for 0.8? Doesn't need to be much detail at all, just a copy of 0.7 and a mention of the new telehub addition and a mention in the landdata section. Thanks.

Also, just to be clear, we can't treat one solution with precedence over another just on the basis that they're already been implemented elsewhere. In development code they do have to be treated purely on their technical merits and this stuff could still change up until the next release if there's a good argument for so doing.

[1] http://en.wikipedia.org/wiki/Geography_Markup_Language [^]
[2] http://en.wikipedia.org/wiki/Kml [^]
[3] http://opensimulator.org/wiki/OpenSim_Archives#OAR_Format [^]

- Issue History
Date Modified Username Field Change
2012-05-06 04:48 orenh New Issue
2012-05-06 04:48 orenh File Added: 0001-Save-the-Telehub-and-its-Spawn-Points-in-the-OAR.patch
2012-05-06 04:48 orenh Status new => patch included
2012-05-06 04:48 orenh Summary Save the Telehub in the OAR file => [PATCH] Save the Telehub in the OAR file
2012-05-10 20:02 BlueWall Note Added: 0021408
2012-05-10 20:02 BlueWall Status patch included => resolved
2012-05-10 20:02 BlueWall Fixed in Version => master (dev code)
2012-05-10 20:02 BlueWall Resolution open => fixed
2012-05-10 20:02 BlueWall Assigned To => BlueWall
2012-05-10 20:02 BlueWall Status resolved => closed
2012-05-11 18:41 justincc Assigned To BlueWall => justincc
2012-05-11 18:41 justincc Note Added: 0021418
2012-05-11 18:41 justincc Status closed => feedback
2012-05-11 18:41 justincc Resolution fixed => reopened
2012-05-11 18:54 justincc Status feedback => patch feedback
2012-05-11 22:36 orenh Note Added: 0021443
2012-05-11 22:37 orenh Note Added: 0021444
2012-05-14 12:14 justincc Note Added: 0021459
2012-05-14 12:15 justincc Status patch feedback => resolved
2012-05-14 12:15 justincc Resolution reopened => fixed
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker