Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005962opensim[REGION] OpenSim Corepublic2012-04-15 15:362017-07-02 16:32
Reporterslow putzo 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformAMD OSLinux FedoraOS Version15
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005962: Correct date on "about Land/Objects" most recent column
DescriptionThe date that shows on the ABOUT LAND/OBJECTS "most recent" column always shows the date as WED Dec. 31 18.00.00 1969. This should be corrected to show the actual date so this information has some value.
Steps To Reproduceclick on About Land
select the objects tab
click on the refresh list button
view the information in the "most recent" column
Additional InformationImprudence 1.4.0 beta 2 (Sep 8 2011 17:16:46)
Release Notes

Grid: OSGrid (osgrid)

Built with MSVC version 1400

You are at 2573875.2, 2556494.6, 22.2 in Sanctuary located at 173-170-147-227.res.bhn.net (173.170.147.227:9137)
OpenSim 0.7.4 Dev OSgrid 0.7.4 (Dev) 1647060: 2012-03-23 (Unix/Mono)
TagsNo tags attached.
Git Revision or version numberOSgrid 0.7.4 (Dev) 1647060: 2012-03-23
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
ViewerImprudence 1.5 Beta 2
Attached Files

- Relationships

-  Notes
(0032106)
slow putzo (reporter)
2017-07-01 13:32

Is there a chance this will ever get looked at?

The same is true for all the dates in the "group" displays as well.

By the way the date now show: Thursday 1 January 1970 or "unknown". This might be because I use a different viewer than when I first reported this.
(0032112)
UbitUmarov (administrator)
2017-07-01 16:26

Sounds a viewer fix since Thursday 1 January 1970 is the correct unix reference time for a field we possible send as 0.
Adding those can be tricky now.

Note that new viewers changed some land fields, and we did not and can't at this time.
(0032114)
slow putzo (reporter)
2017-07-02 07:47
edited on: 2017-07-02 08:01

You are missing the point. opensim is not reporting the date. I just logged into my region, went to about land, went to object, clicked refresh to get the display of items on my region. All entries for all avatars say the last date someone rezzed an object was Thursday 1 January 1970. I then rezzed a box, pressed the refresh button once again and guess what. The prim count increased exactly by 1, very good. the date last rezzed reports Thursday 1 January 1970.
Since this is Singularity, I tried cool VL, same results, so I tried Firestorm, same results.
I went to several other regions I run, looked at the dates of last rezzed. again every date the same. The date never changes so yes I guess the value (0) does indeed equate to Thursday 1 January 1970. So the time clock running in opensim is always zero? In that case why even have the field?

opensim is not recording the event date in these displayed fields in "group windows", or in the "about land" window.

Your assessment suggests every single viewer around is broken and has nothing to do with new or old viewers since two of the ones I mentioned have not been touched in years.

I would believe your assessment of a broken viewer if someone could show me an open sim screen shot of about land with the object owners list showing some date other than Thursday 1 January 1970. It is possible this might be an OSgrid implementation problem of the opensim code. I tried the same test on my desktop running a true standalone not connected to anything, just using 127.0.0.1 port 9000, no HG nothing. I got the exact same results.

Then in world I asked a friend to test this, here is the conversation with her permission to use it.

[06:25 AM] Slow Putzo: hey would you mind doing something for me? it's easy
[06:25 AM] Olivia Wells: sure
[06:27 AM] Slow Putzo: on your region would you click on about land, go to the objects tab, click the "refresh" button and tell me the "date" you see for avaters last rezzed in the list please.
[06:27 AM] Olivia Wells: let me load it won't take long
[06:27 AM] Slow Putzo: mine all say Thursday 1 January 1970 so I reported it as a bug and opensim says it is a viewer issue. I reported this bug back in 2012. lol
[06:28 AM] Olivia Wells: wow i noticed on people in different groups it all has a date like that too idk why
[06:28 AM] Olivia Wells: loading my region now
[06:29 AM] Slow Putzo: yes I also reported that as a bug and in my opinion it is a bug in opensim.
[06:30 AM] Olivia Wells: yes on about lan says 01 jan 1970
[06:30 AM] Olivia Wells: could be i don't use the newer opensims
[06:30 AM] Olivia Wells: just 8.3
[06:30 AM] Slow Putzo: smiles well your viewer is broken which viewer do you use?
[06:30 AM] Olivia Wells: singularity
[06:31 AM] Slow Putzo: well it's been broken since 2012 or since Thursday 1 January 1970, take your pick.
[06:31 AM] Olivia Wells: wow rofl
[06:31 AM] Olivia Wells: they need progress
[06:32 AM] Slow Putzo: thanks for giving it a test, do you mind if I post this chat in the bug report? It will have our avatar names in it.
[06:32 AM] Olivia Wells: no go ahead it's fine

As you can see she also commented about the dates in the group display also being all the same and not being recorder.

I really do not believe this is a viewer problem but rather that opensim does not record the date, any date for these events. Maybe it is just reporting "zero" which is what it looks like it is doing.

I do remember Justin looking at this way back when, and mentioned that with so many other things needing fixing things like this kind of were placed on the back burner. He suggested I open a mantis so it would not be forgotten.

Five years of patiently waiting to see if it could be fixed I do think is reasonable.

I'm not suggesting opensim try to figure out what the date currently logged should have been, I'm asking to fix the logging of the current date so from this point forward dates will start to be recorded.

I'll try to give a list of the places in group display where the date is not being recorded as well if it helps.

go to "groups" select "info"
problem date on the GENERAL TAB in the list of "last login says UNKNOWN"
problem date on the MEMBERS AND ROLES TAB same issue
on the NOTICES TAB the dates are correct, so some do work.

I agree these dates are not critical, but if they can be fixed it sure would be nice to have that information available.


It looks like login date (Groups), and rezz date (about land) are the culprits. Other dates usually are correct.

To dispel the "New Viewer" idea, I just tried the Phoenix viewer.
Phoenix Viewer 1.5.2 (1185) Jul 31 2011 18:58:23 (Phoenix Viewer Release)
The same results.
I think we can all agree a 2011 dated Phoenix viewer is not considered to be a "Newer Viewer" by most users today.

It is amazing I still didn't have a copy of Imprudence to test. Guess my backups do not go back forever.

(0032115)
BillBlight (developer)
2017-07-02 08:34
edited on: 2017-07-02 08:34

I think you missed Ubit's point ... Opensim sends 0, which results in the 1970 date .. And with newer viewers opensim can't send anything that they will understand(yet or never) .. So Maybe it could be fixed for older viewers, but not for anything newer ..

(0032117)
slow putzo (reporter)
2017-07-02 09:48

You are right, I did not understand what ubit said. However in that case how come many other dates are displayed and work fine? How are those sent to the viewer?

Like in the "notices" list of the "groups" window. Those all show the date the notice was posted correctly. Send the date the same way maybe?

Is it sending the unix time stamp? Good grief what have programmers come to today if the viewers don't or won't understand the unix time stamp.

How can recording and sending a date become incompatible in this world. It does not explain why back in 2012 it didn't work then either.

I am sure under the covers this is a lot more complicated than meets the eye.
(0032119)
UbitUmarov (administrator)
2017-07-02 15:53

Sorry if I was not clear confirming that we do not support those fields, and send 0 date on them.
And it is not sending.. it is not collecting, storing, etc, respective data
(0032120)
slow putzo (reporter)
2017-07-02 16:32

Ahh, Now I understand. There is no bug because opensim actually does not handle those items. Got ya. Could this be changed to become a future enhancement? Does opensim even have such a category?

I guess what is being done is kind of like "place holding" in the data stream opensim sends and this particular item is set to zero so it has something in it, but there is no code to collect any of this information.

Is this a better way to think of it?

Can you change this mantis to a feature request? If not lets just close it as not supported or something like that.

I bet that is exactly what Justin was trying to tell me years ago. That no code was ever written to support it and to enter a mantis so it could be considered once the big issues had been crushed? Just guessing of course.

- Issue History
Date Modified Username Field Change
2012-04-15 15:36 slow putzo New Issue
2017-07-01 13:32 slow putzo Note Added: 0032106
2017-07-01 16:26 UbitUmarov Note Added: 0032112
2017-07-02 07:47 slow putzo Note Added: 0032114
2017-07-02 08:01 slow putzo Note Edited: 0032114 View Revisions
2017-07-02 08:34 BillBlight Note Added: 0032115
2017-07-02 08:34 BillBlight Note Edited: 0032115 View Revisions
2017-07-02 09:48 slow putzo Note Added: 0032117
2017-07-02 15:53 UbitUmarov Note Added: 0032119
2017-07-02 16:32 slow putzo Note Added: 0032120


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker