Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005916opensim[REGION] OpenSim Corepublic2012-03-04 20:292014-07-29 13:40
ReporterGuduleLapointe 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFreeBSDOperating SystemFreeBSDOperating System Version8.2
Product Version 
Target VersionFixed in Version 
Summary0005916: OpenJPEG errors on FreeBSD
DescriptionWhen building OpenSim 0.7.3 for FreeBSD 8.2:
Build succeeds, sim starts, but I got plenty of error messages of three types (copied below).

The first visible consequence is that all map tiles come as a grey square.

Found a patch to fix the problem, but this is roughly done and would make the code break for other platforms.

ERROR - OpenSim.Region.CoreModules.World.LegacyMap.MapImageModule Failed generating terrain map: System.DllNotFoundException: lib32/libopenjpeg-dotnet-2.1.3.0-dotnet-1-i686
  at (wrapper managed-to-native) OpenMetaverse.Imaging.OpenJPEG:DotNetAllocDecoded (OpenMetaverse.Imaging.OpenJPEG/MarshalledImage&)
  at OpenMetaverse.Imaging.OpenJPEG.Encode (OpenMetaverse.Imaging.ManagedImage image, Boolean lossless) [0x00000] in <filename unknown>:0
  at OpenMetaverse.Imaging.OpenJPEG.EncodeFromImage (System.Drawing.Bitmap bitmap, Boolean lossless) [0x00000] in <filename unknown>:0
  at OpenSim.Region.CoreModules.World.LegacyMap.MapImageModule.WriteJpeg2000Image () [0x00000] in <filename unknown>:0
ERROR - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TexturedMapTileRenderer]: OpenJpeg is not installed correctly on this system. Asset Data is empty for (uuid)
ERROR - OpenSim.Region.Physics.Meshing.Meshmerizer [PHYSICS]: OpenJpeg is not installed correctly on this system. Physics Proxy generation failed. Often times this is because of an old version of GLIBC. You must have version 2.4 or above!

    (btw, it seems that FreeBSD doesn't use glibc at all, so the last message type is inaccurate and should be elaborated)

Steps To ReproduceBuild OpenSim from 0.7.3 release source,
configure as GridHypergrid
run
Additional InformationI had to merge and correct outdated instructions from several sources.

I found two (outdated) pages documenting "openjpeg-libsl" fix for FreeBSD, but after managing to get the library built, the messages remained. I don't know if this fix is still useful for other issues

http://opensimulator.org/wiki/Troubleshooting#I_have_problems_with_viewing_the_worldmap [^]
http://opensimulator.org/wiki/User:Devalnor/DevalnorWorkNotes [^]

Found partial information on these two pages
    http://opensimulator.org/mantis/view.php?id=1913 [^]
        mantis about this, closed, however this seems to be exactly the same issue
    http://forums.freebsd.org/showthread.php?t=13122 [^]

Binaries present in opensim-libs/LibOMV_2568/bin/*openjpeg* don't work out of the box (errors remain)

I changed the file opensim-libs/libomv-0.7.0/openjpeg-dotnet/libopenjpeg/opj_malloc.h
        /* Linux x86_64 and OSX always align allocations to 16 bytes */
        #elif !defined(__amd64__) && !defined(__APPLE__)
                /* #define HAVE_MEMALIGN */
                /* #include <malloc.h> */
                #include <stdlib.h>

But this would break other platform build...

I added following line to the end of bin/OpenMetaverse.dll.config
        <dllmap os="freebsd" dll="openjpeg-dotnet.dll" target="libopenjpeg-dotnet-\
2.1.3.0-dotnet-1" />
</configuration>

... but I don't know if it would break other platforms or not
TagsNo tags attached.
Git Revision or version number0.7.3 release
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Files? file icon opensim-freebsd-patch-OpenMetaverseDllConfig [^] (753 bytes) 2012-03-05 20:46 [Show Content]
? file icon opensim-freebsd-patch-opj_malloc [^] (93 bytes) 2012-03-05 20:46 [Show Content]

- Relationships

-  Notes
(0021023)
Digi Fly (reporter)
2012-03-05 05:10

If mono on freeBSD dont use glibc ? what does it use then ?
And is that at the correct version, it still sounbd like you need to install glibc
or at least update the replacement to the correct version.

Otherwise compile mono manual in userspace, so it dont interfere with the system but still installing
then correct packadges. make sure you install everything from mono then in userspace.
But not common with freebsd.
(0021026)
justincc (administrator)
2012-03-05 18:52

OpenSimulator isn't supported on FreeBSD at this time. I suspect those wiki instructions haven't been updated for a long, long time.
(0021030)
GuduleLapointe (reporter)
2012-03-05 20:48

I uploaded the patches I used. These are of course only to be used on FreeBSD. It would break other distributions.
(0021031)
GuduleLapointe (reporter)
2012-03-05 21:44

I updated the following wiki sections:
http://opensimulator.org/wiki/Build_Instructions#FreeBSD [^]
http://opensimulator.org/wiki/Troubleshooting#I_have_problems_with_viewing_the_worldmap [^]
http://opensimulator.org/wiki/Troubleshooting#System.DllNotFoundException:_lib32.2Flibopenjpeg-dotnet-2.1.3.0-dotnet-1-i686 [^]
http://opensimulator.org/wiki/Troubleshooting#System.DllNotFoundException:_..2Flibopenjpeg-libsl-2.1.2.0.so [^]
http://opensimulator.org/wiki/User:Devalnor/DevalnorWorkNotes#Install_FreeBSD_on_VMWARE [^]
(0021156)
justincc (administrator)
2012-03-30 16:23

Moving to resolved but not closed in case there are any future comments. Please do not close this mantis.

- Issue History
Date Modified Username Field Change
2012-03-04 20:29 GuduleLapointe New Issue
2012-03-05 05:10 Digi Fly Note Added: 0021023
2012-03-05 18:52 justincc Note Added: 0021026
2012-03-05 20:46 GuduleLapointe File Added: opensim-freebsd-patch-OpenMetaverseDllConfig
2012-03-05 20:46 GuduleLapointe File Added: opensim-freebsd-patch-opj_malloc
2012-03-05 20:48 GuduleLapointe Note Added: 0021030
2012-03-05 21:44 GuduleLapointe Note Added: 0021031
2012-03-30 16:23 justincc Note Added: 0021156
2012-03-30 16:23 justincc Status new => resolved
2012-03-30 16:23 justincc Resolution open => fixed
2012-03-30 16:23 justincc Assigned To => justincc
2014-07-29 13:40 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker