Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005891opensim[REGION] Scripting Enginepublic2012-02-16 19:432013-05-13 16:14
Reporterkenvc 
Assigned Tokenvc 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformQuad core 2.8 ghz 8 gig ramOSWindows 7 64 bitOS Version7 64 bit
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005891: Red spew on console when AppDomainLoading = false. All kinds of script and other issues after this.
DescriptionI used to run my sims this way until a few months ago but heard AppDomainLoading = true was slightly more stable on Windows. I decided to do some experimenting again with AppDomainLoading = false and see if the stability had changed since I last tried it.

Very shortly after simulator startup red spew started rolling past the console and by the time the sims were started, the log file was about 2.3 meg in size. Changed back to AppDomainLoading = true and things went back to normal. Did this 4 times to make sure. Included below is s sample of the errors that repeat over and over in the console. A larger sample is attached, but cannot include the entire session log because the file is too large to attach.
Steps To Reproduce1. Set AppDomainLoading = false
2. Start Opensim
3. Off and on during sim startup, tons of red spew all over console with the errors included below repeated over and over.
4. Log file was 2.3 meg in size just from one startup because of all the spew.
5. Now set AppDomainLoading = true and problem vanishes.
6. Not sure when this started, but it never behaved like this last time I tried = false.
Additional Information2012-02-16 21:16:26,344 ERROR - OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance [SCRIPT INSTANCE]: Error loading assembly ScriptEngines\0c319961-f0dd-11df-98cf-0800200c9a66\CommonCompiler_compiled_6a6c6de1-f507-4baf-9576-8f6904840d6f.dll. Exception Could not load file or assembly 'CommonCompiler_compiled_6a6c6de1-f507-4baf-9576-8f6904840d6f' or one of its dependencies. Invalid pointer (Exception from HRESULT: 0x80004003 (E_POINTER)) at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
   at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance..ctor(IScriptEngine engine, SceneObjectPart part, UUID itemID, UUID assetID, String assembly, AppDomain dom, String primName, String scriptName, Int32 startParam, Boolean postOnRez, StateSource stateSource, Int32 maxScriptQueue) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Region\ScriptEngine\Shared\Instance\ScriptInstance.cs:line 291
2012-02-16 21:16:26,346 ERROR - OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance [SCRIPT INSTANCE]: Error loading script instance from assembly ScriptEngines\0c319961-f0dd-11df-98cf-0800200c9a66\CommonCompiler_compiled_6a6c6de1-f507-4baf-9576-8f6904840d6f.dll. Exception Object reference not set to an instance of an object. at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance..ctor(IScriptEngine engine, SceneObjectPart part, UUID itemID, UUID assetID, String assembly, AppDomain dom, String primName, String scriptName, Int32 startParam, Boolean postOnRez, StateSource stateSource, Int32 maxScriptQueue) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Region\ScriptEngine\Shared\Instance\ScriptInstance.cs:line 311
2012-02-16 21:16:26,348 ERROR - OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance [SCRIPT INSTANCE]: Error loading assembly ScriptEngines\0c319961-f0dd-11df-98cf-0800200c9a66\CommonCompiler_compiled_6a6c6de1-f507-4baf-9576-8f6904840d6f.dll. Exception Value cannot be null.
Parameter name: path1 at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
TagsNo tags attached.
Git Revision or version number18099
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Fileslog file icon OpenSim.32BitLaunch.log [^] (1,009,469 bytes) 2012-02-16 19:43

- Relationships

-  Notes
(0020880)
justincc (administrator)
2012-02-16 19:46

Since the last time, some extra errors are being output on console again. It might be that the same errors occurred last time but you never saw them. This is all quite strange because I didnt' see any of these issues when I tried it a few days ago on Windows XP with 5200 scripts spread over two regions.
(0020881)
justincc (administrator)
2012-02-16 19:48

It almost looks like some kind of race condition.
(0020882)
kenvc (reporter)
2012-02-16 19:56

I suspect this is a symptom of a deeper issue. I also noticed timeout for heartbeat error messages just prior to this starting in some cases. Sample of log with that part included below.

2012-02-16 21:16:52,977 INFO - OpenSim.Region.OptionalModules.Scripting.RegionReady.RegionReadyModule [RegionReady]: Logins enabled for Night Spot
2012-02-16 21:16:54,823 ERROR - OpenSim.OpenSim [WATCHDOG]: Timeout detected for thread "Heartbeat (White Sand Beach)". ThreadState=Running. Last tick was 5772ms ago
2012-02-16 21:16:55,226 WARN - OpenSim.Services.Connectors.NeighbourServicesConnector [NEIGHBOUR SERVICE CONNCTOR]: Unable to send HelloNeighbour from Night Spot to Queen. Exception Unable to connect to the remote server at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at OpenSim.Services.Connectors.NeighbourServicesConnector.DoHelloNeighbourCall(GridRegion region, RegionInfo thisRegion) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Services\Connectors\Neighbour\NeighbourServiceConnector.cs:line 151
2012-02-16 21:16:55,230 INFO - OpenSim.Region.Framework.Scenes.SceneCommunicationService [INTERGRID]: Failed to inform neighbour 9992-9999 that I'm here.
2012-02-16 21:17:03,394 WARN - OpenSim.Services.Connectors.NeighbourServicesConnector [NEIGHBOUR SERVICE CONNCTOR]: Unable to send HelloNeighbour from Night Spot to cheyenne5. Exception The operation has timed out at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at OpenSim.Services.Connectors.NeighbourServicesConnector.DoHelloNeighbourCall(GridRegion region, RegionInfo thisRegion) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Services\Connectors\Neighbour\NeighbourServiceConnector.cs:line 151
2012-02-16 21:17:03,398 INFO - OpenSim.Region.Framework.Scenes.SceneCommunicationService [INTERGRID]: Failed to inform neighbour 9991-9999 that I'm here.
2012-02-16 21:17:03,441 WARN - OpenSim.Services.Connectors.NeighbourServicesConnector [NEIGHBOUR SERVICE CONNCTOR]: Unable to send HelloNeighbour from Night Spot to GolandTest. Exception The operation has timed out at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at OpenSim.Services.Connectors.NeighbourServicesConnector.DoHelloNeighbourCall(GridRegion region, RegionInfo thisRegion) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Services\Connectors\Neighbour\NeighbourServiceConnector.cs:line 151
2012-02-16 21:17:03,447 INFO - OpenSim.Region.Framework.Scenes.SceneCommunicationService [INTERGRID]: Failed to inform neighbour 9991-10000 that I'm here.
2012-02-16 21:17:03,535 WARN - OpenSim.Services.Connectors.NeighbourServicesConnector [NEIGHBOUR SERVICE CONNCTOR]: Unable to send HelloNeighbour from Night Spot to SvetsRegion. Exception The operation has timed out at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at OpenSim.Services.Connectors.NeighbourServicesConnector.DoHelloNeighbourCall(GridRegion region, RegionInfo thisRegion) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Services\Connectors\Neighbour\NeighbourServiceConnector.cs:line 151
2012-02-16 21:17:03,540 INFO - OpenSim.Region.Framework.Scenes.SceneCommunicationService [INTERGRID]: Failed to inform neighbour 9991-10001 that I'm here.
2012-02-16 21:17:03,971 WARN - OpenSim.Services.Connectors.NeighbourServicesConnector [NEIGHBOUR SERVICE CONNCTOR]: Unable to send HelloNeighbour from Night Spot to Phaenareti. Exception The operation has timed out at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at OpenSim.Services.Connectors.NeighbourServicesConnector.DoHelloNeighbourCall(GridRegion region, RegionInfo thisRegion) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Services\Connectors\Neighbour\NeighbourServiceConnector.cs:line 151
2012-02-16 21:17:03,975 INFO - OpenSim.Region.Framework.Scenes.SceneCommunicationService [INTERGRID]: Failed to inform neighbour 9993-9999 that I'm here.
2012-02-16 21:17:04,142 ERROR - OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance [SCRIPT INSTANCE]: Error loading assembly ScriptEngines\b6d10780-61fc-11e0-80e3-0800200c9a66\CommonCompiler_compiled_b06a941e-b8bd-44e4-8296-146c238f3327.dll. Exception Could not load file or assembly 'CommonCompiler_compiled_b06a941e-b8bd-44e4-8296-146c238f3327' or one of its dependencies. Invalid pointer (Exception from HRESULT: 0x80004003 (E_POINTER)) at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
   at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance..ctor(IScriptEngine engine, SceneObjectPart part, UUID itemID, UUID assetID, String assembly, AppDomain dom, String primName, String scriptName, Int32 startParam, Boolean postOnRez, StateSource stateSource, Int32 maxScriptQueue) in C:\Users\Ken\Desktop\Opensim Git\OpenSim\Region\ScriptEngine\Shared\Instance\ScriptInstance.cs:line 291
(0020883)
smxy (reporter)
2012-02-16 20:37

On my Linux systems, with Mono, I always see the heartbeat timeout just before the scripts start, if there are more than just a handful that will be loaded.
(0023883)
kenvc (reporter)
2013-05-13 16:14

Havee not seen this happen in some time, so I assume the problem is fixed.

- Issue History
Date Modified Username Field Change
2012-02-16 19:43 kenvc New Issue
2012-02-16 19:43 kenvc File Added: OpenSim.32BitLaunch.log
2012-02-16 19:46 justincc Note Added: 0020880
2012-02-16 19:47 kenvc Description Updated View Revisions
2012-02-16 19:48 justincc Note Added: 0020881
2012-02-16 19:56 kenvc Note Added: 0020882
2012-02-16 20:37 smxy Note Added: 0020883
2013-05-13 16:14 kenvc Note Added: 0023883
2013-05-13 16:14 kenvc Status new => resolved
2013-05-13 16:14 kenvc Fixed in Version => master (dev code)
2013-05-13 16:14 kenvc Resolution open => fixed
2013-05-13 16:14 kenvc Assigned To => kenvc
2013-05-13 16:14 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker