Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005839opensim[REGION] Physics Enginespublic2012-01-02 16:152012-01-06 16:32
Reportermirceakitsune 
Assigned Tojustincc 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformCustomOSWindows 7OS Version64bit
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005839: Stopping then resuming flight in midair causes avatar to get stuck until touching the ground
DescriptionIf an avatar stops then resumes flying in midair, he is no longer able to move in any direction, and gets stuck in place. The avatar can only fly normally again after he stops flying and touches the ground due to gravity.
Steps To Reproduce- Fly somewhere high enough.

- Stop flying while airborne. The avatar will start to fall.

- Start flying again before the avatar touches the ground.

- RESULT: You are stuck in place, and cannot go in any direction. All you can do is hover or fall, and only after touching the ground you can fly normally again.
Additional InformationAvatars still play the proper flight animations when this happens (eg: leaning forward when pressing the forward key). Turning left or right also works while stuck in the air. Friction still applies to the avatar as he gets stuck (if you have horizontal velocity while you fall and resume flying), meaning the avatar doesn't get frozen in place but velocity is no longer applied instead.

I'm pretty sure this didn't happen in older OpenSim versions, so it might have been introduced a few months ago. The sim this was noticed on is ran on OSGrid.
Tagsfall, flight, flying, frozen, ground, movement, physics, stuck
Git Revision or version numberr/17677
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer3.2.4 (246439)
Attached Files

- Relationships

-  Notes
(0020618)
Bruce (reporter)
2012-01-02 16:38

Tested with r/17677 in home regions as well as three different OSG regions. Could not reproduce this but then I have a different setup (ODE, .NET / Windows64, Imprudence 1.4.0 beta 2).
(0020624)
tglion (reporter)
2012-01-03 22:47

I can reproduce this issue on my Grid
Tested with r/17679, ODE, mono 2.4.3, SuseLinux 11.2 64bit
Imprudence 1.3.2
(0020642)
justincc (administrator)
2012-01-06 16:18

Hopefully fixed by git master c5079f6
(0020643)
mirceakitsune (reporter)
2012-01-06 16:32

Re-tested in r/17728. The issue no longer happens on my sims, so I think it's safe to assume it's fully fixed.

- Issue History
Date Modified Username Field Change
2012-01-02 16:15 mirceakitsune New Issue
2012-01-02 16:20 mirceakitsune Additional Information Updated View Revisions
2012-01-02 16:31 mirceakitsune Additional Information Updated View Revisions
2012-01-02 16:34 mirceakitsune Tag Attached: physics
2012-01-02 16:34 mirceakitsune Tag Attached: walk
2012-01-02 16:34 mirceakitsune Tag Attached: fall
2012-01-02 16:34 mirceakitsune Tag Attached: flight
2012-01-02 16:34 mirceakitsune Tag Attached: flying
2012-01-02 16:34 mirceakitsune Tag Attached: frozen
2012-01-02 16:34 mirceakitsune Tag Attached: ground
2012-01-02 16:34 mirceakitsune Tag Attached: movement
2012-01-02 16:34 mirceakitsune Tag Attached: stuck
2012-01-02 16:34 mirceakitsune Tag Detached: walk
2012-01-02 16:38 Bruce Note Added: 0020618
2012-01-02 16:49 nebadon Status new => confirmed
2012-01-03 22:47 tglion Note Added: 0020624
2012-01-06 16:18 justincc Note Added: 0020642
2012-01-06 16:18 justincc Status confirmed => resolved
2012-01-06 16:18 justincc Resolution open => fixed
2012-01-06 16:18 justincc Assigned To => justincc
2012-01-06 16:32 mirceakitsune Note Added: 0020643
2012-01-06 16:32 mirceakitsune Status resolved => closed
2012-01-06 16:32 mirceakitsune Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker