Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005831opensim[GRID] Hypergridpublic2011-12-23 22:232011-12-24 15:55
Reportertimber 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version1.7.3
Product Version 
Target VersionFixed in Version 
Summary0005831: HG enabled, errors in IM's and repeating IM text
DescriptionStarting recently, when being IM'd by another OSgrid user on a HG enabled region, it would produce red errors in the console with each exchange (see below for log)
The received IM's would start rapidly repeating previously typed lines continuously.
Both errors stopped when moving into the adjacent NON hg enabled region, and began again upon return to the hg enabled region.
Restarting viewers and regions had no effect, disabling hg by changing the architecture line in opensim.ini to Grid.ini stopped all errors
Steps To Reproduce1.7.3 from 11/3/2011, with HG enabled, receiving an IM from another OSgrid avatar from their own region in the grid.

Errors took place between myself and 2 different users, both reported the below errors at THEIR end stopepd once I moved into a hg disabled region;

[2011/12/23 18:00] Other User: and I get you as [01:58] System: User is not logged in. Message saved. for every line you send


Additional Information[INSTANT MESSAGE]: Caught unexpected exception:System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Region.CoreModules.Avatar.InstantMessage.HGMessageTransferModule.SendIMToScene (OpenSim.Framework.GridInstantMessage gim, UUID toAgentID) [0x00000] in <filename unknown>:0
  at OpenSim.Region.CoreModules.Avatar.InstantMessage.HGMessageTransferModule.SendInstantMessage (OpenSim.Framework.GridInstantMessage im) [0x00000] in <filename unknown>:0
  at OpenSim.Services.HypergridService.HGInstantMessageService.IncomingInstantMessage (OpenSim.Framework.GridInstantMessage im) [0x00000] in <filename unknown>:0
  at OpenSim.Server.Handlers.Hypergrid.InstantMessageServerConnector.ProcessInstantMessage (Nwc.XmlRpc.XmlRpcRequest request, System.Net.IPEndPoint remoteClient) [0x00000] in <filename unknown>:0
TagsNo tags attached.
Git Revision or version number1.7.3
Run Mode Grid (Multiple Regions per Sim)
Physics EnginePhysX
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
Viewer
Attached Files

- Relationships

-  Notes
(0020597)
timber (reporter)
2011-12-23 22:47

The region you have entered is running a different simulator version: OpenSim 0.7.3 Dev OSgrid 0.7.3 (Dev) 6b4ae4f: 2011-11-02 (Unix/Mono)
(0020598)
timber (reporter)
2011-12-23 23:17
edited on: 2011-12-24 15:54

I updated to the latest version of 12/17/2011 and it appears the problem has been solved, but then another problem came up- all cut/hollow doorways and sculpty stairs became SOLID walls, and all door scripts ceased to function.

I went back to the 11/2 version and disabled HG on the regions again and all problems ceased.


- Issue History
Date Modified Username Field Change
2011-12-23 22:23 timber New Issue
2011-12-23 22:47 timber Note Added: 0020597
2011-12-23 23:17 timber Note Added: 0020598
2011-12-23 23:20 timber Note Edited: 0020598 View Revisions
2011-12-23 23:20 timber Resolution open => fixed
2011-12-23 23:23 timber Note Edited: 0020598 View Revisions
2011-12-24 15:54 timber Note Edited: 0020598 View Revisions
2011-12-24 15:55 timber Resolution fixed => open


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker