Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005828opensim[MISC] Compiling / Buildingpublic2011-12-20 18:562012-02-06 12:20
Reporterkip hanly 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005828: I have 5 regions on one machine..In two of the regions I am able to create a script, mod it, compile and upload. In three of the
DescriptionOK..reinstalled newer version of simulator..reloaded all regions from oar..things worked fine...for three days...now I am back to the same problem

in three of the 5 regions on the server I can

create a box
create a new script
edit the script and put a space in it
save..

console says
20:02:09 - [CAPS]: System.ArgumentNullException: Value cannot be null.
20:02:09 - [BASE HTTP SERVER]: HandleRequest() threw System.ArgumentNullExceptio
n: String reference not set to an instance of a String.
TagsNo tags attached.
Git Revision or version numberosgrid.opensim-12172011.v0.7.3.4d065f0
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships
related to 0002904closedRalfHaifisch not all scripts are executed - i.e. putting new regions in opensim instance stops script execution (partly) 

-  Notes
(0020578)
danbanner (manager)
2011-12-20 19:27

kip have you set AppDomainLoading = true?
(0020579)
kip hanly (reporter)
2011-12-20 20:37

Tried that..and got crashes with AppDomainLoading=True. And it did not fix. So went back.

what i have now done is to run two simulators..three regions in one and two in another..I am back to being able to compile in all regions now, but I have saved the original folder so I can go back to one simulator if need be. I only created a new http port for second simulator, when I separated regions. But the install of update on Saturday caused things to work for awhile...then failed today (Tuesday). so I will have to see if this continues ok or my problem arises again.
(0020580)
Michelle Argus (reporter)
2011-12-21 08:08

Couldn't find the old resloved mantis, but this is a known issue which pops up every now and then... The first +- 3 regions that are listed in the region.ini have scripts running and the rest not. This only shows when running multiple regions per sim.
(0020581)
Marcus Llewellyn (reporter)
2011-12-21 08:27

This might be related to http://opensimulator.org/mantis/view.php?id=2904 [^]
(0020582)
Michelle Argus (reporter)
2011-12-21 08:36

Yip, thats related and there is a much newer mantis aswell, max 1 year old
(0020583)
kip hanly (reporter)
2011-12-21 08:55

thanks all..lucked into a solution by starting a second simulator for three of the regions...
(0020711)
tomhaines (reporter)
2012-01-25 12:31

I am seeing this issue now as well on two separate region servers. On each region server, there are some regions where scripts run perfectly well, and some where they don't run at all. Both running Ubuntu 10.10 and mono 2.10.8. Whenever a script is saved on some of the regions, we get this error in the console.

5:26:19 - [CAPS]: System.ArgumentNullException: Argument cannot be null.
Parameter name: obj
  at System.Threading.Monitor.TryEnter (System.Object obj, Int32 millisecondsTimeout, System.Boolean& lockTaken) [0x00049] in /home/local/ERDTS/vdighe/mono-2.10.8/mcs/class/corlib/System.Threading/Monitor.cs:225
  at System.Threading.Monitor.Enter (System.Object obj, System.Boolean& lockTaken) [0x00000] in /home/local/ERDTS/vdighe/mono-2.10.8/mcs/class/corlib/System.Threading/Monitor.cs:198
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance.set_Suspended (Boolean value) [0x00000] in /opt/opensim071/201112251832/OpenSim/Region/ScriptEngine/Shared/Instance/ScriptInstance.cs:148
  at (wrapper remoting-invoke-with-check) OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance:set_Suspended (bool)
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance.Resume () [0x00000] in /opt/opensim071/201112251832/OpenSim/Region/ScriptEngine/Shared/Instance/ScriptInstance.cs:1061
  at OpenSim.Region.ScriptEngine.XEngine.XEngine.ResumeScript (UUID itemID) [0x0000e] in /opt/opensim071/201112251832/OpenSim/Region/ScriptEngine/XEngine/XEngine.cs:1824
  at OpenSim.Region.Framework.Scenes.SceneObjectPartInventory.ResumeScripts () [0x0008b] in /opt/opensim071/201112251832/OpenSim/Region/Framework/Scenes/SceneObjectPartInventory.cs:1174
  at OpenSim.Region.Framework.Scenes.SceneObjectGroup.ResumeScripts () [0x00013] in /opt/opensim071/201112251832/OpenSim/Region/Framework/Scenes/SceneObjectGroup.Inventory.cs:390
  at OpenSim.Region.Framework.Scenes.Scene.CapsUpdateTaskInventoryScriptAsset (IClientAPI remoteClient, UUID itemId, UUID primId, Boolean isScriptRunning, System.Byte[] data) [0x0013f] in /opt/opensim071/201112251832/OpenSim/Region/Framework/Scenes/Scene.Inventory.cs:286
  at OpenSim.Region.Framework.Scenes.Scene.CapsUpdateTaskInventoryScriptAsset (UUID avatarId, UUID itemId, UUID primId, Boolean isScriptRunning, System.Byte[] data) [0x0000e] in /opt/opensim071/201112251832/OpenSim/Region/Framework/Scenes/Scene.Inventory.cs:300
  at OpenSim.Region.ClientStack.Linden.BunchOfCaps.TaskScriptUpdated (UUID itemID, UUID primID, Boolean isScriptRunning, System.Byte[] data, System.Collections.ArrayList& errors) [0x0000b] in /opt/opensim071/201112251832/OpenSim/Region/ClientStack/Linden/Caps/BunchOfCaps/BunchOfCaps.cs:322
  at OpenSim.Region.ClientStack.Linden.TaskInventoryScriptUpdater.uploaderCaps (System.Byte[] data, System.String path, System.String param) [0x00029] in /opt/opensim071/201112251832/OpenSim/Region/ClientStack/Linden/Caps/BunchOfCaps/BunchOfCaps.cs:967
15:26:19 - [BASE HTTP SERVER]: HandleRequest() threw System.ArgumentNullException: Argument cannot be null.
Parameter name: s
  at System.Text.Encoding.GetBytes (System.String s) [0x0007b] in /home/local/ERDTS/vdighe/mono-2.10.8/mcs/class/corlib/System.Text/Encoding.cs:261
  at OpenSim.Framework.Servers.HttpServer.BinaryStreamHandler.Handle (System.String path, System.IO.Stream request, IOSHttpRequest httpRequest, IOSHttpResponse httpResponse) [0x0001e] in /opt/opensim071/201112251832/OpenSim/Framework/Servers/HttpServer/BinaryStreamHandler.cs:45
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleRequest (OpenSim.Framework.Servers.HttpServer.OSHttpRequest request, OpenSim.Framework.Servers.HttpServer.OSHttpResponse response) [0x000f1] in /opt/opensim071/201112251832/OpenSim/Framework/Servers/HttpServer/BaseHttpServer.cs:462
(0020797)
albertlr Landar (reporter)
2012-02-04 20:48

I am also experiencing a problem with scripts not running in the regions in a multi region sim. The first row seems to work fine, but any starting on the second or third row the scripts will not run, and I get an error message in Imprudence to try later. This happens with the 1-19-2012, 2-1-2012, and 2-4-2012 updates of opensim. And I am running this on a Windows XP Server. I never had these problems in the past.
(0020802)
albertlr Landar (reporter)
2012-02-06 12:20

Not sure which OS you have but if it is Windows make sure you have AppDomainLoading=true in the opensim.ini. For several recent releases it has been changed to AppDomainLoading=false instead of the default setting. Changing it back to true has resolved my script errors and scripts not working in some regions. Thanks to Bo I was pointed to this as a solution.

- Issue History
Date Modified Username Field Change
2011-12-20 18:56 kip hanly New Issue
2011-12-20 19:27 danbanner Note Added: 0020578
2011-12-20 20:37 kip hanly Note Added: 0020579
2011-12-21 08:08 Michelle Argus Note Added: 0020580
2011-12-21 08:27 Marcus Llewellyn Note Added: 0020581
2011-12-21 08:36 Michelle Argus Note Added: 0020582
2011-12-21 08:37 Michelle Argus Relationship added related to 0002904
2011-12-21 08:55 kip hanly Note Added: 0020583
2012-01-25 12:31 tomhaines Note Added: 0020711
2012-02-04 20:48 albertlr Landar Note Added: 0020797
2012-02-06 12:20 albertlr Landar Note Added: 0020802


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker