Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005801opensim[REGION] OpenSim Corepublic2011-11-27 15:072012-08-12 13:13
ReporterBruce 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusconfirmedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005801: Map tiles in world map are rendered in white
DescriptionMap tiles of home regions of HG standalone instances are rendered in white.

Break is at hash 01ae916bad672722aa62ee712b7b580d6f5f4370 (r/17324 of 19 Nov 11)
Steps To Reproduce1. Pull, compile, install
2. Clear viewer cache
3. Login
TagsNo tags attached.
Git Revision or version number01ae916bad672722aa62ee712b7b580d6f5f4370 (r/17324 of 19 Nov 11)
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerImprudence 1.4.0 beta 2
Attached Files

- Relationships

-  Notes
(0020445)
Bruce (reporter)
2011-12-06 15:09
edited on: 2011-12-06 15:33

Just an update to say that this still occurs with hash 8e542cfa03f9368368a0f73fbcff0d54622b5588 (r/17501 of 2011-12-06) and that white tiles are also generated for home regions when running simulator in standalone without HG enabled. With dolphin viewer 3 map tiles of home regions are shown correctly but no map tiles are rendered for hyperlinked regions.

(0020601)
Diva (administrator)
2011-12-30 21:47

Committed fix in 56dbcae402000e199e556827944dfdd1bb3a64be

    Bug fix in map tiles in standalone: the map has been blank since commit 01ae916bad672722aa62ee712b7b580d6f5f4370 r/17324 (Nov.18, justincc). But the root cause comes from commit 02e54c57c4901167779f07ed3e89fb1d24ffc22a Author: Oren Hurvitz Date: 7/22/2011
    This is a nasty situation. The map tile UUID is, in principle, stored authoritatively in RegionSettings. However, it also needs to be stored in the Grid Service because that's how other sims can retrieve it to send it in Map Blocks to non-V3 viewers. So every time the tile image changes, that change needs to propagate to the Grid Service, and this is done via RegisterRegion (ugh!). Interestingly, this problem didn't affect grids because by default AllowRemoteDelete is false, so the prior images aren't being deleted from the asset servers -- but they were not being correctly updated in the map either, the map was stuck with old images.
(0020602)
Bruce (reporter)
2011-12-31 08:44

Confirming that map tiles of home regions of standalone instances are rendered correctly again. Thank you for fixing this Diva.
(0020755)
Snoopy (administrator)
2012-02-02 11:47

I still see white map tiles using the latest OpenSim version for standalone regions. git 585fc5e79d4b87a5375fa3c2986b5f91d0de1f4e - r/17461
(0020756)
Snoopy (administrator)
2012-02-02 11:48

Diva, I still have that white map tile issue using the latest OpenSim versions. I would not be surprised if it is not HyperGrid related.
(0020757)
smxy (reporter)
2012-02-02 12:38

I'm running yesterday's code. I just HG TPd to a standalone of mine, from my robust grid. When I check the map, it looks fine. I use the warp3d map module however. Which are you using?
(0020758)
Snoopy (administrator)
2012-02-02 12:46

I use WorldMapModule = "WorldMap", because with many prims Warp3DImageModule needs an incredible amount of time to create a map tile.

Interesting is that when I create a HyperGrid link to such a standalone region, I see the map tile of that standalone region in the map window. But when I log into the standalone region with local avatar, I just see white map tiles.
(0020759)
melanie (administrator)
2012-02-02 14:18

Warp3D uses files in Flotsam disk cache to hold map tile data in the texture metadata. If you dont't have Flotsam disk caching or clear that cache Warp will not work in an acceptable fashion. If you let the cache manage itself, you will see Warp working just fine.
(0020763)
Snoopy (administrator)
2012-02-02 15:05

I use Flotsam disk caching. I had a couple of regions where creating Warp3D map tiles took over 20 minutes. This simply was not acceptable. Even with the map tile in the cache restarts were very much slowed down. People are not willing to wait so much long for a region restart, just to see a slightly nicer map tile.
(0021210)
Diva (administrator)
2012-04-08 17:57

Is this still an issue?

- Issue History
Date Modified Username Field Change
2011-11-27 15:07 Bruce New Issue
2011-11-27 16:54 Bruce File Added: World_Map_Errors.txt
2011-11-27 16:55 Bruce Note Added: 0020401
2011-11-27 16:55 Bruce Note Edited: 0020401 View Revisions
2011-11-27 17:16 BlueWall File Deleted: World_Map_Errors.txt
2011-11-27 17:17 Bruce Note Deleted: 0020401
2011-12-06 15:09 Bruce Note Added: 0020445
2011-12-06 15:33 Bruce Note Edited: 0020445 View Revisions
2011-12-30 21:47 Diva Note Added: 0020601
2011-12-31 08:44 Bruce Note Added: 0020602
2011-12-31 09:02 Diva Status new => resolved
2011-12-31 09:02 Diva Resolution open => fixed
2011-12-31 09:02 Diva Assigned To => Diva
2012-02-02 11:47 Snoopy Note Added: 0020755
2012-02-02 11:48 Snoopy Note Added: 0020756
2012-02-02 11:48 Snoopy Status resolved => confirmed
2012-02-02 12:38 smxy Note Added: 0020757
2012-02-02 12:46 Snoopy Note Added: 0020758
2012-02-02 14:18 melanie Note Added: 0020759
2012-02-02 15:05 Snoopy Note Added: 0020763
2012-04-08 17:57 Diva Note Added: 0021210
2012-08-18 04:32 DMX04 Issue cloned: 0006215


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker