Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005787opensim[REGION] OpenSim Corepublic2011-11-10 17:202014-02-24 12:30
ReporterLaniGlobal 
Assigned To 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005787: Teleport Fail Causes Region Neighbors To Disappear in View; all next teleports fail, requires relog
DescriptionThis bug has been seen randomly during most of the 0.7x versions in 2011.

Condition: Region running on a Grid. (in test case, OSGrid was used)
PROBLEM:
1. Attempt to teleport to a distant region randomly fails.
2. Viewer pop up error appears:
 "Could not teleport. Problems connecting to destination."
3. After some delay, avatar is still alive in original region.
4. After the teleport fail:
A. All further attempts to teleport anywhere fail.
B. All neighbor regions disappear visually from attempted teleporting client's viewer. (but the neighbor regions do not disappear from the viewers of those avatars who are in the same region, but have not attempted to teleport).
C. The 'failed teleporting avatar' can not cross border into neighbor region, (but avatars who have not attempted to teleport can cross border).
5. Only cure for this condition is viewer client Re-Log.
Steps To Reproduce1. Start in a home region on a grid.
2. Repeatedly try to teleport to various other non-neighbor regions.
3. If teleport succeeds, try teleporting to another region until it fails.
4. After a random time, a teleport will fail.
5. From that point on, all your teleports to any destination will fail.
6. The only cure is Re-Log.
Additional Information"Could not teleport. Problems connecting to destination."

TESTED/REPRODUCED WITH VIEWERS:
1) Imprudence 1.4.0 beta 2 (Sep 23 2011 20:58:56)
2) Phoenix Viewer 1.5.1 (373) Oct 3 2010 01:26:22

OpenSim 0.7.2 Dev (Unix/Mono)

===============CONSOLE LOG========================

2011-11-10 16:14:58,587 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Pack data
2011-11-10 16:15:31,312 WARN - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferModule [ENTITY TRANSFER MODULE]: Teleport of Lani Global to The Higs Dreamscape failed due to no callback from destination region. Returning avatar to source region.
2011-11-10 16:25:08,948 ERROR - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer [LLUDPSERVER]: Client packet handler for 0fe3c770-2615-eb6a-fd58-0090846ce24e for packet MapItemRequest threw an exception
2011-11-10 16:25:08,949 ERROR - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer Object reference not set to an instance of an object
System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.HandleMapItemRequest (IClientAPI remoteClient, UInt32 flags, UInt32 EstateID, Boolean godlike, UInt32 itemtype, UInt64 regionhandle) [0x00000] in :0
  at (wrapper delegate-invoke) :invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleMapItemRequest (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in :0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessPacketMethod (OpenMetaverse.Packets.Packet packet) [0x00000] in :0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket (OpenMetaverse.Packets.Packet packet) [0x00000] in :0
  at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.ProcessInPacket (System.Object state) [0x00000] in :0
2011-11-10 16:25:12,903 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Pack data
2011-11-10 16:25:45,291 WARN - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferModule [ENTITY TRANSFER MODULE]: Teleport of Lani Global to The Higs Dreamscape failed due to no callback from destination region. Returning avatar to source region.
2011-11-10 16:30:56,270 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Pack data
2011-11-10 16:31:27,475 WARN - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferModule [ENTITY TRANSFER MODULE]: Teleport of Lani Global to Transgenia failed due to no callback from destination region. Returning avatar to source region.
2011-11-10 16:34:56,212 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Pack data
TagsNo tags attached.
Git Revision or version numberOpenSim 0.7.2 Dev 2b2580e3a12d5c493f9a77bf9435ca32a0a0355c - 16773 (Unix/Mono)
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentMono / Linux32
Mono VersionOther
ViewerImprudence 1.4.0 beta 2
Attached Files

- Relationships
related to 0005840closedjustincc Teleports sometimes fail forcing a relog 

-  Notes
(0020350)
LaniGlobal (reporter)
2011-11-13 20:40

Region crossing error after teleport fail.
(0023695)
justincc (administrator)
2013-03-25 16:32

I know this is a very old bug but please try git master 128c72a. I have checked out various teleport failure scenarios and very few disable the avatar completely, and none in the way described.
(0025277)
LaniGlobal (reporter)
2014-02-22 13:26

This appears to have been fixed by 0.8.0 or prior to it.

- Issue History
Date Modified Username Field Change
2011-11-10 17:20 LaniGlobal New Issue
2011-11-13 20:40 LaniGlobal Note Added: 0020350
2011-11-13 20:40 LaniGlobal Description Updated View Revisions
2012-01-06 23:20 LaniGlobal Relationship added related to 0005840
2013-03-25 16:32 justincc Note Added: 0023695
2014-02-22 13:26 LaniGlobal Note Added: 0025277
2014-02-22 13:26 LaniGlobal Status new => resolved
2014-02-22 13:26 LaniGlobal Fixed in Version => master (dev code)
2014-02-22 13:26 LaniGlobal Resolution open => fixed
2014-02-22 13:26 LaniGlobal Assigned To => LaniGlobal
2014-02-24 12:30 justincc Status resolved => closed
2014-02-24 12:30 justincc Assigned To LaniGlobal =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker