Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005740opensim[REGION] Specific OpenSim Modulepublic2011-10-12 00:502011-11-26 15:52
Reportermmetzmac 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005740: Error from Freeswitch Module
DescriptionI get the following Error during startup of a Region, connected to a Robust Service:

2011-10-12 09:35:24,906 DEBUG - OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPlugin [REGIONMODULES]: Found shared region module FreeSwitchVoiceModule, class OpenSim.Region.OptionalModules.Avatar.Voice.FreeSwitchVoice.FreeSwitchVoiceModule
2011-10-12 09:35:24,957 DEBUG - OpenSim.Services.Connectors.RemoteFreeswitchConnector [FREESWITCH CONNECTOR]: Requesting config from http://grid.secondlearning.de:8002/fsapi/region-config [^]
2011-10-12 09:35:25,540 ERROR - OpenSim.Region.OptionalModules.Avatar.Voice.FreeSwitchVoice.FreeSwitchVoiceModule [FreeSwitchVoice]: plugin initialization failed: Cannot cast from source type to destination type. at OpenSim.Region.OptionalModules.Avatar.Voice.FreeSwitchVoice.FreeSwitchVoiceModule.Initialise (IConfigSource config) [0x00000] in <filename unknown>:0
2011-10-12 09:35:27,331 DEBUG - OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPlugin [REGIONMODULE]: Adding scene SecondLearningGate to shared module FreeSwitchVoiceModule

I Have Robust, mod_curl_xml and OpenSim.ini modified, as shown in the opensim-freeswitch wiki. As up to version 0.7.1.1-Rel this configuration also ran fine.

Up from now, no Voice is possible.
TagsNo tags attached.
Git Revision or version number0.7.2-Release
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono Version2.10.2
ViewerAll 1.3.x
Attached Files

- Relationships

-  Notes
(0020140)
mmetzmac (reporter)
2011-10-12 02:25

just one addition: it seems, that the port for freeswitch service was changed in the 0.7.2 ... from initially 8002 (all 0.7.1 releases) to 8004. Means in fact, that also mod_xml_curl mus be adjusted to the new port. As doing this, the configuration does not work for me. My login ID points to port 8002, therfore I've changed my configuration in robust.ini (ServiceConnectors), opensim.ini (http://IPAddress:8002/fsapi [^]) and in mod_xml_curl (http://IPAddress:8002/fsapi/freeswitch-config [^]) to the old 8002 values. As most people have not opened Port 8004 on the Firewall (it was not needed in previouse releases), I would suggest to stick on the old values.
(0020398)
svetoslav80 (reporter)
2011-11-26 15:50

I have the same problem and have no idea what to do.

- Issue History
Date Modified Username Field Change
2011-10-12 00:50 mmetzmac New Issue
2011-10-12 00:50 mmetzmac Git Revision => 0.7.2-Release
2011-10-12 00:50 mmetzmac Run Mode => Grid (1 Region per Sim)
2011-10-12 00:50 mmetzmac Physics Engine => ODE
2011-10-12 00:50 mmetzmac Environment => Mono / Linux64
2011-10-12 00:50 mmetzmac Mono Version => 2.10.2
2011-10-12 00:50 mmetzmac Viewer => All 1.3.x
2011-10-12 02:25 mmetzmac Note Added: 0020140
2011-11-26 15:50 svetoslav80 Note Added: 0020398


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker